summaryrefslogtreecommitdiff
path: root/sys-libs/musl
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2015-09-08 15:50:14 -0400
committerAnthony G. Basile <blueness@gentoo.org>2015-09-08 15:50:29 -0400
commit2a098330a77d2daec0f55e838782805ef4cd3de3 (patch)
treef90dc945cb225849b1c7fefe3b95e98f76bd5d88 /sys-libs/musl
parentb3465584075bcdc89e1b94e52751f458e868174e (diff)
downloadgentoo-2a098330a77d2daec0f55e838782805ef4cd3de3.tar.gz
gentoo-2a098330a77d2daec0f55e838782805ef4cd3de3.tar.xz
sys-libs/musl: add fix for codeset.
See http://www.openwall.com/lists/musl/2015/09/01/3 Package-Manager: portage-2.2.20.1
Diffstat (limited to 'sys-libs/musl')
-rw-r--r--sys-libs/musl/files/musl-1.1.11-fix-codeset.patch12
-rw-r--r--sys-libs/musl/musl-1.1.11-r1.ebuild129
2 files changed, 141 insertions, 0 deletions
diff --git a/sys-libs/musl/files/musl-1.1.11-fix-codeset.patch b/sys-libs/musl/files/musl-1.1.11-fix-codeset.patch
new file mode 100644
index 00000000000..e846f5f32a7
--- /dev/null
+++ b/sys-libs/musl/files/musl-1.1.11-fix-codeset.patch
@@ -0,0 +1,12 @@
+diff -Naur musl-1.1.11.orig/src/locale/langinfo.c musl-1.1.11/src/locale/langinfo.c
+--- musl-1.1.11.orig/src/locale/langinfo.c 2015-08-30 00:15:56.000000000 -0400
++++ musl-1.1.11/src/locale/langinfo.c 2015-09-08 15:46:26.717980251 -0400
+@@ -34,7 +34,7 @@
+ const char *str;
+
+ if (item == CODESET)
+- return MB_CUR_MAX==1 ? "UTF-8-CODE-UNITS" : "UTF-8";
++ return "UTF-8";
+
+ switch (cat) {
+ case LC_NUMERIC:
diff --git a/sys-libs/musl/musl-1.1.11-r1.ebuild b/sys-libs/musl/musl-1.1.11-r1.ebuild
new file mode 100644
index 00000000000..011baca9048
--- /dev/null
+++ b/sys-libs/musl/musl-1.1.11-r1.ebuild
@@ -0,0 +1,129 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils flag-o-matic multilib toolchain-funcs
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://git.musl-libc.org/musl"
+ inherit git-2
+fi
+
+export CBUILD=${CBUILD:-${CHOST}}
+export CTARGET=${CTARGET:-${CHOST}}
+if [[ ${CTARGET} == ${CHOST} ]] ; then
+ if [[ ${CATEGORY} == cross-* ]] ; then
+ export CTARGET=${CATEGORY#cross-}
+ fi
+fi
+
+DESCRIPTION="Lightweight, fast and simple C library focused on standards-conformance and safety"
+HOMEPAGE="http://www.musl-libc.org/"
+if [[ ${PV} != "9999" ]] ; then
+ PATCH_VER=""
+ SRC_URI="http://www.musl-libc.org/releases/${P}.tar.gz"
+ KEYWORDS="-* ~amd64 ~arm ~mips ~ppc ~x86"
+fi
+
+LICENSE="MIT LGPL-2 GPL-2"
+SLOT="0"
+IUSE="crosscompile_opts_headers-only"
+
+RDEPEND="!sys-apps/getent"
+
+is_crosscompile() {
+ [[ ${CHOST} != ${CTARGET} ]]
+}
+
+just_headers() {
+ use crosscompile_opts_headers-only && is_crosscompile
+}
+
+musl_endian() {
+ # XXX: this wont work for bi-endian, but we dont have any
+ touch "${T}"/endian.s
+ $(tc-getAS ${CTARGET}) "${T}"/endian.s -o "${T}"/endian.o
+ case $(file "${T}"/endian.o) in
+ *" MSB "*) echo "";;
+ *" LSB "*) echo "el";;
+ *) echo "nfc";; # We shouldn't be here
+ esac
+}
+
+pkg_setup() {
+ if [ ${CTARGET} == ${CHOST} ] ; then
+ case ${CHOST} in
+ *-musl*) ;;
+ *) die "Use sys-devel/crossdev to build a musl toolchain" ;;
+ esac
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-fix-codeset.patch
+ epatch_user
+}
+
+src_configure() {
+ tc-getCC ${CTARGET}
+ just_headers && export CC=true
+
+ local sysroot
+ is_crosscompile && sysroot=/usr/${CTARGET}
+ ./configure \
+ --target=${CTARGET} \
+ --prefix=${sysroot}/usr \
+ --syslibdir=${sysroot}/lib \
+ --disable-gcc-wrapper
+}
+
+src_compile() {
+ emake include/bits/alltypes.h || die
+ just_headers && return 0
+
+ emake || die
+}
+
+src_install() {
+ local target="install"
+ just_headers && target="install-headers"
+ emake DESTDIR="${D}" ${target} || die
+ just_headers && return 0
+
+ # musl provides ldd via a sym link to its ld.so
+ local sysroot
+ is_crosscompile && sysroot=/usr/${CTARGET}
+ local ldso=$(basename "${D}"${sysroot}/lib/ld-musl-*)
+ dosym ${sysroot}/lib/${ldso} ${sysroot}/usr/bin/ldd
+
+ if [[ ${CATEGORY} != cross-* ]] ; then
+ local target=$(tc-arch) arch
+ local endian=$(musl_endian)
+ case ${target} in
+ amd64) arch="x86_64";;
+ arm) arch="armhf";; # We only have hardfloat right now
+ mips) arch="mips${endian}";;
+ ppc) arch="powerpc";;
+ x86) arch="i386";;
+ esac
+ cp "${FILESDIR}"/ldconfig.in "${T}"
+ sed -e "s|@@ARCH@@|${arch}|" "${T}"/ldconfig.in > "${T}"/ldconfig
+ into /
+ dosbin "${T}"/ldconfig
+ into /usr
+ dobin "${FILESDIR}"/getent
+ echo 'LDPATH="include ld.so.conf.d/*.conf"' > "${T}"/00musl
+ doenvd "${T}"/00musl || die
+ fi
+}
+
+pkg_postinst() {
+ is_crosscompile && return 0
+
+ [ "${ROOT}" != "/" ] && return 0
+
+ ldconfig
+ # reload init ...
+ /sbin/telinit U 2>/dev/null
+}