summaryrefslogtreecommitdiff
path: root/sys-libs/pwdb/pwdb-0.62.ebuild
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-libs/pwdb/pwdb-0.62.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-libs/pwdb/pwdb-0.62.ebuild')
-rw-r--r--sys-libs/pwdb/pwdb-0.62.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/sys-libs/pwdb/pwdb-0.62.ebuild b/sys-libs/pwdb/pwdb-0.62.ebuild
new file mode 100644
index 00000000000..8a7725c27a9
--- /dev/null
+++ b/sys-libs/pwdb/pwdb-0.62.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="Password database"
+HOMEPAGE="http://packages.gentoo.org/package/sys-libs/pwdb"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="|| ( BSD GPL-2 )"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
+IUSE="selinux"
+RESTRICT="test" #122603
+
+# Note: NIS could probably be made conditional if anyone cared ...
+RDEPEND="selinux? ( sys-libs/libselinux )
+ net-libs/libtirpc"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-build.patch
+
+ use selinux && epatch "${FILESDIR}"/${P}-selinux.patch
+
+ append-cppflags $($(tc-getPKG_CONFIG) --cflags libtirpc)
+ export LDLIBS=$($(tc-getPKG_CONFIG) --libs libtirpc)
+
+ sed -i \
+ -e "s/^DIRS = .*/DIRS = libpwdb/" \
+ -e "s:EXTRAS += :EXTRAS += ${CFLAGS} :" \
+ Makefile || die
+ sed -i \
+ -e "s:=gcc:=$(tc-getCC):g" \
+ -e "s:=ar:=$(tc-getAR):g" \
+ -e "s:=ranlib:=$(tc-getRANLIB):g" \
+ default.defs || die
+}
+
+src_install() {
+ dodir /usr/$(get_libdir) /usr/include/pwdb
+ emake \
+ INCLUDED="${D}"/usr/include/pwdb \
+ LIBDIR="${D}"/usr/$(get_libdir) \
+ LDCONFIG="echo" \
+ install
+
+ gen_usr_ldscript -a pwdb
+
+ insinto /etc
+ doins conf/pwdb.conf
+
+ dodoc CHANGES CREDITS README doc/*.txt
+ dohtml -r doc/html/*
+}