summaryrefslogtreecommitdiff
path: root/sys-libs
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2017-09-30 11:24:50 +0200
committerPacho Ramos <pacho@gentoo.org>2017-09-30 11:24:50 +0200
commit8c950f9ec687e00d48056c25c87a63a7539a1764 (patch)
tree03a7886c9e521c10f8edbb3bdab19e4ee4053683 /sys-libs
parentb025a480e0a931502773b7aa53834c75e1ec16e3 (diff)
downloadgentoo-8c950f9ec687e00d48056c25c87a63a7539a1764.tar.gz
gentoo-8c950f9ec687e00d48056c25c87a63a7539a1764.tar.xz
sys-libs/libieee1284: python needs to be handled for both arches in multilib (#619810)
Package-Manager: Portage-2.3.10, Repoman-2.3.3
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libieee1284/libieee1284-0.2.11-r5.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/sys-libs/libieee1284/libieee1284-0.2.11-r5.ebuild b/sys-libs/libieee1284/libieee1284-0.2.11-r5.ebuild
new file mode 100644
index 00000000000..5fff2c1ba2e
--- /dev/null
+++ b/sys-libs/libieee1284/libieee1284-0.2.11-r5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1 multilib-minimal
+
+DESCRIPTION="Library to query devices using IEEE1284"
+HOMEPAGE="http://cyberelk.net/tim/libieee1284/index.html"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="doc python static-libs"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}
+ doc? (
+ app-text/docbook-sgml-utils
+ >=app-text/docbook-sgml-dtd-4.1
+ app-text/docbook-dsssl-stylesheets
+ dev-perl/XML-RegExp
+ )"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ --enable-shared \
+ $(use_enable static-libs static) \
+ $(use_with python)
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ dodoc doc/interface*
+
+ if ! use static-libs; then
+ find "${D}" -name '*.la' -delete || die
+ fi
+}