summaryrefslogtreecommitdiff
path: root/sys-libs
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2016-06-04 20:40:47 -0400
committerAnthony G. Basile <blueness@gentoo.org>2016-06-04 20:40:47 -0400
commit980e1b634d138ee9b711866abdecf11b51d4cbde (patch)
treed928f1bc3bd4bc3b8d559511ed3b8c84f32830a3 /sys-libs
parent9188802088bd9616e71d23dce350f5a278b6f686 (diff)
downloadgentoo-980e1b634d138ee9b711866abdecf11b51d4cbde.tar.gz
gentoo-980e1b634d138ee9b711866abdecf11b51d4cbde.tar.xz
sys-libs/musl: add TODO comment wrt obtaining arch name
Package-Manager: portage-2.2.28
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/musl/musl-9999.ebuild2
1 files changed, 2 insertions, 0 deletions
diff --git a/sys-libs/musl/musl-9999.ebuild b/sys-libs/musl/musl-9999.ebuild
index bf1ebe9fc03..3c6e9c8b6a1 100644
--- a/sys-libs/musl/musl-9999.ebuild
+++ b/sys-libs/musl/musl-9999.ebuild
@@ -102,6 +102,8 @@ src_install() {
dosym ${sysroot}/lib/${ldso} ${sysroot}/usr/bin/ldd
if [[ ${CATEGORY} != cross-* ]] ; then
+ # TODO: We may be able to simplify this code by obtianing the arch name with
+ # /usr/lib/libc.so 2>&1 | sed -n 's/^.*(\(.*\))$/\1/;1p'
local target=$(tc-arch) arch
local endian=$(musl_endian)
case ${target} in