summaryrefslogtreecommitdiff
path: root/sys-process/pkill-darwin
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-process/pkill-darwin
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-process/pkill-darwin')
-rw-r--r--sys-process/pkill-darwin/Manifest1
-rw-r--r--sys-process/pkill-darwin/metadata.xml5
-rw-r--r--sys-process/pkill-darwin/pkill-darwin-1.0.ebuild39
3 files changed, 45 insertions, 0 deletions
diff --git a/sys-process/pkill-darwin/Manifest b/sys-process/pkill-darwin/Manifest
new file mode 100644
index 00000000000..09a21212b57
--- /dev/null
+++ b/sys-process/pkill-darwin/Manifest
@@ -0,0 +1 @@
+DIST pkill-darwin-1.0.tar.xz 8232 RMD160 58ba7aee0730da2c3af521471f6d6ff103f464a6 SHA1 ba7a407f4315d556d767ed8329cc0de2252e9742 SHA256 a1adc263e6685d210397b8fc186b6856730b8a075aef987cee593e8cf7241e4f
diff --git a/sys-process/pkill-darwin/metadata.xml b/sys-process/pkill-darwin/metadata.xml
new file mode 100644
index 00000000000..f737f232e3b
--- /dev/null
+++ b/sys-process/pkill-darwin/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>prefix</herd>
+</pkgmetadata>
diff --git a/sys-process/pkill-darwin/pkill-darwin-1.0.ebuild b/sys-process/pkill-darwin/pkill-darwin-1.0.ebuild
new file mode 100644
index 00000000000..bc0f538d18f
--- /dev/null
+++ b/sys-process/pkill-darwin/pkill-darwin-1.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+inherit toolchain-funcs
+
+DESCRIPTION="pgrep(1) and pkill(1) for Darwin"
+HOMEPAGE="http://prefix.gentooexperimental.org:8000/pkill-darwin/"
+SRC_URI="http://www.gentoo.org/~grobian/distfiles/${P}.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~ppc-macos ~x86-macos ~x64-macos"
+IUSE=""
+
+src_compile() {
+ echo $(tc-getCC) ${CFLAGS} -o pkill ${LDFLAGS} pkill.c
+ $(tc-getCC) ${CFLAGS} -o pkill ${LDFLAGS} pkill.c || die
+ # don't link, such that the suid trick described below won't make people
+ # suid their pkill too
+ cp pkill pgrep || die
+ ln -s pkill.1 pgrep.1 || die
+}
+
+src_install() {
+ into /usr
+ dobin pkill pgrep
+ doman pkill.1 pgrep.1
+}
+
+pkg_postinst() {
+ einfo "If you you want pgrep to be able to show and match on the arguments"
+ einfo "of all processes, you will have to make pgrep suid root. To do so"
+ einfo "you have to perform the following steps:"
+ einfo " % sudo chown root ${EPREFIX}/usr/bin/pgrep"
+ einfo " % sudo chmod u+s ${EPREFIX}/usr/bin/prgep"
+}