summaryrefslogtreecommitdiff
path: root/www-apache/mod_auth_openid
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-apache/mod_auth_openid
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-apache/mod_auth_openid')
-rw-r--r--www-apache/mod_auth_openid/Manifest1
-rw-r--r--www-apache/mod_auth_openid/files/10_mod_auth_openid.conf5
-rw-r--r--www-apache/mod_auth_openid/metadata.xml10
-rw-r--r--www-apache/mod_auth_openid/mod_auth_openid-0.8.ebuild39
4 files changed, 55 insertions, 0 deletions
diff --git a/www-apache/mod_auth_openid/Manifest b/www-apache/mod_auth_openid/Manifest
new file mode 100644
index 00000000000..010709f8fd8
--- /dev/null
+++ b/www-apache/mod_auth_openid/Manifest
@@ -0,0 +1 @@
+DIST mod_auth_openid-0.8.tar.gz 355531 SHA256 86812c9659e2b36b3d2cac98cdcb97d743d08ca76120159f20cc77800947445a SHA512 3994585fa26c42fde8ab76992c62c8a486316bd418bc2eac65e1390bbcd87e3b96fc1b58cb3645e749cb0cfc74811bb5035bc014f0b95bf6f037ec9f5c0ac7e2 WHIRLPOOL 3963b743735b0557503b186d8d0b1d2d35e6b6554bb155a1e595d512e93a84ea28123b1fa3ef2d493f4e8bddbe9fd141f68fdc72d31200fed5d601dd7ba20eb0
diff --git a/www-apache/mod_auth_openid/files/10_mod_auth_openid.conf b/www-apache/mod_auth_openid/files/10_mod_auth_openid.conf
new file mode 100644
index 00000000000..2364dc36b3e
--- /dev/null
+++ b/www-apache/mod_auth_openid/files/10_mod_auth_openid.conf
@@ -0,0 +1,5 @@
+<IfDefine AUTH_OPENID>
+LoadModule authopenid_module modules/mod_auth_openid.so
+</IfDefine>
+
+# vim: ts=4 filetype=apache
diff --git a/www-apache/mod_auth_openid/metadata.xml b/www-apache/mod_auth_openid/metadata.xml
new file mode 100644
index 00000000000..42650fd9cd1
--- /dev/null
+++ b/www-apache/mod_auth_openid/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">bmuller/mod_auth_openid</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/www-apache/mod_auth_openid/mod_auth_openid-0.8.ebuild b/www-apache/mod_auth_openid/mod_auth_openid-0.8.ebuild
new file mode 100644
index 00000000000..8caec457bcd
--- /dev/null
+++ b/www-apache/mod_auth_openid/mod_auth_openid-0.8.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit apache-module
+
+DESCRIPTION="An OpenID authentication module for the apache webserver"
+HOMEPAGE="http://findingscience.com/mod_auth_openid/"
+SRC_URI="https://github.com/bmuller/mod_auth_openid/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-db/sqlite-3
+ dev-libs/libpcre
+ >=net-libs/libopkele-2.0
+ net-misc/curl"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+APACHE2_MOD_CONF="10_${PN}"
+APACHE2_MOD_DEFINE="AUTH_OPENID"
+
+need_apache2
+
+src_configure() {
+ econf --with-apxs="${APXS}" \
+ --with-sqlite3=/usr \
+ --with-apr-config=/usr/bin/apr-1-config
+}
+
+src_compile() {
+ # default src_compile fails
+ emake
+}