summaryrefslogtreecommitdiff
path: root/www-apps/cvsweb
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-apps/cvsweb
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-apps/cvsweb')
-rw-r--r--www-apps/cvsweb/Manifest3
-rw-r--r--www-apps/cvsweb/cvsweb-1.112.ebuild37
-rw-r--r--www-apps/cvsweb/cvsweb-3.0.5.ebuild39
-rw-r--r--www-apps/cvsweb/cvsweb-3.0.6-r1.ebuild45
-rw-r--r--www-apps/cvsweb/cvsweb-3.0.6.ebuild39
-rw-r--r--www-apps/cvsweb/files/cvsweb-3.0.6-perl518.patch25
-rw-r--r--www-apps/cvsweb/files/postinstall-en.txt1
-rw-r--r--www-apps/cvsweb/files/reconfig15
-rw-r--r--www-apps/cvsweb/metadata.xml5
9 files changed, 209 insertions, 0 deletions
diff --git a/www-apps/cvsweb/Manifest b/www-apps/cvsweb/Manifest
new file mode 100644
index 00000000000..3e3f7554768
--- /dev/null
+++ b/www-apps/cvsweb/Manifest
@@ -0,0 +1,3 @@
+DIST cvsweb-1.112.tar.gz 37239 SHA256 55656465590231d8ead238cb2b7def59a9f00ad5f126176c15f2a9e340812fa4
+DIST cvsweb-3.0.5.tar.gz 72199 SHA256 ab1acebde0b4f2c75932bab529150c8280cf881deba81323d71733d81c28643c
+DIST cvsweb-3.0.6.tar.gz 72484 SHA256 07391ee70212ae42e54b8f6d5e613623ef2aad5fd7474899a102fcca48d213c2 SHA512 32ac58bcb025746e4cc20bdc12d1bd915e2286a4093afebf8d60cb94a70ac614301f9b7f0a175458b14262a03d3d2eb8c29eabaf9127bef1aa6847905f331cc6 WHIRLPOOL becd4a96f21b178595be2083f8117e84b6203508fca09a9a74891cc324f8086b6a2b273eabfbb50301864a0f5f53a84374f7e3e0c9a1a32b0e7bd08a1a60aaa3
diff --git a/www-apps/cvsweb/cvsweb-1.112.ebuild b/www-apps/cvsweb/cvsweb-1.112.ebuild
new file mode 100644
index 00000000000..bbe5cb1d285
--- /dev/null
+++ b/www-apps/cvsweb/cvsweb-1.112.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="WWW interface to a CVS tree"
+HOMEPAGE="http://www.freebsd.org/projects/cvsweb.html"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="x86 sparc ~ppc"
+IUSE=""
+
+RDEPEND=">=dev-lang/perl-5
+ >=dev-vcs/rcs-5.7"
+
+S="${WORKDIR}/cvsweb"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd "${S}"
+ local x
+ for x in cvsweb.cgi cvsweb.conf
+ do
+ cp ${x} ${x}.orig
+ sed -e "s:/usr/local/web/apache/conf/:/etc/apache/conf/:g" ${x}.orig > ${x}
+ done
+}
+
+src_install() {
+ insinto /etc/apache/conf
+ doins cvsweb.conf
+ insinto /home/httpd/cgi-bin
+ insopts -m755
+ doins cvsweb.cgi
+ dodoc README TODO
+}
diff --git a/www-apps/cvsweb/cvsweb-3.0.5.ebuild b/www-apps/cvsweb/cvsweb-3.0.5.ebuild
new file mode 100644
index 00000000000..2360c73001b
--- /dev/null
+++ b/www-apps/cvsweb/cvsweb-3.0.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit webapp
+
+DESCRIPTION="WWW interface to a CVS tree"
+HOMEPAGE="http://www.freebsd.org/projects/cvsweb.html"
+SRC_URI="ftp://ftp.freebsd.org/pub/FreeBSD/ports/local-distfiles/scop/${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~x86 ~sparc ~ppc"
+IUSE=""
+
+RDEPEND=">=dev-lang/perl-5.8
+ >=dev-vcs/cvs-1.11
+ >=dev-vcs/rcs-5.7
+ >=dev-perl/URI-1.28
+ dev-perl/IPC-Run
+ dev-perl/MIME-Types
+ dev-perl/String-Ediff
+ >=dev-vcs/cvsgraph-1.4.0
+ >=app-text/enscript-1.6.3"
+
+src_install() {
+ webapp_src_preinst
+
+ cp cvsweb.conf "${D}"/${MY_HOSTROOTDIR}
+ cp css/cvsweb.css "${D}"/${MY_HTDOCSDIR}
+ exeinto ${MY_CGIBINDIR}
+ doexe cvsweb.cgi
+ chmod +x "${D}"/${MY_CGIBINDIR}/cvsweb.cgi
+
+ dodoc README TODO NEWS ChangeLog
+
+ webapp_hook_script "${FILESDIR}"/reconfig
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_src_install
+}
diff --git a/www-apps/cvsweb/cvsweb-3.0.6-r1.ebuild b/www-apps/cvsweb/cvsweb-3.0.6-r1.ebuild
new file mode 100644
index 00000000000..3ca81647a82
--- /dev/null
+++ b/www-apps/cvsweb/cvsweb-3.0.6-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils webapp
+
+DESCRIPTION="WWW interface to a CVS tree"
+HOMEPAGE="http://www.freebsd.org/projects/cvsweb.html"
+SRC_URI="ftp://ftp.freebsd.org/pub/FreeBSD/ports/local-distfiles/scop/${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~ppc sparc x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/perl-5.8
+ >=dev-vcs/cvs-1.11
+ >=dev-vcs/rcs-5.7
+ >=dev-perl/URI-1.28
+ dev-perl/IPC-Run
+ dev-perl/MIME-Types
+ dev-perl/String-Ediff
+ >=dev-vcs/cvsgraph-1.4.0
+ >=app-text/enscript-1.6.3"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-perl518.patch"
+}
+
+src_install() {
+ webapp_src_preinst
+
+ cp cvsweb.conf "${D}"/${MY_HOSTROOTDIR}
+ cp css/cvsweb.css "${D}"/${MY_HTDOCSDIR}
+ exeinto ${MY_CGIBINDIR}
+ doexe cvsweb.cgi
+ chmod +x "${D}"/${MY_CGIBINDIR}/cvsweb.cgi
+
+ dodoc README TODO NEWS ChangeLog
+
+ webapp_hook_script "${FILESDIR}"/reconfig
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_src_install
+}
diff --git a/www-apps/cvsweb/cvsweb-3.0.6.ebuild b/www-apps/cvsweb/cvsweb-3.0.6.ebuild
new file mode 100644
index 00000000000..2c4cb5062f0
--- /dev/null
+++ b/www-apps/cvsweb/cvsweb-3.0.6.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit webapp
+
+DESCRIPTION="WWW interface to a CVS tree"
+HOMEPAGE="http://www.freebsd.org/projects/cvsweb.html"
+SRC_URI="ftp://ftp.freebsd.org/pub/FreeBSD/ports/local-distfiles/scop/${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~ppc sparc x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/perl-5.8
+ >=dev-vcs/cvs-1.11
+ >=dev-vcs/rcs-5.7
+ >=dev-perl/URI-1.28
+ dev-perl/IPC-Run
+ dev-perl/MIME-Types
+ dev-perl/String-Ediff
+ >=dev-vcs/cvsgraph-1.4.0
+ >=app-text/enscript-1.6.3"
+
+src_install() {
+ webapp_src_preinst
+
+ cp cvsweb.conf "${D}"/${MY_HOSTROOTDIR}
+ cp css/cvsweb.css "${D}"/${MY_HTDOCSDIR}
+ exeinto ${MY_CGIBINDIR}
+ doexe cvsweb.cgi
+ chmod +x "${D}"/${MY_CGIBINDIR}/cvsweb.cgi
+
+ dodoc README TODO NEWS ChangeLog
+
+ webapp_hook_script "${FILESDIR}"/reconfig
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_src_install
+}
diff --git a/www-apps/cvsweb/files/cvsweb-3.0.6-perl518.patch b/www-apps/cvsweb/files/cvsweb-3.0.6-perl518.patch
new file mode 100644
index 00000000000..ba1195ae916
--- /dev/null
+++ b/www-apps/cvsweb/files/cvsweb-3.0.6-perl518.patch
@@ -0,0 +1,25 @@
+Source:
+http://cvsweb.netbsd.org/bsdweb.cgi/pkgsrc/www/cvsweb/patches/patch-cvsweb.cgi.diff?r1=1.1.2.1&r2=1.1.2.2&f=h
+
+Fix warnings from newer perl versions
+
+--- cvsweb.cgi.orig 2013-07-30 12:49:33.268655300 +0000
++++ cvsweb.cgi
+@@ -1192,7 +1192,7 @@ EOF
+ <legend>General options</legend>
+ <input type="hidden" name="copt" value="1" />
+ EOF
+- for my $v qw(hidecvsroot hidenonreadable) {
++ for my $v (qw(hidecvsroot hidenonreadable)) {
+ printf(qq{<input type="hidden" name="%s" value="%s" />\n},
+ $v, $input{$v} || 0);
+ }
+@@ -2951,7 +2951,7 @@ sub printLog($$$;$$)
+ print "<br />\n";
+
+ print '<i>';
+- if (defined @mytz) {
++ if (@mytz) {
+ my ($est) = $mytz[(localtime($date{$_}))[8]];
+ print scalar localtime($date{$_}), " $est</i> (";
+ } else {
diff --git a/www-apps/cvsweb/files/postinstall-en.txt b/www-apps/cvsweb/files/postinstall-en.txt
new file mode 100644
index 00000000000..e6e1dbf1e54
--- /dev/null
+++ b/www-apps/cvsweb/files/postinstall-en.txt
@@ -0,0 +1 @@
+Now edit ${VHOST_ROOT}/cvsweb.conf
diff --git a/www-apps/cvsweb/files/reconfig b/www-apps/cvsweb/files/reconfig
new file mode 100644
index 00000000000..10767108f1a
--- /dev/null
+++ b/www-apps/cvsweb/files/reconfig
@@ -0,0 +1,15 @@
+#!/bin/bash
+
+die() {
+ echo "#####"
+ echo $1
+ echo "#####"
+ exit 1
+}
+
+if [ $1 = "install" ]; then
+ sed "s|/usr/local/etc/cvsweb/cvsweb.conf|${VHOST_ROOT}/cvsweb.conf|g
+ s|/usr/local/etc/cvsweb|${VHOST_ROOT}|g
+ s|/css/cvsweb.css|/cvsweb.css|g
+ s|/usr/local/etc/apache/mime.types|/etc/mime.types|g" -i ${VHOST_ROOT}/cgi-bin/cvsweb.cgi ${VHOST_ROOT}/cvsweb.conf || die "sed failed"
+fi
diff --git a/www-apps/cvsweb/metadata.xml b/www-apps/cvsweb/metadata.xml
new file mode 100644
index 00000000000..95c06f0095b
--- /dev/null
+++ b/www-apps/cvsweb/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>web-apps</herd>
+</pkgmetadata>