summaryrefslogtreecommitdiff
path: root/www-apps/dotproject
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-apps/dotproject
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-apps/dotproject')
-rw-r--r--www-apps/dotproject/Manifest1
-rw-r--r--www-apps/dotproject/dotproject-2.1.7-r1.ebuild46
-rw-r--r--www-apps/dotproject/files/dotproject-2.1.7-pear-date.patch39
-rw-r--r--www-apps/dotproject/files/install-en.txt17
-rw-r--r--www-apps/dotproject/metadata.xml8
5 files changed, 111 insertions, 0 deletions
diff --git a/www-apps/dotproject/Manifest b/www-apps/dotproject/Manifest
new file mode 100644
index 00000000000..9d05468161d
--- /dev/null
+++ b/www-apps/dotproject/Manifest
@@ -0,0 +1 @@
+DIST dotproject-2.1.7.tar.gz 4528969 SHA256 1c55e2bfa50f543c4f6fb877870fa99ffe2abb3971aa8ab53c03b25a578a9a74 SHA512 887637d8b66096ca0313dd257de44f2afef587c795cb8009861698f799db4e09677f6cd7e5ee57d3655e81219e25257c379deafac77003bf7e6f82e70eef8f58 WHIRLPOOL ee158b755338e44148913765c58becca1394f1e0bd6218be7636949c64db26f9dfa0ae219d1aee77158e31d72290c68681146b44538bed79ae538bf48076a59e
diff --git a/www-apps/dotproject/dotproject-2.1.7-r1.ebuild b/www-apps/dotproject/dotproject-2.1.7-r1.ebuild
new file mode 100644
index 00000000000..16b1f6cb00b
--- /dev/null
+++ b/www-apps/dotproject/dotproject-2.1.7-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+inherit eutils webapp depend.php
+
+DESCRIPTION="dotProject is a PHP web-based project management framework"
+HOMEPAGE="http://www.dotproject.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+LICENSE="GPL-2"
+IUSE=""
+
+DEPEND=""
+RDEPEND="app-text/poppler[utils]
+ dev-php/PEAR-Date"
+
+need_httpd_cgi
+need_php_httpd
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-pear-date.patch"
+}
+
+src_install () {
+ webapp_src_preinst
+
+ dodoc ChangeLog README
+ rm -rf ChangeLog README lib/PEAR/Date.php lib/PEAR/Date
+
+ mv includes/config{-dist,}.php
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_serverowned "${MY_HTDOCSDIR}"/includes/config.php
+ webapp_serverowned "${MY_HTDOCSDIR}"/files{,/temp}
+ webapp_serverowned "${MY_HTDOCSDIR}"/locales/en
+
+ webapp_postinst_txt en "${FILESDIR}"/install-en.txt
+ webapp_src_install
+}
diff --git a/www-apps/dotproject/files/dotproject-2.1.7-pear-date.patch b/www-apps/dotproject/files/dotproject-2.1.7-pear-date.patch
new file mode 100644
index 00000000000..a907589f00e
--- /dev/null
+++ b/www-apps/dotproject/files/dotproject-2.1.7-pear-date.patch
@@ -0,0 +1,39 @@
+diff -u -r dotproject/classes/date.class.php dotproject-patched/classes/date.class.php
+--- dotproject/classes/date.class.php 2011-03-10 06:11:25.000000000 +0100
++++ dotproject-patched/classes/date.class.php 2013-01-03 12:35:36.598020904 +0100
+@@ -8,7 +8,8 @@
+ }
+
+
+-require_once $AppUI->getLibraryClass('PEAR/Date');
++#require_once $AppUI->getLibraryClass('PEAR/Date');
++require_once 'Date.php';
+
+ define('FMT_DATEISO', '%Y%m%dT%H%M%S');
+ define('FMT_DATELDAP', '%Y%m%d%H%M%SZ');
+diff -u -r dotproject/modules/calendar/calendar.class.php dotproject-patched/modules/calendar/calendar.class.php
+--- dotproject/modules/calendar/calendar.class.php 2012-06-19 11:05:19.000000000 +0200
++++ dotproject-patched/modules/calendar/calendar.class.php 2013-01-03 12:36:10.898019883 +0100
+@@ -7,7 +7,8 @@
+ ## Calendar classes
+ ##
+
+-require_once ($AppUI->getLibraryClass('PEAR/Date'));
++#require_once ($AppUI->getLibraryClass('PEAR/Date'));
++require_once 'Date.php';
+ require_once ($AppUI->getSystemClass ('dp'));
+ require_once $AppUI->getSystemClass('libmail');
+ require_once $AppUI->getSystemClass('date');
+diff -u -r dotproject/modules/projects/projects.class.php dotproject-patched/modules/projects/projects.class.php
+--- dotproject/modules/projects/projects.class.php 2011-06-20 13:07:49.000000000 +0200
++++ dotproject-patched/modules/projects/projects.class.php 2013-01-03 12:36:12.709019829 +0100
+@@ -10,7 +10,8 @@
+ */
+
+ require_once ($AppUI->getSystemClass ('dp'));
+-require_once ($AppUI->getLibraryClass('PEAR/Date'));
++#require_once ($AppUI->getLibraryClass('PEAR/Date'));
++require_once 'Date.php';
+ require_once ($AppUI->getModuleClass('tasks'));
+ require_once ($AppUI->getModuleClass('companies'));
+ require_once ($AppUI->getModuleClass('departments'));
diff --git a/www-apps/dotproject/files/install-en.txt b/www-apps/dotproject/files/install-en.txt
new file mode 100644
index 00000000000..049fdc4da7e
--- /dev/null
+++ b/www-apps/dotproject/files/install-en.txt
@@ -0,0 +1,17 @@
+You will need to provide a database for your dotproject installation.
+
+This assumes you have some knowledge of MySQL, and already have it
+installed and configured. If not, please refer to the Gentoo MySQL
+guide at the following URL:
+
+http://www.gentoo.org/doc/en/mysql-howto.xml
+
+Once you have a database ready all you need to do is to go to this
+location
+
+http://${VHOST_HOSTNAME}/${VHOST_APPDIR}/install
+
+and provide the credentials required for the database access.
+
+Note the administrator password dotproject will provide and after
+logging in with these credentials you can start to use the application.
diff --git a/www-apps/dotproject/metadata.xml b/www-apps/dotproject/metadata.xml
new file mode 100644
index 00000000000..bd5db4864e4
--- /dev/null
+++ b/www-apps/dotproject/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>web-apps</herd>
+ <upstream>
+ <remote-id type="sourceforge">dotproject</remote-id>
+ </upstream>
+</pkgmetadata>