summaryrefslogtreecommitdiff
path: root/www-apps/drupal/drupal-6.38.ebuild
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2016-02-25 02:05:28 -0100
committerJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2016-02-25 02:06:01 -0100
commitc64c78c46ee9688004522c80117c351fee5d3a47 (patch)
tree72499e2098cb1b4689b196396eabd2247f9efa13 /www-apps/drupal/drupal-6.38.ebuild
parent509202eb2bb13f4490e0083a9b4abe2cb0398e3f (diff)
downloadgentoo-c64c78c46ee9688004522c80117c351fee5d3a47.tar.gz
gentoo-c64c78c46ee9688004522c80117c351fee5d3a47.tar.xz
[www-apps/drupal] Security bump for releases 6.38, 7.43 and 8.0.4 - SA-CORE-2016-001.
Drop drupal-6 keywords as it has finally reached EoL. Signed-off-by: Jorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>
Diffstat (limited to 'www-apps/drupal/drupal-6.38.ebuild')
-rw-r--r--www-apps/drupal/drupal-6.38.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/www-apps/drupal/drupal-6.38.ebuild b/www-apps/drupal/drupal-6.38.ebuild
new file mode 100644
index 00000000000..b00d669e72f
--- /dev/null
+++ b/www-apps/drupal/drupal-6.38.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit webapp
+
+MY_PV=${PV:0:3}.0
+
+DESCRIPTION="PHP-based open-source platform and content management system"
+HOMEPAGE="http://drupal.org/"
+SRC_URI="http://drupal.org/files/projects/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS=""
+IUSE="+mysql postgres"
+
+RDEPEND="
+ dev-lang/php[gd,pdo,postgres?,xml]
+ virtual/httpd-php
+ mysql? (
+ || (
+ dev-lang/php[mysql]
+ dev-lang/php[mysqli]
+ )
+ )"
+
+need_httpd_cgi
+
+REQUIRED_USE="|| ( mysql postgres )"
+
+src_install() {
+ webapp_src_preinst
+
+ local docs="MAINTAINERS.txt LICENSE.txt INSTALL.txt CHANGELOG.txt INSTALL.mysql.txt INSTALL.pgsql.txt UPGRADE.txt "
+ dodoc ${docs}
+ rm -f ${docs} INSTALL COPYRIGHT.txt || die
+
+ cp sites/default/{default.settings.php,settings.php} || die
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ dodir "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/sites/default
+ webapp_serverowned "${MY_HTDOCSDIR}"/sites/default/settings.php
+
+ webapp_configfile "${MY_HTDOCSDIR}"/sites/default/settings.php
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ echo
+ ewarn "SECURITY NOTICE"
+ ewarn "If you plan on using SSL on your Drupal site, please consult the postinstall information:"
+ ewarn "\t# webapp-config --show-postinst ${PN} ${PV}"
+ echo
+}