summaryrefslogtreecommitdiff
path: root/www-apps/gallery/gallery-3.0.9.ebuild
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-apps/gallery/gallery-3.0.9.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-apps/gallery/gallery-3.0.9.ebuild')
-rw-r--r--www-apps/gallery/gallery-3.0.9.ebuild86
1 files changed, 86 insertions, 0 deletions
diff --git a/www-apps/gallery/gallery-3.0.9.ebuild b/www-apps/gallery/gallery-3.0.9.ebuild
new file mode 100644
index 00000000000..c4bd59fa818
--- /dev/null
+++ b/www-apps/gallery/gallery-3.0.9.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit webapp
+
+DESCRIPTION="Web based (PHP Script) photo album viewer/creator"
+HOMEPAGE="http://gallery.menalto.com/"
+SRC_URI="mirror://sourceforge/gallery/${PN}/${P}.zip"
+
+LICENSE="GPL-2"
+KEYWORDS="amd64 hppa ppc ppc64 x86"
+IUSE="ffmpeg +gd imagemagick mysql mysqli"
+
+# Build depend is on unzip
+DEPEND="app-arch/unzip"
+
+#PHP flags
+PHP_REQUIRED_FLAGS="ctype,filter,iconv,json,simplexml,tokenizer,unicode"
+PHP_OPTIONAL_FLAGS="gd?,mysql?,mysqli?"
+
+# No forced dependency on
+# mysql? ( virtual/mysql )
+# which may live on another server
+RDEPEND="
+ imagemagick? ( || (
+ media-gfx/imagemagick
+ media-gfx/graphicsmagick[imagemagick]
+ ) )
+ ffmpeg? ( virtual/ffmpeg )
+ >=dev-lang/php-5.2.3[${PHP_REQUIRED_FLAGS},${PHP_OPTIONAL_FLAGS}]
+ virtual/httpd-php"
+
+REQUIRED_USE="
+ || ( gd imagemagick )
+ || ( mysql mysqli )"
+
+S="${WORKDIR}/${PN}3"
+
+src_install() {
+ webapp_src_preinst
+
+ rm LICENSE
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ keepdir "${MY_HTDOCSDIR}"/var
+ webapp_serverowned "${MY_HTDOCSDIR}"/var
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_postupgrade_txt en "${FILESDIR}"/postupgrade-en.txt
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ ewarn
+ ewarn "\033[1;33m**************************************************\033[00m"
+ ewarn
+ ewarn "gallery3 requires short_open_tag to be enabled."
+ ewarn "You need to edit \"/etc/php/apache2-php5.?/php.ini\","
+ ewarn "set short_open_tag to \"On\" and then restart apache."
+ ewarn
+ ewarn "This ebuild does not depend on mysql or mariadb,"
+ ewarn "because the database may run on different host. But"
+ ewarn "you will need to run a database server somewhere."
+ ewarn
+ ewarn "\033[1;33m**************************************************\033[00m"
+ ewarn
+
+ einfo
+ einfo "\033[1;32m**************************************************\033[00m"
+ einfo
+ einfo "To see the post install instructions, do"
+ einfo
+ einfo " webapp-config --show-postinst ${PN} ${PVR}"
+ einfo
+ einfo "or for the post upgrade instructions, do"
+ einfo
+ einfo " webapp-config --show-postupgrade ${PN} ${PVR}"
+ einfo
+ einfo "\033[1;32m**************************************************\033[00m"
+ einfo
+}