summaryrefslogtreecommitdiff
path: root/www-apps/metadot
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-apps/metadot
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-apps/metadot')
-rw-r--r--www-apps/metadot/Manifest2
-rw-r--r--www-apps/metadot/files/metadot.conf20
-rw-r--r--www-apps/metadot/files/postinstall-en-6.1.6.txt48
-rw-r--r--www-apps/metadot/files/postinstall-en-6.4_p3.txt34
-rw-r--r--www-apps/metadot/files/reconfig-6.1.65
-rw-r--r--www-apps/metadot/files/reconfig-6.4_p318
-rw-r--r--www-apps/metadot/metadata.xml5
-rw-r--r--www-apps/metadot/metadot-6.1.6.ebuild57
-rw-r--r--www-apps/metadot/metadot-6.4.5.4.ebuild71
9 files changed, 260 insertions, 0 deletions
diff --git a/www-apps/metadot/Manifest b/www-apps/metadot/Manifest
new file mode 100644
index 00000000000..fab77254e33
--- /dev/null
+++ b/www-apps/metadot/Manifest
@@ -0,0 +1,2 @@
+DIST Metadot6.4.5.4.tar.gz 4055040 SHA256 d125b61d59563d25b2feac8ae692225478130e88f5f9165cf1de34c7985cc785
+DIST metadot6.1.6.tar.gz 3754969 SHA256 d7033b8ad561914714ea3d4d32d745566b291494fd3cfc46f66c496e37c48339
diff --git a/www-apps/metadot/files/metadot.conf b/www-apps/metadot/files/metadot.conf
new file mode 100644
index 00000000000..8dc1e503694
--- /dev/null
+++ b/www-apps/metadot/files/metadot.conf
@@ -0,0 +1,20 @@
+<VirtualHost VHOST:80>
+ DocumentRoot "ROOTDIR/html"
+
+ <Directory "ROOTDIR/html">
+ Order allow,deny
+ Allow from all
+ </Directory>
+
+ Alias /images/ ROOTDIR/html/images/
+ Alias /js/ ROOTDIR/html/js/
+ Alias /metadot/ ROOTDIR/metadot/
+ Alias /public/ ROOTDIR/sitedata/public/
+ Alias /skins/ ROOTDIR/sitedata/skins/
+
+ <Location "/metadot">
+ SetHandler perl-script
+ PerlHandler Apache::Registry
+ Options +ExecCGI
+ </Location>
+</VirtualHost>
diff --git a/www-apps/metadot/files/postinstall-en-6.1.6.txt b/www-apps/metadot/files/postinstall-en-6.1.6.txt
new file mode 100644
index 00000000000..5a25713e1b0
--- /dev/null
+++ b/www-apps/metadot/files/postinstall-en-6.1.6.txt
@@ -0,0 +1,48 @@
+
+1. Set up your database:
+cd ${MY_INSTALLDIR}/default_data
+If using MySQL-3*: mysql -uroot -p mysql < createdbanduser.sql
+If using MySQL-4*: mysql -uroot -p mysql < createdbanduser4x.sql
+
+Then change the default password:
+mysql -uroot -p mysql
+mysql> update user set password = password('<newpassword>') where user = 'metadot';
+mysql> flush privileges;
+mysql> quit
+
+Now,
+mysql -umetadot -p<newpassword> metadotdb < sampledata.sql
+
+2. Edit the Metadot configuration file:
+edit ${MY_INSTALLDIR}/etc/metadot.conf
+Set your database password from step 1.
+Read the online docs! Especially if you want to use virtual servers.
+
+3. Configure Apache:
+Add the follwing to you apache.conf or .htaccess:
+
+Alias /images/ ${MY_INSTALLDIR}/html/images/
+Alias /js/ ${MY_INSTALLDIR}/html/js/
+Alias /metadot/ ${MY_INSTALLDIR}/metadot/
+Alias /public/ ${MY_INSTALLDIR}/sitedata/public/
+Alias /skins/ ${MY_INSTALLDIR}/sitedata/skins/
+Alias /htmlarea3/ ${MY_INSTALLDIR}/html/htmlarea3/
+
+<Location "/metadot/">
+ SetHandler perl-script
+ PerlHandler Apache::Registry
+ Options +ExecCGI
+</Location>
+
+To quote the docs:
+"Make sure that this directory is owned by apache:apache"
+Read the section about configuring your MIME types.
+Now restart Apache.
+
+4. Configure cronjobs.
+Read the relevant section in the docs, and be sure to specify the right paths.
+HINT: /home/metadot is not used, everything is in ${MY_INSTALLDIR}/${PN}
+
+5. Now go to http://${VHOST_HOSTNAME}/metadot/index.pl
+Hopefully everything worked. Now go read the docs and set up your Metadot, and
+change the default Admin password.
diff --git a/www-apps/metadot/files/postinstall-en-6.4_p3.txt b/www-apps/metadot/files/postinstall-en-6.4_p3.txt
new file mode 100644
index 00000000000..9888bd3509e
--- /dev/null
+++ b/www-apps/metadot/files/postinstall-en-6.4_p3.txt
@@ -0,0 +1,34 @@
+
+1. Set up your database:
+cd ${MY_INSTALLDIR}/default_data
+If using MySQL-3*: mysql -uroot -p mysql < createdbanduser.sql
+If using MySQL-4*: mysql -uroot -p mysql < createdbanduser4x.sql
+
+Then change the default password:
+mysql -uroot -p mysql
+mysql> update user set password = password('<newpassword>') where user = 'metadot';
+mysql> flush privileges;
+mysql> quit
+
+Now,
+mysql -umetadot -p<newpassword> metadotdb < sampledata.sql
+
+2. Edit the Metadot configuration file:
+edit ${MY_INSTALLDIR}/etc/metadot.conf
+Set your database password from step 1.
+Read the online docs! Especially if you want to use virtual servers.
+
+3. Configure Apache:
+The ebuild installed an Apache configfile: ${VHOST_ROOT}/${PN}.conf
+Copy it into /etc/{apache,apache2}/vhosts.d and edit it to
+suit your needs.
+
+4. Configure cronjobs.
+Read the relevant section in the docs, and be sure to specify the right paths.
+HINT: /home/metadot is not used, everything is in ${MY_INSTALLDIR}
+
+5. Now go to http://${VHOST_HOSTNAME}/${VHOST_APPDIR}/index.pl
+Hopefully everything worked. Now go read the docs and set up your Metadot, and
+change the default Admin password.
+
+Don't forget to read the online docs!!!
diff --git a/www-apps/metadot/files/reconfig-6.1.6 b/www-apps/metadot/files/reconfig-6.1.6
new file mode 100644
index 00000000000..c70721fcbe2
--- /dev/null
+++ b/www-apps/metadot/files/reconfig-6.1.6
@@ -0,0 +1,5 @@
+#!/bin/bash
+if [ $1 = "start" -o $1 = "install" ]; then
+ sed -e "s|skin_template_dir = /home/metadot/metadot/sitedata/skins|skin_template_dir = ${MY_INSTALLDIR}/sitedata/skins|
+ s|public_uploads_dir = /home/metadot/metadot/sitedata/public|public_uploads_dir = ${MY_INSTALLDIR}/sitedata/public|" -i ${MY_INSTALLDIR}/etc/metadot.conf
+fi
diff --git a/www-apps/metadot/files/reconfig-6.4_p3 b/www-apps/metadot/files/reconfig-6.4_p3
new file mode 100644
index 00000000000..f37752ba4a9
--- /dev/null
+++ b/www-apps/metadot/files/reconfig-6.4_p3
@@ -0,0 +1,18 @@
+#!/bin/bash
+
+die() {
+ echo "#####"
+ echo $1
+ echo "#####"
+ exit 1
+}
+
+if [ $1 = "install" ]; then
+ sed -e "s|/home/metadot/metadot|${MY_INSTALLDIR}|g" -i ${MY_INSTALLDIR}/etc/metadot.conf || die
+ # fix Apache configs
+ sed -e "s|ROOTDIR|${MY_INSTALLDIR}|g
+ s|VHOST|${VHOST_HOSTNAME}|" -i ${VHOST_ROOT}/metadot.conf || die
+
+elif [ $1 = "clean" ]; then
+ echo $1
+fi
diff --git a/www-apps/metadot/metadata.xml b/www-apps/metadot/metadata.xml
new file mode 100644
index 00000000000..95c06f0095b
--- /dev/null
+++ b/www-apps/metadot/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>web-apps</herd>
+</pkgmetadata>
diff --git a/www-apps/metadot/metadot-6.1.6.ebuild b/www-apps/metadot/metadot-6.1.6.ebuild
new file mode 100644
index 00000000000..9d7c2de08aa
--- /dev/null
+++ b/www-apps/metadot/metadot-6.1.6.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit webapp
+MY_P=${P/-/}
+S=${WORKDIR}/${PN}
+
+IUSE=""
+
+DESCRIPTION="Metadot is a CMS with file, page and link management, and collaboration features"
+HOMEPAGE="http://www.metadot.com"
+SRC_URI="http://download.metadot.com/${MY_P}.tar.gz"
+
+KEYWORDS="~x86 ppc"
+
+RDEPEND="
+ >=dev-lang/perl-5.005
+ >=www-apache/mod_perl-2.0
+ dev-perl/DBI
+ dev-perl/DBD-mysql
+ dev-perl/Apache-DBI
+ dev-perl/XML-RSS
+ virtual/perl-Storable
+ dev-perl/perl-ldap
+ dev-perl/Log-Agent
+ dev-perl/Mail-POP3Client
+ dev-perl/IO-stringy
+ dev-perl/MailTools
+ dev-perl/MIME-tools
+ dev-perl/Unicode-String
+ dev-perl/Spreadsheet-WriteExcel
+ dev-perl/Date-Calc
+ dev-perl/AppConfig
+ dev-perl/ImageSize
+ dev-perl/Template-Toolkit
+ virtual/perl-Time-HiRes
+ dev-perl/Lingua-EN-NameParse
+ dev-perl/Number-Format
+ dev-perl/XML-Simple
+ dev-perl/Text-CSV_XS
+ dev-perl/Archive-Zip
+ dev-perl/DateManip
+"
+
+LICENSE="GPL-2"
+
+src_install() {
+ webapp_src_preinst
+ dodir ${MY_HOSTROOTDIR}/${PN}
+
+ dodoc CHANGELOG README
+ cp -R [[:lower:]][[:lower:]]* "${D}"/${MY_HTDOCSDIR}
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en-${PVR}.txt
+ webapp_hook_script "${FILESDIR}"/reconfig-${PVR}
+ webapp_src_install
+}
diff --git a/www-apps/metadot/metadot-6.4.5.4.ebuild b/www-apps/metadot/metadot-6.4.5.4.ebuild
new file mode 100644
index 00000000000..6ca41f9494c
--- /dev/null
+++ b/www-apps/metadot/metadot-6.4.5.4.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit webapp
+MY_P="Metadot${PV}"
+S=${WORKDIR}/${PN}
+
+IUSE=""
+
+DESCRIPTION="Metadot is a CMS with file, page and link management, and collaboration features"
+HOMEPAGE="http://www.metadot.com"
+SRC_URI="http://download.metadot.com/${MY_P}.tar.gz"
+
+KEYWORDS="ppc ~x86"
+
+DEPEND=""
+RDEPEND="
+ >=dev-lang/perl-5.6
+ =www-apache/mod_perl-2*
+ dev-perl/DBI
+ >=dev-perl/DBD-mysql-2.1027
+ dev-perl/Apache-DBI
+ >=dev-perl/AppConfig-1.55
+ >=dev-perl/XML-RSS-1.02
+ dev-perl/perl-ldap
+ >=dev-perl/Log-Agent-0.304
+ dev-perl/Mail-POP3Client
+ >=dev-perl/IO-stringy-2.108
+ dev-perl/MailTools
+ dev-perl/MIME-tools
+ >=dev-perl/Unicode-String-2.07
+ >=dev-perl/Spreadsheet-WriteExcel-0.41
+ >=dev-perl/Date-Calc-5.3
+ >=dev-perl/ImageSize-2.991
+ >=dev-perl/Template-Toolkit-2.09
+ >=virtual/perl-Time-HiRes-1.48
+ >=virtual/perl-Test-Harness-2.28
+ >=dev-perl/Test-Manifest-0.91
+ >=virtual/perl-Test-Simple-0.47
+ >=dev-perl/Lingua-EN-NameParse-1.18
+ >=dev-perl/Number-Format-1.45
+ >=dev-perl/XML-Simple-2.08
+ dev-perl/XML-Dumper
+ dev-perl/Archive-Zip
+ dev-perl/DateManip
+ dev-perl/Text-CSV_XS
+ dev-perl/HTML-Tree
+ dev-perl/HTML-Format
+ dev-perl/Data-ShowTable
+"
+
+LICENSE="GPL-2"
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc CHANGELOG README
+ cp -R [[:lower:]][[:lower:]]* "${D}"/${MY_HTDOCSDIR}
+
+ cp "${FILESDIR}"/${PN}.conf "${D}"/${MY_HOSTROOTDIR}
+ sed -i "s|Apache::Registry|Modperl::Registry|" \
+ "${D}"/${MY_HOSTROOTDIR}/${PN}.conf
+
+ webapp_serverowned ${MY_HTDOCSDIR}
+ webapp_serverowned ${MY_HTDOCSDIR}/sitedata/public
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en-6.4_p3.txt
+ webapp_hook_script "${FILESDIR}"/reconfig-6.4_p3
+ webapp_src_install
+}