summaryrefslogtreecommitdiff
path: root/www-apps/mypictures
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-apps/mypictures
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-apps/mypictures')
-rw-r--r--www-apps/mypictures/Manifest1
-rw-r--r--www-apps/mypictures/files/mypictures.diff14
-rw-r--r--www-apps/mypictures/files/postinstall-en.txt4
-rw-r--r--www-apps/mypictures/metadata.xml5
-rw-r--r--www-apps/mypictures/mypictures-20040202-r1.ebuild40
-rw-r--r--www-apps/mypictures/mypictures-20040202.ebuild46
6 files changed, 110 insertions, 0 deletions
diff --git a/www-apps/mypictures/Manifest b/www-apps/mypictures/Manifest
new file mode 100644
index 00000000000..9c045f73e4a
--- /dev/null
+++ b/www-apps/mypictures/Manifest
@@ -0,0 +1 @@
+DIST mypictures.tgz 43783 SHA256 d466258dd49aaf59830d9dd8f840da78c2cdd0ce80259299ca24aef9d27d8cd9
diff --git a/www-apps/mypictures/files/mypictures.diff b/www-apps/mypictures/files/mypictures.diff
new file mode 100644
index 00000000000..88c4048ab66
--- /dev/null
+++ b/www-apps/mypictures/files/mypictures.diff
@@ -0,0 +1,14 @@
+diff -u --recursive mypictures.orig/index.php mypictures/index.php
+--- mypictures.orig/index.php 2004-05-03 01:45:58.523174520 +0100
++++ mypictures/index.php 2004-05-03 01:47:16.713287816 +0100
+@@ -471,8 +471,8 @@
+ }
+
+ $cmd = $config['convert'];
+- $cmd .= ' -geometry 120x120 ';
+- $cmd .= '"'.$img.'" "'.$thumb.'"';
++ $cmd .= ' -size 120x120 ';
++ $cmd .= '"'.$img.'" -resize 120x120 +profile "*" "'.$thumb.'"';
+ system($cmd);
+
+ header("Content-type: image/png");
diff --git a/www-apps/mypictures/files/postinstall-en.txt b/www-apps/mypictures/files/postinstall-en.txt
new file mode 100644
index 00000000000..378d4b34b2f
--- /dev/null
+++ b/www-apps/mypictures/files/postinstall-en.txt
@@ -0,0 +1,4 @@
+From the author:
+
+Please note that MyPictures is intended for personal use only and should never
+be run on a public server.
diff --git a/www-apps/mypictures/metadata.xml b/www-apps/mypictures/metadata.xml
new file mode 100644
index 00000000000..95c06f0095b
--- /dev/null
+++ b/www-apps/mypictures/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>web-apps</herd>
+</pkgmetadata>
diff --git a/www-apps/mypictures/mypictures-20040202-r1.ebuild b/www-apps/mypictures/mypictures-20040202-r1.ebuild
new file mode 100644
index 00000000000..3dbea50f6e6
--- /dev/null
+++ b/www-apps/mypictures/mypictures-20040202-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit webapp eutils
+
+DESCRIPTION="Simple photo-gallery for websites"
+HOMEPAGE="http://www.splitbrain.org/Programming/PHP/mypictures/index.php"
+SRC_URI="http://www.splitbrain.org/Programming/PHP/${PN}/${PN}.tgz"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc"
+IUSE=""
+
+RDEPEND="media-gfx/imagemagick"
+
+S=${WORKDIR}/${PN}
+
+src_unpack () {
+ unpack ${A}
+ cd "${S}"
+
+ # we have to patch the path to imagemagick's convert tool
+
+ epatch "${FILESDIR}"/mypictures.diff
+ sed -i "s|/usr/bin/X11/convert|/usr/bin/convert|g;" index.php
+}
+
+src_install() {
+ webapp_src_preinst
+
+ cp -R [[:lower:]]* .img "${D}/${MY_HTDOCSDIR}"
+
+ dodoc CHANGES README
+
+ webapp_configfile "${MY_HTDOCSDIR}"/index.php
+ webapp_serverowned "${MY_HTDOCSDIR}"/.img
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_src_install
+}
diff --git a/www-apps/mypictures/mypictures-20040202.ebuild b/www-apps/mypictures/mypictures-20040202.ebuild
new file mode 100644
index 00000000000..3aa7d0e9f6b
--- /dev/null
+++ b/www-apps/mypictures/mypictures-20040202.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit webapp eutils
+
+DESCRIPTION="Simple photo-gallery for websites"
+HOMEPAGE="http://www.splitbrain.org/Programming/PHP/mypictures/index.php"
+SRC_URI="http://www.splitbrain.org/Programming/PHP/mypictures/mypictures.tgz"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86 ppc"
+IUSE=""
+
+DEPEND="sys-apps/sed"
+RDEPEND="media-gfx/imagemagick"
+
+S=${WORKDIR}/${PN}
+
+src_unpack () {
+ unpack ${A}
+ cd "${S}"
+
+ # we have to patch the path to imagemagick's convert tool
+
+ epatch "${FILESDIR}"/mypictures.diff
+ sed -i "s|/usr/bin/X11/convert|/usr/bin/convert|g;" index.php
+}
+
+src_compile() {
+ # do nothing
+ echo > /dev/null
+}
+
+src_install() {
+ webapp_src_preinst
+
+ cp index.php exifReader.inc exifWriter.inc "${D}${MY_HTDOCSDIR}"
+ mkdir "${D}${MY_HTDOCSDIR}"/.img
+ cp .img/* "${D}${MY_HTDOCSDIR}"/.img
+
+ dodoc CHANGES README
+
+ webapp_configfile "${MY_HTDOCSDIR}"
+ webapp_src_install
+}