summaryrefslogtreecommitdiff
path: root/www-apps/pcgi
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-apps/pcgi
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-apps/pcgi')
-rw-r--r--www-apps/pcgi/Manifest2
-rw-r--r--www-apps/pcgi/metadata.xml5
-rw-r--r--www-apps/pcgi/pcgi-2.0_alpha5.ebuild48
3 files changed, 55 insertions, 0 deletions
diff --git a/www-apps/pcgi/Manifest b/www-apps/pcgi/Manifest
new file mode 100644
index 00000000000..dba03f86ab0
--- /dev/null
+++ b/www-apps/pcgi/Manifest
@@ -0,0 +1,2 @@
+DIST PCGI-HOWTO-1998-08-13.html.bz2 6483 RMD160 947f41464581346c614a01c0f62c074a5441b547 SHA1 c644c58785881241d03a1f5938e23816651f5321 SHA256 b6ba268bc1b41aca82224193bbcb3a882e0e097d6cbe598486a3584c7a7e8610
+DIST Zope-2.6.1-src.tgz 2318685 RMD160 c6a66ea2e0f449af7c6e01a02473c168a5578a01 SHA1 9eddfc8a0e173bd80f655ed1dda102b4256a3cc9 SHA256 0629b4d1af328641e2d2ea324899ab174561cdd9dea974bc02ea01e83e67149a
diff --git a/www-apps/pcgi/metadata.xml b/www-apps/pcgi/metadata.xml
new file mode 100644
index 00000000000..95c06f0095b
--- /dev/null
+++ b/www-apps/pcgi/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>web-apps</herd>
+</pkgmetadata>
diff --git a/www-apps/pcgi/pcgi-2.0_alpha5.ebuild b/www-apps/pcgi/pcgi-2.0_alpha5.ebuild
new file mode 100644
index 00000000000..9e66687d08a
--- /dev/null
+++ b/www-apps/pcgi/pcgi-2.0_alpha5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# this package is ONLY available inside the Zope tarball!!!
+ZOPE_PV=2.6.1
+ZOPE_P=Zope-${ZOPE_PV}-src
+S="${WORKDIR}/${ZOPE_P}/pcgi"
+
+# the only real docs about it are on the author's homepage
+# the html.bz2 file is a copy of http://starship.python.net/crew/jbauer/persistcgi/howto/index.html, renamed.
+# this is specifically done as every link I have seen is to the old URL of the
+# author
+DOCDATE="1998-08-13"
+
+MY_PV="${PV/_alpha/a}"
+
+DESCRIPTION="Jeff Bauer's Persistent CGI"
+HOMEPAGE="http://starship.python.net/crew/jbauer/persistcgi/"
+SRC_URI="http://www.zope.org/Products/Zope/${ZOPE_PV}/${ZOPE_P}.tgz
+ mirror://gentoo/PCGI-HOWTO-${DOCDATE}.html.bz2"
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE=""
+DEPEND="${DEPEND}"
+RDEPEND="${RDEPEND}
+ dev-lang/python"
+
+src_compile() {
+ econf || die "econf failed"
+ emake all creosote || die "emake failed"
+}
+
+src_install() {
+ into /usr
+ dodir /usr/bin
+ dodoc ${WORKDIR}/CGI-HOWTO-1998-08-13.html
+ newbin pcgi-wrapper pcgi-wrapper${MY_PV}
+ dosym /usr/bin/pcgi-wrapper${MY_PV} /usr/bin/pcgi-wrapper
+ dodoc MrCreosote/README.MrCreosote README Test/README.parseinfo
+ newdoc Util/README README.Util
+ dobin MrCreosote/pcgi-creosote MrCreosote/creosote.py
+ dobin Util/killpcgi.py Util/pcgifile.py
+ dobin pcgi_publisher.py
+ newbin Test/parseinfo pcgi-parseinfo
+ cp -pPR Example ${D}/usr/share/doc/${PF}/
+}