summaryrefslogtreecommitdiff
path: root/www-apps
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-09-27 06:32:25 +1300
committerPatrice Clement <monsieurp@gentoo.org>2017-10-04 00:03:43 +0200
commit46613dd254cb789aabc84dd7e77427fb1d419fb1 (patch)
tree10061b64338734f4e6d99e040fa8a5273a5a3007 /www-apps
parent6e2c3392fa1aafe28d2e56399c1e32a9e9d4db62 (diff)
downloadgentoo-46613dd254cb789aabc84dd7e77427fb1d419fb1.tar.gz
gentoo-46613dd254cb789aabc84dd7e77427fb1d419fb1.tar.xz
www-apps/rt: fix loading of Date::Manip w/ Factory TZ.
On machines where TZ=Factory, such as ones freshly rolled out from gentoo install media, `use Date::Manip` fails. This leads to a failure at configure and install time. Ideally, end users will need to configure their machines properly. But their Timezone being right should have no bearing on the ability to build this package. Package-Manager: Portage-2.3.8, Repoman-2.3.3 Closes: https://github.com/gentoo/gentoo/pull/5795
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/rt/rt-4.2.12-r1.ebuild6
-rw-r--r--www-apps/rt/rt-4.4.1.ebuild6
2 files changed, 10 insertions, 2 deletions
diff --git a/www-apps/rt/rt-4.2.12-r1.ebuild b/www-apps/rt/rt-4.2.12-r1.ebuild
index 00b268f8c87..011c42d0189 100644
--- a/www-apps/rt/rt-4.2.12-r1.ebuild
+++ b/www-apps/rt/rt-4.2.12-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -231,6 +231,10 @@ src_configure() {
web="apache"
depsconf+=" --with-MODPERL2"
fi
+ # Any loading Date::Manip from here on
+ # may fail if TZ=Factory as it is on gentoo install
+ # media ( affects install as well )
+ export TZ=UTC
./configure --enable-layout=Gentoo \
--with-bin-owner=rt \
diff --git a/www-apps/rt/rt-4.4.1.ebuild b/www-apps/rt/rt-4.4.1.ebuild
index 3fa6e51a7e6..35232292400 100644
--- a/www-apps/rt/rt-4.4.1.ebuild
+++ b/www-apps/rt/rt-4.4.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -236,6 +236,10 @@ src_configure() {
web="apache"
depsconf+=" --with-MODPERL2"
fi
+ # Any loading Date::Manip from here on
+ # may fail if TZ=Factory as it is on gentoo install
+ # media ( affects install as well )
+ export TZ=UTC
./configure --enable-layout=Gentoo \
--with-bin-owner=rt \