summaryrefslogtreecommitdiff
path: root/www-apps
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-06-30 17:57:05 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-06-30 17:57:05 -0500
commitad78aa38a07dcf38d30798dd7c89bddd7ff0d058 (patch)
treea81b413a7d258db6af6f664ba82ca6da30738e13 /www-apps
parent42bdffe7965568ff651899b35bfa6dceeb757d24 (diff)
downloadgentoo-ad78aa38a07dcf38d30798dd7c89bddd7ff0d058.tar.gz
gentoo-ad78aa38a07dcf38d30798dd7c89bddd7ff0d058.tar.xz
www-apps/icingaweb2-module-director: adding for bug 582568
Package-Manager: portage-2.2.28
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/icingaweb2-module-director/Manifest1
-rw-r--r--www-apps/icingaweb2-module-director/icingaweb2-module-director-1.1.0.ebuild33
-rw-r--r--www-apps/icingaweb2-module-director/icingaweb2-module-director-9999.ebuild33
-rw-r--r--www-apps/icingaweb2-module-director/metadata.xml10
4 files changed, 77 insertions, 0 deletions
diff --git a/www-apps/icingaweb2-module-director/Manifest b/www-apps/icingaweb2-module-director/Manifest
new file mode 100644
index 00000000000..c6e2b5ecd1b
--- /dev/null
+++ b/www-apps/icingaweb2-module-director/Manifest
@@ -0,0 +1 @@
+DIST icingaweb2-module-director-1.1.0.tar.gz 1287302 SHA256 525434cf8555bfa07aba351769006691fed2a570ec01b06576a901e89647d8df SHA512 a1253c1c803f05b238e12d86e7a367c56e10998293f99beb645ba3ca4d7165407a34dd4f53ef84ee1338464013201adb4fcee09cf3ca78d8850513c366a7a038 WHIRLPOOL 28c7a898c3a0f07bb69932d8d54a39a7f7b225ede32794500f3d75ad8fb0ef168e88c263996d3564603ab6c5a70ea5bf5ad00f4590269f086ae4c933008c62e7
diff --git a/www-apps/icingaweb2-module-director/icingaweb2-module-director-1.1.0.ebuild b/www-apps/icingaweb2-module-director/icingaweb2-module-director-1.1.0.ebuild
new file mode 100644
index 00000000000..539cc51bcc1
--- /dev/null
+++ b/www-apps/icingaweb2-module-director/icingaweb2-module-director-1.1.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Icinga Web 2 plugin for configuration"
+HOMEPAGE="https://dev.icinga.org/projects/icingaweb2-module-director/"
+if [[ "${PV}" == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Icinga/icingaweb2-module-director.git"
+else
+ KEYWORDS="~amd64 ~x86"
+ MY_PN="icingaweb2-module-director"
+ SRC_URI="https://codeload.github.com/Icinga/${MY_PN}/tar.gz/v${PV} -> ${P}.tar.gz"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND=">=net-analyzer/icinga2-2.4.3
+ >=www-apps/icingaweb2-2.2.0
+ || (
+ dev-lang/php:5.6[curl]
+ dev-lang/php:7.0[curl]
+ )"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ insinto "/usr/share/icingaweb2/modules/director/"
+ doins -r "${S}"/*
+}
diff --git a/www-apps/icingaweb2-module-director/icingaweb2-module-director-9999.ebuild b/www-apps/icingaweb2-module-director/icingaweb2-module-director-9999.ebuild
new file mode 100644
index 00000000000..539cc51bcc1
--- /dev/null
+++ b/www-apps/icingaweb2-module-director/icingaweb2-module-director-9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Icinga Web 2 plugin for configuration"
+HOMEPAGE="https://dev.icinga.org/projects/icingaweb2-module-director/"
+if [[ "${PV}" == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Icinga/icingaweb2-module-director.git"
+else
+ KEYWORDS="~amd64 ~x86"
+ MY_PN="icingaweb2-module-director"
+ SRC_URI="https://codeload.github.com/Icinga/${MY_PN}/tar.gz/v${PV} -> ${P}.tar.gz"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND=">=net-analyzer/icinga2-2.4.3
+ >=www-apps/icingaweb2-2.2.0
+ || (
+ dev-lang/php:5.6[curl]
+ dev-lang/php:7.0[curl]
+ )"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ insinto "/usr/share/icingaweb2/modules/director/"
+ doins -r "${S}"/*
+}
diff --git a/www-apps/icingaweb2-module-director/metadata.xml b/www-apps/icingaweb2-module-director/metadata.xml
new file mode 100644
index 00000000000..1301fb3341b
--- /dev/null
+++ b/www-apps/icingaweb2-module-director/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <longdescription lang="en">
+ </longdescription>
+</pkgmetadata>