summaryrefslogtreecommitdiff
path: root/www-client/fetch
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-03-31 12:43:26 +0000
committerPatrice Clement <monsieurp@gentoo.org>2016-03-31 12:44:32 +0000
commitf0801b1187b55275875d0a04fb84fb54c31339a8 (patch)
treea4b06e588eabe1b3ac662bc744bff34fde31ca8f /www-client/fetch
parent85cc36eb4685f8b8ed374c02020139a7a95ba241 (diff)
downloadgentoo-f0801b1187b55275875d0a04fb84fb54c31339a8.tar.gz
gentoo-f0801b1187b55275875d0a04fb84fb54c31339a8.tar.xz
www-client/fetch: EAPI 6 bump.
Package-Manager: portage-2.2.26
Diffstat (limited to 'www-client/fetch')
-rw-r--r--www-client/fetch/fetch-1.0-r2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/www-client/fetch/fetch-1.0-r2.ebuild b/www-client/fetch/fetch-1.0-r2.ebuild
new file mode 100644
index 00000000000..6c55320b7f2
--- /dev/null
+++ b/www-client/fetch/fetch-1.0-r2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="HTTP download tool built atop the HTTP fetcher library"
+HOMEPAGE="http://sourceforge.net/projects/fetch/"
+SRC_URI="mirror://sourceforge/fetch/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-libs/http-fetcher-1.0.1"
+
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${P}"
+
+src_prepare() {
+ default
+ sed -i -e "/^ld_rpath/d" configure || die "sed failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc README INSTALL
+ dodoc -r docs/*.html
+}