summaryrefslogtreecommitdiff
path: root/www-client/firefox
diff options
context:
space:
mode:
authorAndrew Savchenko <bircoph@gentoo.org>2016-08-11 11:14:44 +0300
committerAndrew Savchenko <bircoph@gentoo.org>2016-08-11 11:28:28 +0300
commite445fe9d84ab2c644723fae330a3ecfb2914740b (patch)
treeb6f58ee9d6b40b8342ec43eff18a20b50367d2ad /www-client/firefox
parente59325799098b48c8570438c054d11fed75b2b72 (diff)
downloadgentoo-e445fe9d84ab2c644723fae330a3ecfb2914740b.tar.gz
gentoo-e445fe9d84ab2c644723fae330a3ecfb2914740b.tar.xz
www-client/firefox: fix PGO build, bug 388585
Fix PGO build by providing proper pgo-run target. Patches are based on Daniel Rammelt's patches, bug 499650. Tested on ~amd64. Package-Manager: portage-2.3.0 Signed-off-by: Andrew Savchenko <bircoph@gentoo.org>
Diffstat (limited to 'www-client/firefox')
-rw-r--r--www-client/firefox/files/firefox-48.0-pgo.patch12
-rw-r--r--www-client/firefox/firefox-48.0.ebuild5
2 files changed, 15 insertions, 2 deletions
diff --git a/www-client/firefox/files/firefox-48.0-pgo.patch b/www-client/firefox/files/firefox-48.0-pgo.patch
new file mode 100644
index 00000000000..645c0085e22
--- /dev/null
+++ b/www-client/firefox/files/firefox-48.0-pgo.patch
@@ -0,0 +1,12 @@
+--- firefox-47.0.1/Makefile.in.orig 2016-06-01 07:11:37.000000000 +0300
++++ firefox-47.0.1/Makefile.in 2016-08-06 16:45:14.442699244 +0300
+@@ -55,6 +55,9 @@
+ endif
+ endif
+
++pgo-profile-run:
++ $(PYTHON) $(topsrcdir)/build/pgo/profileserver.py $(EXTRA_TEST_ARGS)
++
+ ifdef JS_STANDALONE
+ .PHONY: CLOBBER
+ CLOBBER:
diff --git a/www-client/firefox/firefox-48.0.ebuild b/www-client/firefox/firefox-48.0.ebuild
index 33c3f469051..c430b690c71 100644
--- a/www-client/firefox/firefox-48.0.ebuild
+++ b/www-client/firefox/firefox-48.0.ebuild
@@ -115,7 +115,8 @@ src_unpack() {
src_prepare() {
# Apply our patches
- eapply "${WORKDIR}/firefox"
+ eapply "${WORKDIR}/firefox" \
+ "${FILESDIR}"/${PN}-48.0-pgo.patch
# "${FILESDIR}"/${PN}-45-qt-widget-fix.patch
if ! tc-ld-is-gold && has_version ">=sys-devel/binutils-2.26" ; then
@@ -203,7 +204,7 @@ src_configure() {
# Allow for a proper pgo build
if use pgo; then
- echo "mk_add_options PROFILE_GEN_SCRIPT='\$(PYTHON) \$(OBJDIR)/_profile/pgo/profileserver.py'" >> "${S}"/.mozconfig
+ echo "mk_add_options PROFILE_GEN_SCRIPT='EXTRA_TEST_ARGS=10 \$(MAKE) -C \$(MOZ_OBJDIR) pgo-profile-run'" >> "${S}"/.mozconfig
fi
echo "mk_add_options MOZ_OBJDIR=${BUILD_OBJ_DIR}" >> "${S}"/.mozconfig