summaryrefslogtreecommitdiff
path: root/www-client/jd
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-client/jd
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-client/jd')
-rw-r--r--www-client/jd/Manifest1
-rw-r--r--www-client/jd/jd-2.8.5_p120826.ebuild59
-rw-r--r--www-client/jd/metadata.xml8
3 files changed, 68 insertions, 0 deletions
diff --git a/www-client/jd/Manifest b/www-client/jd/Manifest
new file mode 100644
index 00000000000..ab8b7e48ab2
--- /dev/null
+++ b/www-client/jd/Manifest
@@ -0,0 +1 @@
+DIST jd-2.8.5-120826.tgz 784657 SHA256 494a190ae64c222cd7080cb121f23043bd231829572cd685258185a9b5dfff32 SHA512 0c4aa0845aca71f1172a565d7b9e4a7099fa27c221b452c623b818144b958c8b042e5ab00582eee07bc8d44186a172c9abb750550ae3293851e03382e527e11b WHIRLPOOL d1a02eb054c94533ba8b7de0d0ef1a4ffed3f3cb8528784004f5ac68983e5f59b14c4898f11676ee8d111d0303fa4e21cde6f14c6d5ad46d64c27abfc69d3dc2
diff --git a/www-client/jd/jd-2.8.5_p120826.ebuild b/www-client/jd/jd-2.8.5_p120826.ebuild
new file mode 100644
index 00000000000..e21b80c489d
--- /dev/null
+++ b/www-client/jd/jd-2.8.5_p120826.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils autotools autotools-utils
+
+MY_P="${P/_p/-}"
+MY_P="${MY_P/_/-}"
+
+DESCRIPTION="gtk2 based 2ch browser written in C++"
+HOMEPAGE="http://jd4linux.sourceforge.jp/"
+SRC_URI="mirror://sourceforge.jp/jd4linux/56721/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa gnome gnutls migemo"
+
+RDEPEND="dev-cpp/gtkmm:2.4
+ dev-libs/glib:2
+ x11-misc/xdg-utils
+ alsa? ( >=media-libs/alsa-lib-1 )
+ gnome? ( >=gnome-base/libgnomeui-2 )
+ !gnome? (
+ x11-libs/libSM
+ x11-libs/libICE
+ )
+ gnutls? ( >=net-libs/gnutls-1.2 )
+ !gnutls? ( >=dev-libs/openssl-0.9 )
+ migemo? ( app-text/cmigemo )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+AUTOTOOLS_AUTORECONF=1
+
+src_configure() {
+ # use gnomeui sm instead of Xorg SM/ICE
+ local myeconfargs=(
+ --with-xdgopen
+ $(use_with gnome sessionlib gnomeui)
+ $(use_with !gnome sessionlib xsmp)
+ $(use_with alsa)
+ $(use_with !gnutls openssl)
+ $(use_with migemo)
+ $(use_with migemo migemodict /usr/share/migemo/migemo-dict)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ doicon ${PN}.png
+ domenu ${PN}.desktop
+ #dodoc AUTHORS ChangeLog NEWS README
+}
diff --git a/www-client/jd/metadata.xml b/www-client/jd/metadata.xml
new file mode 100644
index 00000000000..8aa71b38e8d
--- /dev/null
+++ b/www-client/jd/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>cjk</herd>
+ <upstream>
+ <remote-id type="sourceforge-jp">jd4linux</remote-id>
+ </upstream>
+</pkgmetadata>