summaryrefslogtreecommitdiff
path: root/www-client
diff options
context:
space:
mode:
authorPawel Hajdan, Jr <phajdan.jr@gentoo.org>2016-05-15 22:28:14 +0200
committerPawel Hajdan, Jr <phajdan.jr@gentoo.org>2016-05-15 22:28:14 +0200
commit941e5d23654a9bcf3613a92b2eef6089c6bbf18a (patch)
tree6987d679d3d8e9624c58b6196b409e7560a74963 /www-client
parentd2ccfbbc1a708d0776a9856d6138ab93ca01f720 (diff)
downloadgentoo-941e5d23654a9bcf3613a92b2eef6089c6bbf18a.tar.gz
gentoo-941e5d23654a9bcf3613a92b2eef6089c6bbf18a.tar.xz
www-client/chromium: reconfigure bundled ffmpeg when using GN
Package-Manager: portage-2.2.26
Diffstat (limited to 'www-client')
-rw-r--r--www-client/chromium/chromium-52.0.2723.2.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/www-client/chromium/chromium-52.0.2723.2.ebuild b/www-client/chromium/chromium-52.0.2723.2.ebuild
index a3c00fc4a81..980a40198ef 100644
--- a/www-client/chromium/chromium-52.0.2723.2.ebuild
+++ b/www-client/chromium/chromium-52.0.2723.2.ebuild
@@ -447,6 +447,7 @@ src_configure() {
ffmpeg_branding="$(usex proprietary-codecs Chrome Chromium)"
myconf_gyp+=" -Dproprietary_codecs=1 -Dffmpeg_branding=${ffmpeg_branding}"
+ myconf_gn+=" proprietary_codecs=true ffmpeg_branding=\"${ffmpeg_branding}\""
# Set up Google API keys, see http://www.chromium.org/developers/how-tos/api-keys .
# Note: these are for Gentoo use ONLY. For your own distribution,
@@ -538,8 +539,7 @@ src_configure() {
export TMPDIR="${WORKDIR}/temp"
mkdir -p -m 755 "${TMPDIR}" || die
- # TODO: also do this for GN bundled ffmpeg build.
- if ! use system-ffmpeg && ! use gn; then
+ if ! use system-ffmpeg; then
local build_ffmpeg_args=""
if use pic && [[ "${ffmpeg_target_arch}" == "ia32" ]]; then
build_ffmpeg_args+=" --disable-asm"