summaryrefslogtreecommitdiff
path: root/www-misc
diff options
context:
space:
mode:
authorsoredake <fdsfgs@krutt.org>2016-09-06 21:02:27 +0300
committerGöktürk Yüksek <gokturk@gentoo.org>2016-11-10 12:18:52 -0500
commit9e3123404d27c23684dfe1fb6e1cfb04d0992888 (patch)
tree04905b88993ff024acd64717290e44401c1917de /www-misc
parentbab14922dd6ef6b518847d2f714d0b1d08d4423e (diff)
downloadgentoo-9e3123404d27c23684dfe1fb6e1cfb04d0992888.tar.gz
gentoo-9e3123404d27c23684dfe1fb6e1cfb04d0992888.tar.xz
www-misc/profile-sync-daemon: add 6.28 and 9999 version
Diffstat (limited to 'www-misc')
-rw-r--r--www-misc/profile-sync-daemon/Manifest1
-rw-r--r--www-misc/profile-sync-daemon/profile-sync-daemon-5.45.1.ebuild8
-rw-r--r--www-misc/profile-sync-daemon/profile-sync-daemon-6.28.ebuild33
-rw-r--r--www-misc/profile-sync-daemon/profile-sync-daemon-9999.ebuild20
4 files changed, 57 insertions, 5 deletions
diff --git a/www-misc/profile-sync-daemon/Manifest b/www-misc/profile-sync-daemon/Manifest
index 7aa277ca65a..fd4968d858b 100644
--- a/www-misc/profile-sync-daemon/Manifest
+++ b/www-misc/profile-sync-daemon/Manifest
@@ -1 +1,2 @@
DIST profile-sync-daemon-5.45.1.tar.gz 25543 SHA256 da4e215f053ca3f2b4cfae3f83e8a8e8370ef328aa343eea1011719a3ca9ede8 SHA512 8a61ebfe52031bd59c70416adfd477edc313641cec93a4e96c80f316517cdb53f49840cfd7711ea2f6180ecce8e8e5d45f01d7bd85ba787c3fe288a14426b944 WHIRLPOOL 07a377c71557c4e285893a2b03513cedf99b5f2c4c7805de1c297393716873d32be2d003090c59fa2a260da64cf48611d910515ffcb907cfe9637614ddfc90bd
+DIST profile-sync-daemon-6.28.tar.gz 20060 SHA256 e38c31711621c12fb0b25d6efc70333cf56006ea13fa878accee90bc4d7e548c SHA512 aebd863077ff71075bd2f03222a197776a34cd1b78d9833dc861f50bb0b6438059278cd33bbf044a83865ec88220fc870fee23053f9ed0c48ee68b66c569cc0a WHIRLPOOL ac040129cb85bdf92f14cf774378325e784be40fe1b75ca50ebef4876596e48f6301626cc7db1afbdc7706777b6f82c4726183c745a0b384f0870c7b42ae3f17
diff --git a/www-misc/profile-sync-daemon/profile-sync-daemon-5.45.1.ebuild b/www-misc/profile-sync-daemon/profile-sync-daemon-5.45.1.ebuild
index 295f34a1821..b3cdc3153d8 100644
--- a/www-misc/profile-sync-daemon/profile-sync-daemon-5.45.1.ebuild
+++ b/www-misc/profile-sync-daemon/profile-sync-daemon-5.45.1.ebuild
@@ -1,12 +1,10 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
-inherit eutils vcs-snapshot
-
-DESCRIPTION="Symlinks and syncs browser profile dirs to RAM"
+DESCRIPTION="Symlinks and syncs browser profile dirs to RAM."
HOMEPAGE="https://wiki.archlinux.org/index.php/Profile-sync-daemon"
SRC_URI="https://github.com/graysky2/profile-sync-daemon/archive/v${PV}.tar.gz -> ${P}.tar.gz"
diff --git a/www-misc/profile-sync-daemon/profile-sync-daemon-6.28.ebuild b/www-misc/profile-sync-daemon/profile-sync-daemon-6.28.ebuild
new file mode 100644
index 00000000000..01683852ad1
--- /dev/null
+++ b/www-misc/profile-sync-daemon/profile-sync-daemon-6.28.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit versionator
+
+DESCRIPTION="Symlinks and syncs browser profile dirs to RAM."
+HOMEPAGE="https://wiki.archlinux.org/index.php/Profile-sync-daemon"
+
+SRC_URI="https://github.com/graysky2/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ app-shells/bash
+ net-misc/rsync[xattr]
+ sys-apps/systemd"
+
+pkg_postinst() {
+ local replacing
+ for replacing in ${REPLACING_VERSIONS}; do
+ if [[ "$(get_major_version ${replacing})" == "5" ]]; then
+ ewarn "${PN}-6 and later dropped OpenRC and /etc/psd.conf support"
+ ewarn "See https://github.com/graysky2/profile-sync-daemon#note-for-version-6"
+ break
+ fi
+ done
+}
diff --git a/www-misc/profile-sync-daemon/profile-sync-daemon-9999.ebuild b/www-misc/profile-sync-daemon/profile-sync-daemon-9999.ebuild
new file mode 100644
index 00000000000..6244ec12650
--- /dev/null
+++ b/www-misc/profile-sync-daemon/profile-sync-daemon-9999.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit git-r3
+
+DESCRIPTION="Symlinks and syncs browser profile dirs to RAM."
+HOMEPAGE="https://wiki.archlinux.org/index.php/Profile-sync-daemon"
+EGIT_REPO_URI="https://github.com/graysky2/${PN}"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ app-shells/bash
+ net-misc/rsync[xattr]
+ sys-apps/systemd"