summaryrefslogtreecommitdiff
path: root/www-plugins
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2017-07-20 10:45:37 +0200
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2017-07-20 10:45:37 +0200
commitaa2763887266bfe7e5dfe447f8833050d2745a27 (patch)
treeca66f628eafced7bd51c883a665207497023a906 /www-plugins
parent6088ec13208ec739ea97c3691a5c2b3f5ee0fafd (diff)
downloadgentoo-aa2763887266bfe7e5dfe447f8833050d2745a27.tar.gz
gentoo-aa2763887266bfe7e5dfe447f8833050d2745a27.tar.xz
www-plugins/lightspark: add upstream patch to fix ffmpeg-free build
Bug: https://bugs.gentoo.org/show_bug.cgi?id=607492 Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'www-plugins')
-rw-r--r--www-plugins/lightspark/files/lightspark-0.8.0-ffmpeg-free.patch31
-rw-r--r--www-plugins/lightspark/lightspark-0.8.0.ebuild2
2 files changed, 33 insertions, 0 deletions
diff --git a/www-plugins/lightspark/files/lightspark-0.8.0-ffmpeg-free.patch b/www-plugins/lightspark/files/lightspark-0.8.0-ffmpeg-free.patch
new file mode 100644
index 00000000000..76566e6be79
--- /dev/null
+++ b/www-plugins/lightspark/files/lightspark-0.8.0-ffmpeg-free.patch
@@ -0,0 +1,31 @@
+From 22a85a13a5c3ded942ef59522ad399eb5d9a58d9 Mon Sep 17 00:00:00 2001
+From: Mikhail Vorobyov <vorobyov.mikhail@gmail.com>
+Date: Tue, 18 Jul 2017 23:46:37 +0300
+Subject: [PATCH] Add NullVideoDecoder::switchCodec
+
+Add VideoDecoder::switchCodec implementation to NullVideoDecoder to fix
+ffmpeg-free build.
+---
+ src/backends/decoder.h | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/src/backends/decoder.h b/src/backends/decoder.h
+index 069543d0..f53288bd 100644
+--- a/src/backends/decoder.h
++++ b/src/backends/decoder.h
+@@ -140,6 +140,7 @@ class NullVideoDecoder: public VideoDecoder
+ public:
+ NullVideoDecoder() {status=VALID;}
+ ~NullVideoDecoder() { while(fenceCount); }
++ void switchCodec(LS_VIDEO_CODEC codecId, uint8_t* initdata, uint32_t datalen, double frameRateHint){};
+ bool decodeData(uint8_t* data, uint32_t datalen, uint32_t time){return false;}
+ bool discardFrame(){return false;}
+ void skipUntil(uint32_t time){}
+@@ -305,6 +306,7 @@ class NullAudioDecoder: public AudioDecoder
+ sampleRate=44100;
+ channelCount=2;
+ }
++ void switchCodec(LS_AUDIO_CODEC codecId, uint8_t* initdata, uint32_t datalen){};
+ uint32_t decodeData(uint8_t* data, int32_t datalen, uint32_t time){return 0;}
+ };
+
diff --git a/www-plugins/lightspark/lightspark-0.8.0.ebuild b/www-plugins/lightspark/lightspark-0.8.0.ebuild
index d67d565b6b3..1a71cb2ec2d 100644
--- a/www-plugins/lightspark/lightspark-0.8.0.ebuild
+++ b/www-plugins/lightspark/lightspark-0.8.0.ebuild
@@ -51,6 +51,8 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${P/_rc*/}
+PATCHES=( "${FILESDIR}"/${P}-ffmpeg-free.patch )
+
pkg_pretend() {
if [[ ${MERGE_TYPE} != binary ]]; then
if tc-is-gcc && [[ $(gcc-major-version) == 4 && $(gcc-minor-version) -lt 6 || $(gcc-major-version) -lt 4 ]] ; then