summaryrefslogtreecommitdiff
path: root/www-servers/bozohttpd
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-servers/bozohttpd
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-servers/bozohttpd')
-rw-r--r--www-servers/bozohttpd/Manifest1
-rw-r--r--www-servers/bozohttpd/bozohttpd-20140708.ebuild35
-rw-r--r--www-servers/bozohttpd/files/bozohttpd.conffile11
-rw-r--r--www-servers/bozohttpd/files/bozohttpd.initscript38
-rw-r--r--www-servers/bozohttpd/metadata.xml11
5 files changed, 96 insertions, 0 deletions
diff --git a/www-servers/bozohttpd/Manifest b/www-servers/bozohttpd/Manifest
new file mode 100644
index 00000000000..2ced85fe906
--- /dev/null
+++ b/www-servers/bozohttpd/Manifest
@@ -0,0 +1 @@
+DIST bozohttpd-20140708.tar.bz2 58024 SHA256 3919e4beec82dd67f19a99e222a05358ef4d06433dbf2df48b5895499af28fc7 SHA512 ebdb27f33cd9e8c893edcb8d62f8d78d2127a3fadde0f75432b9c95fac56a0b743c1b917405b2090c15f4729e9be4ee725f73f14978b62071d2ac7261629607f WHIRLPOOL d3a59f1c39b8668fc3695f4dea649c18f11dba36115e6ba6de0a40800140bd790ce32d53354e72f829a37a3dcd5ad3bef6833144d4637d07dcfde34b6610ce32
diff --git a/www-servers/bozohttpd/bozohttpd-20140708.ebuild b/www-servers/bozohttpd/bozohttpd-20140708.ebuild
new file mode 100644
index 00000000000..3bd0745052c
--- /dev/null
+++ b/www-servers/bozohttpd/bozohttpd-20140708.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit toolchain-funcs
+
+DESCRIPTION="bozohttpd is a small and secure http server"
+HOMEPAGE="http://www.eterna.com.au/bozohttpd/"
+SRC_URI="http://www.eterna.com.au/bozohttpd/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc x86"
+
+DEPEND="dev-libs/openssl"
+RDEPEND="${DEPEND}
+ virtual/logger"
+
+src_prepare() {
+ mv Makefile{.boot,}
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" OPT="${CFLAGS}"
+}
+
+src_install() {
+ dobin bozohttpd
+ doman bozohttpd.8
+
+ newconfd "${FILESDIR}"/${PN}.conffile bozohttpd
+ newinitd "${FILESDIR}"/${PN}.initscript bozohttpd
+}
diff --git a/www-servers/bozohttpd/files/bozohttpd.conffile b/www-servers/bozohttpd/files/bozohttpd.conffile
new file mode 100644
index 00000000000..49dbbe5517c
--- /dev/null
+++ b/www-servers/bozohttpd/files/bozohttpd.conffile
@@ -0,0 +1,11 @@
+# Config file for /etc/init.d/bozohttpd
+
+# necessary stuff
+DATADIR=/var/www/localhost/htdocs
+BIND_ADDRESS=localhost
+LISTEN_PORT=80
+
+# optional stuff
+#USER=daemon
+#INDEX_DEFAULT=index.php
+#APPEND="-C .php /usr/bin/php"
diff --git a/www-servers/bozohttpd/files/bozohttpd.initscript b/www-servers/bozohttpd/files/bozohttpd.initscript
new file mode 100644
index 00000000000..9374e692765
--- /dev/null
+++ b/www-servers/bozohttpd/files/bozohttpd.initscript
@@ -0,0 +1,38 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Id$
+
+#NB: Config is in /etc/conf.d/bozohttpd
+
+
+depend() {
+ need logger net
+}
+
+checkconfig() {
+ if [ -z "$DATADIR" ] || [ -z "$BIND_ADDRESS" ] || [ -z "$LISTEN_PORT" ]; then
+ eerror "You need to setup DATADIR, BIND_ADDRESS and LISTEN PORT in /etc/conf.d/bozohttpd first"
+ return 1
+ fi
+}
+
+start() {
+ checkconfig || return 1
+
+ local params=""
+
+ [ -n "$USER" ] && params="$params -U $USER"
+ [ -n "$INDEX_DEFAULT" ] && params="$params -x $INDEX_DEFAULT"
+ [ -n "$APPEND" ] && params="$params $APPEND"
+
+ ebegin "Starting bozohttpd"
+ start-stop-daemon --start --exec /usr/bin/bozohttpd -- -b -i $BIND_ADDRESS -I $LISTEN_PORT -X ${params} $DATADIR
+ eend ${?}
+}
+
+stop() {
+ ebegin "Stopping bozohttpd"
+ start-stop-daemon --stop --exec /usr/bin/bozohttpd
+ eend ${?}
+}
diff --git a/www-servers/bozohttpd/metadata.xml b/www-servers/bozohttpd/metadata.xml
new file mode 100644
index 00000000000..66bebd492cf
--- /dev/null
+++ b/www-servers/bozohttpd/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>maintainer-needed@gentoo.org</email>
+</maintainer>
+<longdescription>
+ bozohttpd is designed to be small, simple and relatively
+ featureless, hopefully increasing its security.
+</longdescription>
+</pkgmetadata>