summaryrefslogtreecommitdiff
path: root/www-servers/gunicorn
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-08-09 13:50:43 +0200
committerJustin Lecher <jlec@gentoo.org>2015-08-09 13:51:36 +0200
commit73b6d43a9b0b11e395fe4f53c9a732b16ae084ab (patch)
tree021a8b960bcbe778226f48656a7f75d8c49122b2 /www-servers/gunicorn
parentfa6f26a59dbabe885d0d44f6958509835d9d3e24 (diff)
downloadgentoo-73b6d43a9b0b11e395fe4f53c9a732b16ae084ab.tar.gz
gentoo-73b6d43a9b0b11e395fe4f53c9a732b16ae084ab.tar.xz
www-servers/gunicorn: Version Bump
Package-Manager: portage-2.2.20 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'www-servers/gunicorn')
-rw-r--r--www-servers/gunicorn/Manifest1
-rw-r--r--www-servers/gunicorn/gunicorn-19.3.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/www-servers/gunicorn/Manifest b/www-servers/gunicorn/Manifest
index 1bc7ab3b716..4331aef0ee3 100644
--- a/www-servers/gunicorn/Manifest
+++ b/www-servers/gunicorn/Manifest
@@ -1,3 +1,4 @@
DIST gunicorn-0.17.4.tar.gz 372737 SHA256 0f5b63f87ab66b9aaca6938e2b97dd6e785498a0cb4567560996192d7e40ad21 SHA512 e227e2e3b1240d1090c0ef86db884ed68dea92f7d4de6a949afee00a0c258a1cf77309391fd88a6c9861942a246495018b81443e8be3055c14af2373e1f4d793 WHIRLPOOL 873220a9c0065ec5df81ad807d212b641dc3d5a4a9a0dceae28c17f07d1d9a63110a25fd1881bac765198cd10600ca5b802ba20f3a763da8db2ecf7d8bc0e25f
DIST gunicorn-19.0.0.tar.gz 382899 SHA256 0ccb71a2d9e0764fb3abc5dc6f7a44d5d44e3137545be8869befc8aedc02878e SHA512 5e041cfd65c664e687538c1ab1680949492fa76abe8e39f9ab3f8b5239f5ca4f1d91cbb9235e6d671ecd13eec1e58eb440c42f21534488c6acafb34c65288c41 WHIRLPOOL 21bf2f771125c575c85eb8c3c3a8c4b95a29f5e29a157affde2bf2446b29ccef1f192c9f93f5ebe86b1a1196c716a0d9101e94c4f2fcfa7f7304cf5e351b051c
DIST gunicorn-19.1.1.tar.gz 385155 SHA256 82715511fb6246fad4ba66d812eb93416ae8371b464fa88bf3867c9c177daa14 SHA512 1b42f0dadb8ced12954e821ad3dc7fad67ae6f1123218fe79e32d7089d9ae65bcd973613c226d9a16b11d7d35632990f2c9499594c7a383a79698a1c2db471de WHIRLPOOL 29c99b33b72d00dc248adedf89517804f58ee4ee36a3c9fdddb9d65ee047dd57d381d719e1ed44b7b5284f11ac703d29f3d66fd077f996de2ab9effa8fb15fda
+DIST gunicorn-19.3.0.tar.gz 395381 SHA256 8bc835082882ad9a012cd790c460011e4d96bf3512d98a04d3dabbe45393a089 SHA512 8c4e0bb1bf0b35aaf9160b9b7d87890a991451fbc86186454203f3483767858944704c1ec22dd52480ce1e4693e84b62b1428dd3b67b2ae925e0475dc08fcb50 WHIRLPOOL 7a840b5878b409d89a61dcca40632448e7b5a402b0e26ba03a65f3384a9491f06c2c69279cdfcc0013e2b6d7ee0de619d17437a60990d19f674653d29c83502a
diff --git a/www-servers/gunicorn/gunicorn-19.3.0.ebuild b/www-servers/gunicorn/gunicorn-19.3.0.ebuild
new file mode 100644
index 00000000000..d50ed822d76
--- /dev/null
+++ b/www-servers/gunicorn/gunicorn-19.3.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A WSGI HTTP Server for UNIX"
+HOMEPAGE="http://gunicorn.org http://pypi.python.org/pypi/gunicorn https://github.com/benoitc/gunicorn"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+RDEPEND="dev-python/setproctitle[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+DOCS="README.rst"
+
+python_prepare_all() {
+ # these tests requires an already installed version of gunicorn
+ rm tests/test_003-config.py || die
+
+ sed -ie "s/..\/bin/\/usr\/bin\//" docs/Makefile || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ py.test -v || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ use examples && EXAMPLES=( examples/. )
+
+ distutils-r1_python_install_all
+}