summaryrefslogtreecommitdiff
path: root/www-servers/skunkweb/skunkweb-3.4.4.ebuild
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-servers/skunkweb/skunkweb-3.4.4.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-servers/skunkweb/skunkweb-3.4.4.ebuild')
-rw-r--r--www-servers/skunkweb/skunkweb-3.4.4.ebuild80
1 files changed, 80 insertions, 0 deletions
diff --git a/www-servers/skunkweb/skunkweb-3.4.4.ebuild b/www-servers/skunkweb/skunkweb-3.4.4.ebuild
new file mode 100644
index 00000000000..dfb98e3fa50
--- /dev/null
+++ b/www-servers/skunkweb/skunkweb-3.4.4.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+PYTHON_DEPEND="2"
+
+inherit apache-module eutils multilib python user
+
+DESCRIPTION="robust Python web application server"
+HOMEPAGE="http://skunkweb.sourceforge.net/"
+SRC_URI="mirror://sourceforge/skunkweb/${P}.tar.gz"
+
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="app-admin/sudo
+ >=dev-python/egenix-mx-base-2.0.4"
+RDEPEND="${DEPEND}"
+
+need_apache
+
+APACHE2_MOD_FILE="${S}/SkunkWeb/mod_skunkweb/.libs/mod_skunkweb.so"
+APACHE2_MOD_DEFINE="SKUNKWEB"
+APACHE2_MOD_CONF="100_mod_skunkweb"
+
+pkg_setup() {
+ enewgroup skunkweb
+ enewuser skunkweb -1 -1 /usr/share/skunkweb skunkweb
+
+ python_set_active_version 2
+}
+
+src_configure() {
+ econf \
+ --with-user=skunkweb \
+ --with-group=skunkweb \
+ --localstatedir=/var/lib/skunkweb \
+ --bindir=/usr/bin \
+ --libdir=/usr/$(get_libdir)/skunkweb \
+ --sysconfdir=/etc/skunkweb \
+ --prefix=/usr/share/skunkweb \
+ --with-cache=/var/lib/skunkweb/cache \
+ --with-docdir=/usr/share/doc/${P} \
+ --with-logdir=/var/log/skunkweb \
+ --with-python="$(PYTHON -a)" \
+ --with-apxs=${APXS}
+}
+
+src_compile() {
+ default
+}
+
+src_install() {
+ emake DESTDIR="${D}" APXSFLAGS="-c" install || die "emake install failed"
+ apache-module_src_install
+
+ python_need_rebuild
+
+ keepdir /var/{lib,log}/${PN}
+ keepdir /var/lib/${PN}/run
+ fowners skunkweb:skunkweb /var/{lib,log}/${PN}
+
+ newinitd "${FILESDIR}"/skunkweb-init skunkweb
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}"/skunkweb-cron-cache_cleaner skunkweb-cache_cleaner
+
+ dodoc README ChangeLog NEWS HACKING ACKS INSTALL
+}
+
+pkg_postinst() {
+ apache-module_pkg_postinst
+ python_mod_optimize /usr/$(get_libdir)/skunkweb
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/$(get_libdir)/skunkweb
+}