summaryrefslogtreecommitdiff
path: root/x11-apps/python-whiteboard
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-apps/python-whiteboard
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-apps/python-whiteboard')
-rw-r--r--x11-apps/python-whiteboard/Manifest1
-rw-r--r--x11-apps/python-whiteboard/metadata.xml29
-rw-r--r--x11-apps/python-whiteboard/python-whiteboard-20101012.ebuild36
3 files changed, 66 insertions, 0 deletions
diff --git a/x11-apps/python-whiteboard/Manifest b/x11-apps/python-whiteboard/Manifest
new file mode 100644
index 00000000000..440a2dc4c49
--- /dev/null
+++ b/x11-apps/python-whiteboard/Manifest
@@ -0,0 +1 @@
+DIST python-whiteboard-20101012.tar.bz2 131944 SHA256 0270ab3f636ba079261a6e9e093fd5f622e91b07399d4773c050c8904db61630
diff --git a/x11-apps/python-whiteboard/metadata.xml b/x11-apps/python-whiteboard/metadata.xml
new file mode 100644
index 00000000000..53c49846ae4
--- /dev/null
+++ b/x11-apps/python-whiteboard/metadata.xml
@@ -0,0 +1,29 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>lxnay@gentoo.org</email>
+ <name>Fabio Erculiani</name>
+ <description>Maintainer. Assign bugs to him</description>
+ </maintainer>
+ <maintainer>
+ <email>ziapannocchia@gmail.com</email>
+ <name>Marco Clocchiatti</name>
+ <description>Proxy maintainer. CC him on bugs</description>
+ </maintainer>
+ <longdescription lang="en">
+ Build and operate an electronic whiteboard using gnu/linux, a wiimote and an IR pen.
+ </longdescription>
+ <upstream>
+ <maintainer status="active">
+ <email/>
+ <name>Pietro Pilloli</name>
+ </maintainer>
+ <changelog>https://github.com/pnegre/python-whiteboard/commits/master</changelog>
+ <doc>https://github.com/pnegre/python-whiteboard/wiki</doc>
+ <bugs-to>http://groups.google.com/group/python-whiteboard</bugs-to>
+ <remote-id type="sourceforge">git://github.com/pnegre/python-whiteboard.git</remote-id>
+ <remote-id type="github">pnegre/python-whiteboard</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-apps/python-whiteboard/python-whiteboard-20101012.ebuild b/x11-apps/python-whiteboard/python-whiteboard-20101012.ebuild
new file mode 100644
index 00000000000..bf1a73fd954
--- /dev/null
+++ b/x11-apps/python-whiteboard/python-whiteboard-20101012.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+inherit python multilib
+
+SRC_URI="http://dev.gentoo.org/~lxnay/${PN}/${P}.tar.bz2"
+
+KEYWORDS="~x86 ~amd64"
+DESCRIPTION="Build and operate a electronic whiteboard Wiimote and IR Pen"
+HOMEPAGE="http://github.com/pnegre/python-whiteboard"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+RDEPEND="app-misc/cwiid[python]
+ dev-python/numpy
+ dev-python/pybluez
+ dev-python/PyQt4
+ dev-python/python-xlib"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}
+
+pkg_postinst() {
+ python_mod_optimize "/usr/$(get_libdir)/${PN}"
+}
+
+pkg_postrm() {
+ python_mod_cleanup "/usr/$(get_libdir)/${PN}"
+}