summaryrefslogtreecommitdiff
path: root/x11-apps/xman
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-apps/xman
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-apps/xman')
-rw-r--r--x11-apps/xman/Manifest2
-rw-r--r--x11-apps/xman/files/xman-1.1.3-mandb-2.7.patch60
-rw-r--r--x11-apps/xman/metadata.xml5
-rw-r--r--x11-apps/xman/xman-1.1.3-r1.ebuild22
-rw-r--r--x11-apps/xman/xman-1.1.3.ebuild18
-rw-r--r--x11-apps/xman/xman-1.1.4.ebuild22
6 files changed, 129 insertions, 0 deletions
diff --git a/x11-apps/xman/Manifest b/x11-apps/xman/Manifest
new file mode 100644
index 00000000000..59e0368d157
--- /dev/null
+++ b/x11-apps/xman/Manifest
@@ -0,0 +1,2 @@
+DIST xman-1.1.3.tar.bz2 184340 SHA256 405211b606a7fa420029897f099dc107791bb4c29bc88481c6efac9c4590bb1a SHA512 7c6475434984205f359ff3cb47a41282536be6aefe7bc6e970736c4372b23b5de01a26864d7f5b2cae2f770eeef6d254ebbdf6db717b5efab0042a47cb7497be WHIRLPOOL bb3870840c627ac12122dbf038c2488e9c6e7dbf243d3efa74c8fa26f5bb07c261aa5550ccf36cb37314b4344b2e96a3b862b58b8d1dac1f6e78d2519cb86f0d
+DIST xman-1.1.4.tar.bz2 188259 SHA256 b3fa9d2e3f3745c529eb0b6ee4f0e00d936457d11e5221b2efad06ff7c84df29 SHA512 785e973eb15b0300de08aace24f3604dfee61421c7f64ea4cde2e280480bf5d3ad797ab8208668dc023a375494f8db7534fbcaa1c1ef16e79464fdd017b5da68 WHIRLPOOL 846fc19937832074e04ec69b9b4f05c1966b00dccc28993b168659b478b7ace6ef88c473fb4c9cf378e0fd96b26f7b571d0b532eae89ec28d64a413f4af9c88f
diff --git a/x11-apps/xman/files/xman-1.1.3-mandb-2.7.patch b/x11-apps/xman/files/xman-1.1.3-mandb-2.7.patch
new file mode 100644
index 00000000000..f42ce577c2b
--- /dev/null
+++ b/x11-apps/xman/files/xman-1.1.3-mandb-2.7.patch
@@ -0,0 +1,60 @@
+From 438763b6e231410b95b5e352feb65c63cd54de6a Mon Sep 17 00:00:00 2001
+From: Julien Cristau <jcristau@debian.org>
+Date: Fri, 7 Nov 2014 16:19:57 +0000
+Subject: [PATCH] If we have man-db, don't try and emulate man's pipeline
+
+Just let man itself do the formatting / zsoelim / ... dance.
+
+Debian bug#764792 <https://bugs.debian.org/764792>
+
+Signed-off-by: Julien Cristau <jcristau@debian.org>
+---
+ xman/configure.ac | 5 +++++
+ xman/misc.c | 8 ++++++++
+ 2 files changed, 13 insertions(+)
+
+diff --git a/xman/configure.ac b/xman/configure.ac
+index 9a80cbb..8bb44f2 100644
+--- a/xman/configure.ac
++++ b/xman/configure.ac
+@@ -44,6 +44,11 @@ if test "x$GROFF" = "xfound" ; then
+ AC_DEFINE([HAS_GROFF], 1, [Define to 1 if you have the groff package.])
+ fi
+
++AC_CHECK_PROG([MANDB], [mandb], [yes], [no])
++if test x"$MANDB" = xyes; then
++ AC_DEFINE([HAVE_MANDB], 1, [Define if the man implementation is man-db])
++fi
++
+ AC_CHECK_FUNCS([mkstemp])
+
+ AC_ARG_WITH(helpdir,
+diff --git a/xman/misc.c b/xman/misc.c
+index 06891cd..da8744a 100644
+--- a/xman/misc.c
++++ b/xman/misc.c
+@@ -661,6 +661,13 @@ static Boolean
+ ConstructCommand(char *cmdbuf, const char *path,
+ const char *filename, const char *tempfile)
+ {
++#ifdef HAVE_MANDB
++ int used = snprintf(cmdbuf, BUFSIZ, "man -l %s > %s 2>/dev/null",
++ filename, tempfile);
++ if (used >= BUFSIZ - 1)
++ return FALSE;
++ return TRUE;
++#else
+ /* The original code did the following to produce a command line:
+ * sprintf(cmdbuf,"cd %s ; %s %s %s > %s %s", path, TBL,
+ * filename, FORMAT, man_globals->tempfile, "2> /dev/null");
+@@ -783,6 +790,7 @@ ConstructCommand(char *cmdbuf, const char *path,
+ return (FALSE);
+
+ return (TRUE);
++#endif /* man-db */
+ }
+ #endif /* HANDLE_ROFFSEQ */
+
+--
+2.1.1
+
diff --git a/x11-apps/xman/metadata.xml b/x11-apps/xman/metadata.xml
new file mode 100644
index 00000000000..01c4c004e73
--- /dev/null
+++ b/x11-apps/xman/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>x11</herd>
+</pkgmetadata>
diff --git a/x11-apps/xman/xman-1.1.3-r1.ebuild b/x11-apps/xman/xman-1.1.3-r1.ebuild
new file mode 100644
index 00000000000..431922e0d30
--- /dev/null
+++ b/x11-apps/xman/xman-1.1.3-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+XORG_EAUTORECONF=yes
+inherit xorg-2
+
+DESCRIPTION="Manual page display program for the X Window System"
+
+KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND="x11-libs/libXaw
+ x11-libs/libXt
+ x11-libs/libXmu
+ x11-proto/xproto"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1.3-mandb-2.7.patch
+)
diff --git a/x11-apps/xman/xman-1.1.3.ebuild b/x11-apps/xman/xman-1.1.3.ebuild
new file mode 100644
index 00000000000..9cb8ab30d26
--- /dev/null
+++ b/x11-apps/xman/xman-1.1.3.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit xorg-2
+
+DESCRIPTION="Manual page display program for the X Window System"
+
+KEYWORDS="amd64 arm hppa ~mips ppc ppc64 ~s390 ~sh sparc x86"
+IUSE=""
+
+DEPEND="x11-libs/libXaw
+ x11-libs/libXt
+ x11-libs/libXmu
+ x11-proto/xproto"
+RDEPEND="${DEPEND}
+ !>=sys-apps/man-db-2.7"
diff --git a/x11-apps/xman/xman-1.1.4.ebuild b/x11-apps/xman/xman-1.1.4.ebuild
new file mode 100644
index 00000000000..431922e0d30
--- /dev/null
+++ b/x11-apps/xman/xman-1.1.4.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+XORG_EAUTORECONF=yes
+inherit xorg-2
+
+DESCRIPTION="Manual page display program for the X Window System"
+
+KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND="x11-libs/libXaw
+ x11-libs/libXt
+ x11-libs/libXmu
+ x11-proto/xproto"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1.3-mandb-2.7.patch
+)