summaryrefslogtreecommitdiff
path: root/x11-libs/gtkhotkey
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-libs/gtkhotkey
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-libs/gtkhotkey')
-rw-r--r--x11-libs/gtkhotkey/Manifest1
-rw-r--r--x11-libs/gtkhotkey/files/gtkhotkey-0.2.1-glibheaders.patch22
-rw-r--r--x11-libs/gtkhotkey/gtkhotkey-0.2.1.ebuild43
-rw-r--r--x11-libs/gtkhotkey/metadata.xml10
4 files changed, 76 insertions, 0 deletions
diff --git a/x11-libs/gtkhotkey/Manifest b/x11-libs/gtkhotkey/Manifest
new file mode 100644
index 00000000000..d3ec0f24516
--- /dev/null
+++ b/x11-libs/gtkhotkey/Manifest
@@ -0,0 +1 @@
+DIST gtkhotkey-0.2.1.tar.gz 382043 SHA256 fe1cf0d93026d791e856170356f56fbdff9095fe637c4a74104144c1e5111d67 SHA512 7f7e1b9bd94ff806d98277f2dafbf5b6569efdc6f0367a83e885d38584a8f6e098f31d0f03b080f2ca76394eb73e43f9da07e0d944a2e6443a55d9f2e8fee324 WHIRLPOOL 4fb7e1a131ae64c4fa0901c6444fdeb9af97cd0b85f48e282e5cc08877222f32eca9b1f279b072c2d49a8414839384560abed1d8bbc5cad94e64c09d875cb8bc
diff --git a/x11-libs/gtkhotkey/files/gtkhotkey-0.2.1-glibheaders.patch b/x11-libs/gtkhotkey/files/gtkhotkey-0.2.1-glibheaders.patch
new file mode 100644
index 00000000000..389db601c43
--- /dev/null
+++ b/x11-libs/gtkhotkey/files/gtkhotkey-0.2.1-glibheaders.patch
@@ -0,0 +1,22 @@
+diff -Nurp gtkhotkey-0.2.1/src/gtk-hotkey-error.h gtkhotkey-0.2.1_patched//src/gtk-hotkey-error.h
+--- gtkhotkey-0.2.1/src/gtk-hotkey-error.h 2009-09-03 22:52:49.000000000 +0200
++++ gtkhotkey-0.2.1_patched//src/gtk-hotkey-error.h 2012-02-19 12:04:19.483701649 +0100
+@@ -23,7 +23,7 @@
+ #ifndef __GTK_HOTKEY_ERROR_H__
+ #define __GTK_HOTKEY_ERROR_H__
+
+-#include <glib/gquark.h>
++#include <glib.h>
+
+ G_BEGIN_DECLS
+
+--- gtkhotkey-0.2.1/src/x11/tomboykeybinder.h 2009-09-03 22:52:49.000000000 +0200
++++ gtkhotkey-0.2.1-r1/src/x11/tomboykeybinder.h 2012-02-19 21:40:09.004325272 +0100
+@@ -2,7 +2,7 @@
+ #ifndef __TOMBOY_KEY_BINDER_H__
+ #define __TOMBOY_KEY_BINDER_H__
+
+-#include <glib/gtypes.h>
++#include <glib.h>
+
+ G_BEGIN_DECLS
diff --git a/x11-libs/gtkhotkey/gtkhotkey-0.2.1.ebuild b/x11-libs/gtkhotkey/gtkhotkey-0.2.1.ebuild
new file mode 100644
index 00000000000..f430a38d568
--- /dev/null
+++ b/x11-libs/gtkhotkey/gtkhotkey-0.2.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit versionator eutils
+
+MY_CRV=$(get_version_component_range 1-2)
+
+RESTRICT="test"
+# Tests try to access live filesystem
+# See http://bugs.gentoo.org/show_bug.cgi?id=259052#c3
+
+DESCRIPTION="Cross platform library for using desktop wide hotkeys"
+HOMEPAGE="http://launchpad.net/gtkhotkey"
+SRC_URI="http://launchpad.net/${PN}/${MY_CRV}/${PV}/+download/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+COMMON_DEPEND=">=dev-libs/glib-2.16
+ >=x11-libs/gtk+-2.12:2"
+
+RDEPEND="${COMMON_DEPEND}
+ virtual/libintl"
+
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+ >=dev-util/intltool-0.35.0
+ sys-devel/gettext"
+
+src_prepare() {
+ sed -i -e "s: install-gtkhotkeydocDATA ::" Makefile.in || die "Patching Makefile.in failed"
+ epatch "${FILESDIR}"/${P}-glibheaders.patch
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README || die "dodoc failed"
+}
diff --git a/x11-libs/gtkhotkey/metadata.xml b/x11-libs/gtkhotkey/metadata.xml
new file mode 100644
index 00000000000..3a0f048396d
--- /dev/null
+++ b/x11-libs/gtkhotkey/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="launchpad">gtkhotkey</remote-id>
+ </upstream>
+</pkgmetadata>