summaryrefslogtreecommitdiff
path: root/x11-libs/hippo-canvas
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-libs/hippo-canvas
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-libs/hippo-canvas')
-rw-r--r--x11-libs/hippo-canvas/Manifest1
-rw-r--r--x11-libs/hippo-canvas/files/hippo-canvas-python-override.patch10
-rw-r--r--x11-libs/hippo-canvas/hippo-canvas-0.3.0-r2.ebuild53
-rw-r--r--x11-libs/hippo-canvas/metadata.xml12
4 files changed, 76 insertions, 0 deletions
diff --git a/x11-libs/hippo-canvas/Manifest b/x11-libs/hippo-canvas/Manifest
new file mode 100644
index 00000000000..a867825fa4b
--- /dev/null
+++ b/x11-libs/hippo-canvas/Manifest
@@ -0,0 +1 @@
+DIST hippo-canvas-0.3.0.tar.bz2 376859 SHA256 21d0f3f7eb1c448fd6eaec1979b1474011b541249edaaab6e1dfb772ac8eb514 SHA512 8290f6ab1875eed606ea152f12741ec4ebd8839091a9c258b8c4fa39f395adf94217576c6c689c5ab22b62c65e37d82991c7b8942815cb2030bd45616528f4f3 WHIRLPOOL 2b78ce076c1e6f8bfa40fad38e036cc583739b99801c5a550ad835484da255a8ee7c21d086f748c81707a5b262d65b7c95bbfe1a5fd01812d93409f42e7ba76b
diff --git a/x11-libs/hippo-canvas/files/hippo-canvas-python-override.patch b/x11-libs/hippo-canvas/files/hippo-canvas-python-override.patch
new file mode 100644
index 00000000000..bcbae474160
--- /dev/null
+++ b/x11-libs/hippo-canvas/files/hippo-canvas-python-override.patch
@@ -0,0 +1,10 @@
+--- hippo.override 2008-05-21 16:22:02.000000000 -0700
++++ hippo.override-new 2010-04-13 13:11:20.826177339 -0700
+@@ -19,6 +19,7 @@
+ #include "hippo/hippo-canvas-widget.h"
+ #include "hippo/hippo-canvas-window.h"
+ #include "hippo/hippo-canvas-widgets.h"
++#include "common/hippo/hippo-canvas-test.h"
+
+ #include "hippo/hippo-canvas-type-builtins.h"
+
diff --git a/x11-libs/hippo-canvas/hippo-canvas-0.3.0-r2.ebuild b/x11-libs/hippo-canvas/hippo-canvas-0.3.0-r2.ebuild
new file mode 100644
index 00000000000..956e9fd4156
--- /dev/null
+++ b/x11-libs/hippo-canvas/hippo-canvas-0.3.0-r2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+GCONF_DEBUG="no"
+GNOME_TARBALL_SUFFIX="bz2"
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils gnome2 multilib python-single-r1
+
+DESCRIPTION="A canvas library based on GTK+ 2, Cairo, and Pango"
+HOMEPAGE="https://wiki.gnome.org/Projects/HippoCanvas"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+IUSE="python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ >=dev-libs/glib-2.6:2
+ dev-libs/libcroco
+ >=x11-libs/gtk+-2.6:2
+ x11-libs/pango
+ gnome-base/librsvg:2
+ python? (
+ ${PYTHON_DEPS}
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygtk:2[${PYTHON_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ cd "${S}/python"
+ epatch "${FILESDIR}/${PN}-python-override.patch"
+ cd "${S}"
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable python)
+}
diff --git a/x11-libs/hippo-canvas/metadata.xml b/x11-libs/hippo-canvas/metadata.xml
new file mode 100644
index 00000000000..b0b69c25dfc
--- /dev/null
+++ b/x11-libs/hippo-canvas/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
+ HippoCanvas is a generic user interface element that can draw Cairo graphics, respond to key and mouse events,
+ and lay out other widgets. It is currently used to implement a number of Sugar's custom widgets (toolbars,
+ rounded buttons, etc.) and to lay out the screen.
+ </longdescription>
+</pkgmetadata>