summaryrefslogtreecommitdiff
path: root/x11-libs/libdrm
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2016-07-21 11:52:49 -0700
committerMatt Turner <mattst88@gentoo.org>2016-07-21 11:53:25 -0700
commit8b097c4223a19d521aac6c358a33de69063911ab (patch)
tree4142c9b21ff5743d7a00cd3273c0944163c29ca9 /x11-libs/libdrm
parent70320ac0d9efad37cd29fe131360f3d29aed072d (diff)
downloadgentoo-8b097c4223a19d521aac6c358a33de69063911ab.tar.gz
gentoo-8b097c4223a19d521aac6c358a33de69063911ab.tar.xz
x11-libs/libdrm: Version bump to 2.4.69.
Diffstat (limited to 'x11-libs/libdrm')
-rw-r--r--x11-libs/libdrm/Manifest1
-rw-r--r--x11-libs/libdrm/libdrm-2.4.69.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/x11-libs/libdrm/Manifest b/x11-libs/libdrm/Manifest
index 9a02d81e54c..6fcc51305ae 100644
--- a/x11-libs/libdrm/Manifest
+++ b/x11-libs/libdrm/Manifest
@@ -3,3 +3,4 @@ DIST libdrm-2.4.65.tar.bz2 645877 SHA256 71960ac8bde7d710992b1bc8879935e8300a870
DIST libdrm-2.4.66.tar.bz2 694574 SHA256 79cb8e988749794edfb2d777b298d5292eff353bbbb71ed813589e61d2bc2d76 SHA512 e0e3cea490389271690a79b5be8acd5e7c892a0646285617bd00d85f7c56ac163580c8c62d9fa79ed99e89468e35eaed6ac8be6ea870ce5ab09589f3e2d7f506 WHIRLPOOL 6f691c8f7444b70461896f2b91a5256c655124c12cb51b25163859db2f556692d182e43b79a851cbc8d565fde1cbe146133d177dbabe442289ab051170b6a695
DIST libdrm-2.4.67.tar.bz2 689483 SHA256 ee5b71e1113be37544d0752681c12f040c01f782e2933df7d7bc21fd0d10cebe SHA512 3c48828b65b32a5e6a17b05b05d17ea02315b1c86c730d386d0680f2d8f312477cf5adc810a898a3734504c96ff376fc46b2d813b34cb8fe84a70b533c18ac2a WHIRLPOOL 134cdb80b035ba87027cbc074a05c1ed66eec4d462846f48b8c56e8eedd7b2b32dc9c6abeb01b0e9bf41f96364ab0bd59b881ef58651aded832b644faa2bd648
DIST libdrm-2.4.68.tar.bz2 735554 SHA256 5b4bd9a5922929bc716411cb74061fbf31b06ba36feb89bc1358a91a8d0ca9df SHA512 646ce2eb6b4d81120d5767f0c4014bfd042ea7030e33aa9a1d016129222d22a0dd012e530d37e1d580f4cc9f4d38e35176ce4d7abeccc086b38ba685cff8e38e WHIRLPOOL 75defa050c11874c7cda511b0aafc559a9a94adb8d6f5beb0434ddd387b6014580462362e1c2a025c5057ee5273497d1e43e840e5230635408fd9f04837f21c8
+DIST libdrm-2.4.69.tar.bz2 817990 SHA256 09510cbc75adba7e84fd3ec86586fd352a787fd534a63377de9e19ff85280b33 SHA512 8d67a692c5dc059a1705014658e737fde7be9181b03c04b37119c84978aada1eaec23e674a83cc064ed0cc59838f69a5c31864e5355689d0a1e88309982e832c WHIRLPOOL 7ccaa10f2ddcaa27b04c902f689c1a9619d618990b17e2dc4f2d9be5e2c2882ec6fe0ddd129992e20618f9723aa536324986f20408c551e40e3ee8bd89f9a3e6
diff --git a/x11-libs/libdrm/libdrm-2.4.69.ebuild b/x11-libs/libdrm/libdrm-2.4.69.ebuild
new file mode 100644
index 00000000000..1936f693c8a
--- /dev/null
+++ b/x11-libs/libdrm/libdrm-2.4.69.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+XORG_MULTILIB=yes
+inherit xorg-2
+
+DESCRIPTION="X.Org libdrm library"
+HOMEPAGE="https://dri.freedesktop.org/"
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="git://anongit.freedesktop.org/git/mesa/drm"
+else
+ SRC_URI="https://dri.freedesktop.org/${PN}/${P}.tar.bz2"
+fi
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~arm-linux ~x86-linux"
+VIDEO_CARDS="amdgpu exynos freedreno intel nouveau omap radeon tegra vc4 vmware"
+for card in ${VIDEO_CARDS}; do
+ IUSE_VIDEO_CARDS+=" video_cards_${card}"
+done
+
+IUSE="${IUSE_VIDEO_CARDS} libkms valgrind"
+RESTRICT="test" # see bug #236845
+
+RDEPEND=">=dev-libs/libpthread-stubs-0.3-r1:=[${MULTILIB_USEDEP}]
+ video_cards_intel? ( >=x11-libs/libpciaccess-0.13.1-r1:=[${MULTILIB_USEDEP}] )
+ abi_x86_32? ( !app-emulation/emul-linux-x86-opengl[-abi_x86_32(-)] )"
+DEPEND="${RDEPEND}
+ valgrind? ( dev-util/valgrind )"
+
+src_prepare() {
+ if [[ ${PV} = 9999* ]]; then
+ # tests are restricted, no point in building them
+ sed -ie 's/tests //' "${S}"/Makefile.am
+ fi
+ xorg-2_src_prepare
+}
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS=(
+ # Udev is only used by tests now.
+ --disable-udev
+ --disable-cairo-tests
+ $(use_enable video_cards_amdgpu amdgpu)
+ $(use_enable video_cards_exynos exynos-experimental-api)
+ $(use_enable video_cards_freedreno freedreno)
+ $(use_enable video_cards_intel intel)
+ $(use_enable video_cards_nouveau nouveau)
+ $(use_enable video_cards_omap omap-experimental-api)
+ $(use_enable video_cards_radeon radeon)
+ $(use_enable video_cards_tegra tegra-experimental-api)
+ $(use_enable video_cards_vc4 vc4)
+ $(use_enable video_cards_vmware vmwgfx)
+ $(use_enable libkms)
+ # valgrind installs its .pc file to the pkgconfig for the primary arch
+ --enable-valgrind=$(usex valgrind auto no)
+ )
+
+ xorg-2_src_configure
+}