summaryrefslogtreecommitdiff
path: root/x11-libs/libdrm
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-09-17 10:58:30 +0200
committerManuel Rüger <mrueg@gentoo.org>2015-09-17 10:58:30 +0200
commit8cde0aa2a2167b2aacb54dfe1739b001dafb81ff (patch)
tree693de98d52074090ebaec8aa9d8e3e06c7e8d5e0 /x11-libs/libdrm
parent2bdd3d55e7ef03fdd661b4a315db08c7309b3a97 (diff)
downloadgentoo-8cde0aa2a2167b2aacb54dfe1739b001dafb81ff.tar.gz
gentoo-8cde0aa2a2167b2aacb54dfe1739b001dafb81ff.tar.xz
x11-libs/libdrm: Version bump
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'x11-libs/libdrm')
-rw-r--r--x11-libs/libdrm/Manifest1
-rw-r--r--x11-libs/libdrm/libdrm-2.4.65.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/x11-libs/libdrm/Manifest b/x11-libs/libdrm/Manifest
index 4d006866334..098826aba1a 100644
--- a/x11-libs/libdrm/Manifest
+++ b/x11-libs/libdrm/Manifest
@@ -1,2 +1,3 @@
DIST libdrm-2.4.59.tar.bz2 592722 SHA256 68d26e1fd85582f4243d66864f9b43ca4ee93662825de32b5506fc8e181ea41b SHA512 b9f61cfd47cf4a02c10e7fe79b0e9c5701383c76425cf4985a9b91d909f905334ca1ace7334aa0a4ab400694ad84a1a3bc1c3f29842d808026702b35fa9f87c3 WHIRLPOOL 6b0e1be70164db86152503e4b72373736f0462ff97ffac2c79a6c1fce83d658e6030d5435be5a61c1f6ca50728db4c7e3a5d8f5e48073fc74169696ff1b7c5be
DIST libdrm-2.4.64.tar.bz2 640440 SHA256 b60786fe7d6e42adb3966ce1a658f63fec528d537396381cbda93bcc99a934b6 SHA512 f4fae23b981c761622b6170ae1f5bc805fc9fe2c5f3531dd45b3e3fcb65c4c4f08d39744c30e2d7f9c14ce6f13dac4a655c0b0ca9785965c59917a4e594e507b WHIRLPOOL 49a96a5d2795f2a9c9fca5cc5808cbfa5e06717d7f4b8221cee55288e16cee503a109321aea04680900fb0bc80e56482a6c8cd15e887eee3d327f0af52706fac
+DIST libdrm-2.4.65.tar.bz2 645877 SHA256 71960ac8bde7d710992b1bc8879935e8300a870c36bd06f22412d0447e3d96c4 SHA512 fabbb3ba163aa1307288472c11c6ce8f1e412cbd67ba3135a614f0e05bf4f881bf6ccc581e9cf05a7e2e965817bb71c0b5335263b5c0b0cb85829a0f29a6029d WHIRLPOOL b00d7aed0437ee0f64f60ed59becf41d165c101725cab700345203b2108a2adc9ed95d17acc0dff5706df86c87c13d058991417f42db40dfc523279cc5eb8547
diff --git a/x11-libs/libdrm/libdrm-2.4.65.ebuild b/x11-libs/libdrm/libdrm-2.4.65.ebuild
new file mode 100644
index 00000000000..8ec9f11f5ef
--- /dev/null
+++ b/x11-libs/libdrm/libdrm-2.4.65.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+XORG_MULTILIB=yes
+inherit xorg-2
+
+DESCRIPTION="X.Org libdrm library"
+HOMEPAGE="http://dri.freedesktop.org/"
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="git://anongit.freedesktop.org/git/mesa/drm"
+else
+ SRC_URI="http://dri.freedesktop.org/${PN}/${P}.tar.bz2"
+fi
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~arm-linux ~x86-linux"
+VIDEO_CARDS="amdgpu exynos freedreno intel nouveau omap radeon tegra vmware"
+for card in ${VIDEO_CARDS}; do
+ IUSE_VIDEO_CARDS+=" video_cards_${card}"
+done
+
+IUSE="${IUSE_VIDEO_CARDS} libkms valgrind"
+RESTRICT="test" # see bug #236845
+
+RDEPEND=">=dev-libs/libpthread-stubs-0.3-r1:=[${MULTILIB_USEDEP}]
+ video_cards_intel? ( >=x11-libs/libpciaccess-0.13.1-r1:=[${MULTILIB_USEDEP}] )
+ abi_x86_32? ( !app-emulation/emul-linux-x86-opengl[-abi_x86_32(-)] )"
+DEPEND="${RDEPEND}
+ valgrind? ( dev-util/valgrind )"
+
+src_prepare() {
+ if [[ ${PV} = 9999* ]]; then
+ # tests are restricted, no point in building them
+ sed -ie 's/tests //' "${S}"/Makefile.am
+ fi
+ xorg-2_src_prepare
+}
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS=(
+ # Udev is only used by tests now.
+ --disable-udev
+ --disable-cairo-tests
+ $(use_enable video_cards_amdgpu amdgpu)
+ $(use_enable video_cards_exynos exynos-experimental-api)
+ $(use_enable video_cards_freedreno freedreno)
+ $(use_enable video_cards_intel intel)
+ $(use_enable video_cards_nouveau nouveau)
+ $(use_enable video_cards_omap omap-experimental-api)
+ $(use_enable video_cards_radeon radeon)
+ $(use_enable video_cards_tegra tegra-experimental-api)
+ $(use_enable video_cards_vmware vmwgfx)
+ $(use_enable libkms)
+ # valgrind installs its .pc file to the pkgconfig for the primary arch
+ --enable-valgrind=$(usex valgrind auto no)
+ )
+
+ xorg-2_src_configure
+}