summaryrefslogtreecommitdiff
path: root/x11-libs/libpciaccess
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-libs/libpciaccess
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-libs/libpciaccess')
-rw-r--r--x11-libs/libpciaccess/Manifest2
-rw-r--r--x11-libs/libpciaccess/libpciaccess-0.13.3.ebuild35
-rw-r--r--x11-libs/libpciaccess/libpciaccess-0.13.4.ebuild35
-rw-r--r--x11-libs/libpciaccess/metadata.xml5
4 files changed, 77 insertions, 0 deletions
diff --git a/x11-libs/libpciaccess/Manifest b/x11-libs/libpciaccess/Manifest
new file mode 100644
index 00000000000..17fb92cc04b
--- /dev/null
+++ b/x11-libs/libpciaccess/Manifest
@@ -0,0 +1,2 @@
+DIST libpciaccess-0.13.3.tar.bz2 368755 SHA256 6cd76ccae4e06eee47d3ead84a118740e9406e2a9b7adc9b08e92c69ce89c2e3 SHA512 11ad783c6278e340973a621339cece3776c098952d0eaf96bfe745d013347e928c0883ed8444c5ddea870f5e4b3c25da16a44facb9d7fc1c8fea1c7e77bd592b WHIRLPOOL 92ba320540535c2b2811c29272a2d94dd3c1f586a0e3073ed4678c03cb3e30656772ad6b0a3e9612a0972a28cfe0d9c4c93ea955610e609fb103a15bb8051e31
+DIST libpciaccess-0.13.4.tar.bz2 372004 SHA256 07f864654561e4ac8629a0ef9c8f07fbc1f8592d1b6c418431593e9ba2cf2fcf SHA512 d5b32c525dd36dc85c9a09f45696808730eabbbd3cce892a6dbfb02a566598baad27be58567eb7ced15b3d99fb9afa1d1c24ec19754bcf7a1857a0c8cea34d92 WHIRLPOOL d48ecb99e7e31bc1c13e779261b7ae579ca28a054b20521cb7503c2bfe3182fa2f96c939eee0ebcca1783f3f38c07535173a3bb9a0713834cadd4b9709f25174
diff --git a/x11-libs/libpciaccess/libpciaccess-0.13.3.ebuild b/x11-libs/libpciaccess/libpciaccess-0.13.3.ebuild
new file mode 100644
index 00000000000..b35235fb441
--- /dev/null
+++ b/x11-libs/libpciaccess/libpciaccess-0.13.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+XORG_MULTILIB=yes
+inherit xorg-2
+
+DESCRIPTION="Library providing generic access to the PCI bus and devices"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~arm-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="minimal zlib"
+
+DEPEND="!<x11-base/xorg-server-1.5
+ zlib? ( >=sys-libs/zlib-1.2.8-r1:=[${MULTILIB_USEDEP}] )"
+RDEPEND="${DEPEND}
+ sys-apps/hwids"
+
+pkg_setup() {
+ xorg-2_pkg_setup
+
+ XORG_CONFIGURE_OPTIONS=(
+ "$(use_with zlib)"
+ "--with-pciids-path=${EPREFIX}/usr/share/misc"
+ )
+}
+
+multilib_src_install() {
+ default
+
+ if multilib_is_native_abi; then
+ dodir /usr/bin
+ ${BASH} libtool --mode=install "$(type -P install)" -c scanpci/scanpci "${ED}"/usr/bin || die
+ fi
+}
diff --git a/x11-libs/libpciaccess/libpciaccess-0.13.4.ebuild b/x11-libs/libpciaccess/libpciaccess-0.13.4.ebuild
new file mode 100644
index 00000000000..7e58b9b95ef
--- /dev/null
+++ b/x11-libs/libpciaccess/libpciaccess-0.13.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+XORG_MULTILIB=yes
+inherit xorg-2
+
+DESCRIPTION="Library providing generic access to the PCI bus and devices"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~arm-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="minimal zlib"
+
+DEPEND="!<x11-base/xorg-server-1.5
+ zlib? ( >=sys-libs/zlib-1.2.8-r1:=[${MULTILIB_USEDEP}] )"
+RDEPEND="${DEPEND}
+ sys-apps/hwids"
+
+pkg_setup() {
+ xorg-2_pkg_setup
+
+ XORG_CONFIGURE_OPTIONS=(
+ "$(use_with zlib)"
+ "--with-pciids-path=${EPREFIX}/usr/share/misc"
+ )
+}
+
+multilib_src_install() {
+ default
+
+ if multilib_is_native_abi; then
+ dodir /usr/bin
+ ${BASH} libtool --mode=install "$(type -P install)" -c scanpci/scanpci "${ED}"/usr/bin || die
+ fi
+}
diff --git a/x11-libs/libpciaccess/metadata.xml b/x11-libs/libpciaccess/metadata.xml
new file mode 100644
index 00000000000..01c4c004e73
--- /dev/null
+++ b/x11-libs/libpciaccess/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>x11</herd>
+</pkgmetadata>