summaryrefslogtreecommitdiff
path: root/x11-libs
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-12-17 10:52:06 +0100
committerAlexis Ballier <aballier@gentoo.org>2015-12-17 10:53:43 +0100
commit0f92e136efe8d59576577a6cf308aef308778ce5 (patch)
treed73c8781187bab9d892dc5fc0ae810a8719f1fcc /x11-libs
parent64c67bb749e47e6cbf963f354f6e7e71085cb3e9 (diff)
downloadgentoo-0f92e136efe8d59576577a6cf308aef308778ce5.tar.gz
gentoo-0f92e136efe8d59576577a6cf308aef308778ce5.tar.xz
x11-libs/libva: bump to 1.6.2
Package-Manager: portage-2.2.26 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libva/Manifest1
-rw-r--r--x11-libs/libva/libva-1.6.2.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/x11-libs/libva/Manifest b/x11-libs/libva/Manifest
index 288f9027625..c81858cb546 100644
--- a/x11-libs/libva/Manifest
+++ b/x11-libs/libva/Manifest
@@ -5,3 +5,4 @@ DIST libva-1.5.0.tar.bz2 774266 SHA256 e946d4b3110e4e23ec6a588e0c828937e502c6719
DIST libva-1.5.1.tar.bz2 761390 SHA256 2511b25ead7a6ac1358bc4b81157647fef61e3904ccaca3cfefc3e976a0da005 SHA512 f3198c7b138974c75b0a929c26b15b4b72ec38fccd782a6d0b4df7ab0d496ceb14beac6837da13806c9dcfe6576d2cf585c01acd6e90ba0542d43c07efe530d8 WHIRLPOOL fc711102dbfab7ce3f81ef91d27e943d75217d668ec7605de75168b758f0465aeecd7f7b16407bf7fb48ea4367f1d589e9fabdd7e583803ae2aecf4a0ca4f74a
DIST libva-1.6.0.tar.bz2 786561 SHA256 3ad9dc9c1a6a10e9cc4234c2a1cd5e568ec0cd25145e86875eba6e0d69153458 SHA512 59a451e42bdb70bca83e90800763e0a1a666044189d6399acf1d539b5ebb85d6e12317e8c7f7a97345549de9fd34ee4c7dc52d17ad5c3eb083f80aa15d1b8ed0 WHIRLPOOL a930d02a64c3caf33146aaf8340a4e1850d693595e3455406680d4611a092c779a3c4dbd97628b3a8e3340327262940f161b5fe925bf9a62022801b027a99a2b
DIST libva-1.6.1.tar.bz2 771910 SHA256 7fa2c23fb4431ed8590a52173db18e8760fabb7321d14110c574cc8674594e2e SHA512 cd21c27b89c975cbf6cc77125625dca77332467b291536e0fa4640618871be9dbd1c51e7bd09d15b1af8dbd9166a29113f2dd10a50558ffa00d21161cb9d7958 WHIRLPOOL 5f9091315b411fe8b9d4a4e246bf41066355632b457e84c7beeb4d40d238d2d4defd828e455639e0403fd29b8f7877118f7658c9e768b5062eeceaf5556fbf4f
+DIST libva-1.6.2.tar.bz2 787002 SHA256 c417f09cdeef549e54f4be5f9876026513afeac395c5be28750b431d848c8bd0 SHA512 7e69c44cc1aaa94f0a9e8662ac10974b9e5ab2b29cb2b230370ef1449d8926ea4d4571593c6fa78c6601da4322716c7ab3d1ff42e889252c4769cc267bdc04be WHIRLPOOL e74193d0d31c1be4229b58058064e2e743aeb729e3daef045c7882e8f317c9ccccad9d74bbbea8144c6706a8793052f77acb1d3fcd6488e679be1e97a4a113f4
diff --git a/x11-libs/libva/libva-1.6.2.ebuild b/x11-libs/libva/libva-1.6.2.ebuild
new file mode 100644
index 00000000000..a882b76a506
--- /dev/null
+++ b/x11-libs/libva/libva-1.6.2.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+SCM=""
+if [ "${PV%9999}" != "${PV}" ] ; then # Live ebuild
+ SCM=git-2
+ EGIT_BRANCH=master
+ EGIT_REPO_URI="git://anongit.freedesktop.org/vaapi/libva"
+fi
+
+AUTOTOOLS_AUTORECONF="yes"
+inherit autotools-multilib ${SCM} multilib
+
+DESCRIPTION="Video Acceleration (VA) API for Linux"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/vaapi"
+if [ "${PV%9999}" != "${PV}" ] ; then # Live ebuild
+ SRC_URI=""
+ S="${WORKDIR}/${PN}"
+else
+ SRC_URI="http://www.freedesktop.org/software/vaapi/releases/libva/${P}.tar.bz2"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+if [ "${PV%9999}" = "${PV}" ] ; then
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+else
+ KEYWORDS=""
+fi
+IUSE="+drm egl opengl vdpau wayland X"
+
+VIDEO_CARDS="dummy nvidia intel fglrx nouveau"
+for x in ${VIDEO_CARDS}; do
+ IUSE+=" video_cards_${x}"
+done
+
+RDEPEND=">=x11-libs/libdrm-2.4.46[${MULTILIB_USEDEP}]
+ X? (
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXfixes-5.0.1[${MULTILIB_USEDEP}]
+ )
+ egl? ( >=media-libs/mesa-9.1.6[egl,${MULTILIB_USEDEP}] )
+ opengl? ( >=virtual/opengl-7.0-r1[${MULTILIB_USEDEP}] )
+ wayland? ( >=dev-libs/wayland-1.0.6[${MULTILIB_USEDEP}] )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+PDEPEND="video_cards_nvidia? ( >=x11-libs/libva-vdpau-driver-0.7.4-r1[${MULTILIB_USEDEP}] )
+ video_cards_nouveau? ( >=x11-libs/libva-vdpau-driver-0.7.4-r3[${MULTILIB_USEDEP}] )
+ vdpau? ( >=x11-libs/libva-vdpau-driver-0.7.4-r1[${MULTILIB_USEDEP}] )
+ video_cards_fglrx? (
+ || ( >=x11-drivers/ati-drivers-14.12-r3[${MULTILIB_USEDEP}]
+ >=x11-libs/xvba-video-0.8.0-r1[${MULTILIB_USEDEP}] )
+ )
+ video_cards_intel? ( >=x11-libs/libva-intel-driver-1.2.2-r1[${MULTILIB_USEDEP}] )
+ "
+
+REQUIRED_USE="|| ( drm wayland X )
+ opengl? ( X )"
+
+DOCS=( NEWS )
+
+MULTILIB_WRAPPED_HEADERS=(
+/usr/include/va/va_backend_glx.h
+/usr/include/va/va_x11.h
+/usr/include/va/va_dri2.h
+/usr/include/va/va_dricommon.h
+/usr/include/va/va_glx.h
+)
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --with-drivers-path="${EPREFIX}/usr/$(get_libdir)/va/drivers"
+ $(use_enable video_cards_dummy dummy-driver)
+ $(use_enable opengl glx)
+ $(use_enable X x11)
+ $(use_enable wayland)
+ $(use_enable egl)
+ $(use_enable drm)
+ )
+ autotools-utils_src_configure
+}