summaryrefslogtreecommitdiff
path: root/x11-libs
diff options
context:
space:
mode:
authorKristian Fiskerstrand <k_f@gentoo.org>2016-11-27 22:30:21 +0100
committerKristian Fiskerstrand <k_f@gentoo.org>2016-11-27 22:33:01 +0100
commit28d17d57a580ffbc0ae0443908b4b51ed15e2d41 (patch)
tree872c1c4c7f6140f61ac8efda916df9c0b7017a1e /x11-libs
parent654b04c78686070ea44f7c3415eec53d46043d3f (diff)
downloadgentoo-28d17d57a580ffbc0ae0443908b4b51ed15e2d41.tar.gz
gentoo-28d17d57a580ffbc0ae0443908b4b51ed15e2d41.tar.xz
x11-libs/xapps: Fixes to previous addition
Package-Manager: portage-2.3.2
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/xapps/xapps-1.0.2-r1.ebuild (renamed from x11-libs/xapps/xapps-1.0.2.ebuild)46
1 files changed, 33 insertions, 13 deletions
diff --git a/x11-libs/xapps/xapps-1.0.2.ebuild b/x11-libs/xapps/xapps-1.0.2-r1.ebuild
index b9d1b3335e6..7bc074f1e0d 100644
--- a/x11-libs/xapps/xapps-1.0.2.ebuild
+++ b/x11-libs/xapps/xapps-1.0.2-r1.ebuild
@@ -2,35 +2,55 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
-inherit autotools
-
-SRC_URI="https://github.com/linuxmint/xapps/archive/${PV}.tar.gz -> ${P}.tar.gz"
-KEYWORDS="~amd64 ~x86"
+inherit autotools gnome2-utils
DESCRIPTION="Cross-desktop libraries and common resources"
HOMEPAGE="https://github.com/linuxmint/xapps/"
+LICENSE="GPL-3"
+
+SRC_URI="https://github.com/linuxmint/xapps/archive/${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
-LICENSE="LGPL-3"
SLOT="0"
+IUSE="static-libs"
RDEPEND="
- >=x11-libs/gdk-pixbuf-2.22.0:2[introspection]
- >=x11-libs/gtk+-3.3.16:3[introspection]
>=dev-libs/glib-2.37.3:2
- x11-libs/cairo
gnome-base/libgnomekbd
gnome-base/gnome-common
+ dev-libs/gobject-introspection:0=
+ x11-libs/cairo
+ >=x11-libs/gdk-pixbuf-2.22.0:2[introspection]
+ >=x11-libs/gtk+-3.3.16:3[introspection]
+ x11-libs/libxkbfile
"
-DEPEND="${RDEPEND}"
-src_prepare(){
+DEPEND="${RDEPEND}
+ "
+
+src_prepare() {
+ eapply_user
eautoreconf
- default
}
-src_install(){
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable introspection)
+}
+
+src_install() {
default
rm -rf "${D}/usr/bin/" || die
+ [ use static-libs ] || rm -rf "${D}/usr/lib64/libxapp.la" || die
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
}