summaryrefslogtreecommitdiff
path: root/x11-libs
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-01-20 05:33:57 +0100
committerLars Wendler <polynomial-c@gentoo.org>2017-01-20 05:34:13 +0100
commitdeb8b48135d54a27409329cb25d5544f61c636e4 (patch)
tree19e5b16bedf9bdf989f6ca0a7958db8469406cdf /x11-libs
parent168df0f9666213c167b5072217cecac8898e3faa (diff)
downloadgentoo-deb8b48135d54a27409329cb25d5544f61c636e4.tar.gz
gentoo-deb8b48135d54a27409329cb25d5544f61c636e4.tar.xz
x11-libs/libxkbcommon: Bump to version 0.7.1
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libxkbcommon/Manifest1
-rw-r--r--x11-libs/libxkbcommon/libxkbcommon-0.7.1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/x11-libs/libxkbcommon/Manifest b/x11-libs/libxkbcommon/Manifest
index 6532b899969..c6fe58cf72f 100644
--- a/x11-libs/libxkbcommon/Manifest
+++ b/x11-libs/libxkbcommon/Manifest
@@ -2,3 +2,4 @@ DIST libxkbcommon-0.5.0.tar.xz 615504 SHA256 90bd7824742b9a6f52a6cf80e2cadd6f534
DIST libxkbcommon-0.6.0.tar.xz 608700 SHA256 69235ec3a13194dea9555d7994bc4548b3ee20070e05a135af5372a958149ef0 SHA512 b70ff4b3b85f03cc2875622ccfa60ba6f1b86a07be90df8be73b867771dd08a85740df95fe8dfef2bacf4356a6dfc9c51523ec6ce60d197184860577b39586c4 WHIRLPOOL f2f07b96912ed91790511fab4da3ef11492b74dd9059d1f3df35c58def3d8bffec8857be5c24835662aabe25cdc2c13437e2721a8200736d90e1d6c557fac7d3
DIST libxkbcommon-0.6.1.tar.xz 722288 SHA256 5b0887b080b42169096a61106661f8d35bae783f8b6c58f97ebcd3af83ea8760 SHA512 5eab309d711ef3f4ce6d98ddd72f7f67fb6374eeea5fa13d37019830847a48a100d5b61b0312787966020c85b180b3ee8a5fd8e7acd3a8a9220ca53dcc411370 WHIRLPOOL 3de7a03f1733b558a672e25c41cda8c4373f1fc08badcd8d44856108ff2a2cf9ea692d4a5aaba7b2e59adef4c2bcaa71bdde023aa57ff99e256e18f082463bdd
DIST libxkbcommon-0.7.0.tar.xz 621980 SHA256 09351592312d67b438655f54da5b67853026662c4a57e6be4d225f04a9989798 SHA512 0610f4e4d177d5323e6513f90cb3c29cd07bb1680c9d09770411e8b01e64b7fcf77c8a05cf24ce3035ee08435e95619f21cf283f842cc96511a31fe3a194dc70 WHIRLPOOL caee4a8c963d21695991eb3cde158f09707ff7ebb35835e496177dbf8934aa83d0ea931bb775a6da1f24d2f71bf89a1afaed7bd037341acf329ec92fa34e3d3e
+DIST libxkbcommon-0.7.1.tar.xz 622384 SHA256 ba59305d2e19e47c27ea065c2e0df96ebac6a3c6e97e28ae5620073b6084e68b SHA512 9f209214d5d7f9334cabb2cd7e0d9b9b0392c1fae06b60e92a03398875399fe48754b543389f78b8b06dd28a86dfd440720e534bae309ca8ef882eb874dce4e1 WHIRLPOOL cc397b6e24c943ea506400789d2fca501d62eb03ead929662c037175c98d2f5b7bc723e4f967b48692646e25b74d1e2120de213014d26b74cc7a85e127bda733
diff --git a/x11-libs/libxkbcommon/libxkbcommon-0.7.1.ebuild b/x11-libs/libxkbcommon/libxkbcommon-0.7.1.ebuild
new file mode 100644
index 00000000000..5d21b337126
--- /dev/null
+++ b/x11-libs/libxkbcommon/libxkbcommon-0.7.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+XORG_EAUTORECONF="yes"
+XORG_MULTILIB="yes"
+
+if [[ ${PV} = *9999* ]]; then
+ GIT_ECLASS="git-r3"
+ EXPERIMENTAL="true"
+ EGIT_REPO_URI="git://github.com/xkbcommon/${PN}"
+else
+ XORG_BASE_INDIVIDUAL_URI=""
+ SRC_URI="http://xkbcommon.org/download/${P}.tar.xz"
+fi
+
+inherit xorg-2 ${GIT_ECLASS}
+
+DESCRIPTION="X.Org xkbcommon library"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="X doc test"
+
+DEPEND="sys-devel/bison
+ sys-devel/flex
+ X? ( >=x11-libs/libxcb-1.10[${MULTILIB_USEDEP},xkb] )
+ >=x11-proto/xproto-7.0.24[${MULTILIB_USEDEP}]
+ >=x11-proto/kbproto-1.0.6-r1[${MULTILIB_USEDEP}]
+ doc? ( app-doc/doxygen )"
+RDEPEND=""
+
+pkg_setup() {
+ XORG_CONFIGURE_OPTIONS=(
+ --with-xkb-config-root="${EPREFIX}/usr/share/X11/xkb"
+ $(use X || use_enable X x11)
+ $(use_with doc doxygen)
+ )
+ xorg-2_pkg_setup
+}