summaryrefslogtreecommitdiff
path: root/x11-misc/Xorgautoconfig
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/Xorgautoconfig
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/Xorgautoconfig')
-rw-r--r--x11-misc/Xorgautoconfig/Manifest1
-rw-r--r--x11-misc/Xorgautoconfig/Xorgautoconfig-0.2.4-r1.ebuild39
-rw-r--r--x11-misc/Xorgautoconfig/files/Xorgautoconfig-lz.patch11
-rw-r--r--x11-misc/Xorgautoconfig/files/backingstore.patch10
-rw-r--r--x11-misc/Xorgautoconfig/metadata.xml13
5 files changed, 74 insertions, 0 deletions
diff --git a/x11-misc/Xorgautoconfig/Manifest b/x11-misc/Xorgautoconfig/Manifest
new file mode 100644
index 00000000000..5f9c5d0e28b
--- /dev/null
+++ b/x11-misc/Xorgautoconfig/Manifest
@@ -0,0 +1 @@
+DIST Xorgautoconfig-0.2.4.tar.bz2 33371 SHA256 63aece49c4584e1ef5b28a38519a7e4b8e102ea260e8acf2d7ead9b6675de3da
diff --git a/x11-misc/Xorgautoconfig/Xorgautoconfig-0.2.4-r1.ebuild b/x11-misc/Xorgautoconfig/Xorgautoconfig-0.2.4-r1.ebuild
new file mode 100644
index 00000000000..0d8e1069b30
--- /dev/null
+++ b/x11-misc/Xorgautoconfig/Xorgautoconfig-0.2.4-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Xorgautconfig generates xorg.conf files for PPC based computers"
+HOMEPAGE="http://dev.gentoo.org/~josejx/Xorgautoconfig.html"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="ppc ppc64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="sys-apps/pciutils"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/backingstore.patch
+ epatch "${FILESDIR}"/${PN}-lz.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die "emake failed!"
+}
+
+src_install() {
+ dodir /usr
+ into /usr
+ dosbin Xorgautoconfig
+
+ newinitd Xorgautoconfig.init Xorgautoconfig
+
+ dodoc ChangeLog
+}
diff --git a/x11-misc/Xorgautoconfig/files/Xorgautoconfig-lz.patch b/x11-misc/Xorgautoconfig/files/Xorgautoconfig-lz.patch
new file mode 100644
index 00000000000..c0182a75495
--- /dev/null
+++ b/x11-misc/Xorgautoconfig/files/Xorgautoconfig-lz.patch
@@ -0,0 +1,11 @@
+--- Makefile.bak 2007-02-12 19:45:05.000000000 -0500
++++ Makefile 2007-02-12 19:44:37.000000000 -0500
+@@ -3,7 +3,7 @@
+ OBJS = Xorgautoconfig.o pci.o misc.o ddcprobe/minifind.o ddcprobe/common.o ddcprobe/vesamode.o ddcprobe/of.o
+
+ all: $(OBJS)
+- ${CC} -s -o Xorgautoconfig $(CFLAGS) $(OBJS) -lpci
++ ${CC} -s -o Xorgautoconfig $(CFLAGS) $(OBJS) -lpci -lz
+
+ clean:
+ rm -f $(OBJS) Xorgautoconfig
diff --git a/x11-misc/Xorgautoconfig/files/backingstore.patch b/x11-misc/Xorgautoconfig/files/backingstore.patch
new file mode 100644
index 00000000000..d1668d7da9f
--- /dev/null
+++ b/x11-misc/Xorgautoconfig/files/backingstore.patch
@@ -0,0 +1,10 @@
+--- Xorgtext.h.bak 2006-07-06 11:48:31.000000000 -0400
++++ Xorgtext.h 2006-07-06 11:48:36.000000000 -0400
+@@ -135,7 +135,6 @@
+
+ static char *driver_radeon =
+ " ### Available Driver options:\n"
+-" Option \"BackingStore\" \"true\" # Increases performance\n"
+ " Option \"EnablePageFlip\" \"true\" # Increases performance\n"
+ " #Option \"SWcursor\" \"false\" # Use Software Cursor\n"
+ " #Option \"NoAccel\" \"false\" # Disable Hardware Acceleration\n"
diff --git a/x11-misc/Xorgautoconfig/metadata.xml b/x11-misc/Xorgautoconfig/metadata.xml
new file mode 100644
index 00000000000..e5db48ef412
--- /dev/null
+++ b/x11-misc/Xorgautoconfig/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ppc</herd>
+<maintainer>
+<email>josejx@gentoo.org</email>
+<name>Joseph Jezak</name>
+</maintainer>
+<longdescription lang="en">
+An X.org auto configuration tool for PPC machines.
+</longdescription>
+</pkgmetadata>
+