summaryrefslogtreecommitdiff
path: root/x11-misc/alock
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/alock
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/alock')
-rw-r--r--x11-misc/alock/Manifest1
-rw-r--r--x11-misc/alock/alock-94.ebuild60
-rw-r--r--x11-misc/alock/files/implicit_pointer_conversion_fix_amd64.patch13
-rw-r--r--x11-misc/alock/metadata.xml8
4 files changed, 82 insertions, 0 deletions
diff --git a/x11-misc/alock/Manifest b/x11-misc/alock/Manifest
new file mode 100644
index 00000000000..c2d8ef0a2a3
--- /dev/null
+++ b/x11-misc/alock/Manifest
@@ -0,0 +1 @@
+DIST alock-svn-94.tar.bz2 68140 SHA256 37938b56588e0e9bdfdf52097bccd000f992ea725c87cd8c8b3ea4df847e8f26
diff --git a/x11-misc/alock/alock-94.ebuild b/x11-misc/alock/alock-94.ebuild
new file mode 100644
index 00000000000..3c362b8c741
--- /dev/null
+++ b/x11-misc/alock/alock-94.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit eutils toolchain-funcs
+
+DESCRIPTION="locks the local X display until a password is entered"
+HOMEPAGE="http://code.google.com/p/alock/
+ http://darkshed.net/projects/alock"
+SRC_URI="http://alock.googlecode.com/files/alock-svn-${PV}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="imlib pam"
+
+DEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm
+ x11-libs/libXrender
+ x11-libs/libXcursor
+ imlib? ( media-libs/imlib2[X] )
+ pam? ( virtual/pam )"
+
+S=${WORKDIR}/${PN}-svn-${PV}
+
+src_prepare() {
+ epatch "${FILESDIR}"/implicit_pointer_conversion_fix_amd64.patch
+}
+
+src_configure() {
+ tc-export CC
+
+ ./configure \
+ --prefix=/usr \
+ --with-all \
+ $(use_with pam) \
+ $(use_with imlib imlib2) || die
+}
+
+src_compile() {
+ emake XMLTO=true || die
+}
+
+src_install() {
+ dobin src/alock || die
+ doman alock.1 || die
+ dodoc {CHANGELOG,README,TODO}.txt || die
+
+ insinto /usr/share/alock/xcursors
+ doins contrib/xcursor-* || die
+
+ insinto /usr/share/alock/bitmaps
+ doins bitmaps/* || die
+
+ if ! use pam; then
+ fperms 4755 /usr/bin/alock
+ fi
+}
diff --git a/x11-misc/alock/files/implicit_pointer_conversion_fix_amd64.patch b/x11-misc/alock/files/implicit_pointer_conversion_fix_amd64.patch
new file mode 100644
index 00000000000..1184ee73a61
--- /dev/null
+++ b/x11-misc/alock/files/implicit_pointer_conversion_fix_amd64.patch
@@ -0,0 +1,13 @@
+Index: alock-svn-94/src/auth_passwd.c
+===================================================================
+--- alock-svn-94.orig/src/auth_passwd.c
++++ alock-svn-94/src/auth_passwd.c
+@@ -43,7 +43,7 @@
+ \* ---------------------------------------------------------------- */
+
+ static struct passwd* pwd_entry = NULL;
+-
++char * crypt (const char *key, const char *salt);
+ static int alock_auth_passwd_init(const char* args) {
+
+ errno = 0;
diff --git a/x11-misc/alock/metadata.xml b/x11-misc/alock/metadata.xml
new file mode 100644
index 00000000000..884db118c2d
--- /dev/null
+++ b/x11-misc/alock/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-misc</herd>
+ <upstream>
+ <remote-id type="google-code">alock</remote-id>
+ </upstream>
+</pkgmetadata>