summaryrefslogtreecommitdiff
path: root/x11-misc/basqet
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/basqet
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/basqet')
-rw-r--r--x11-misc/basqet/Manifest2
-rw-r--r--x11-misc/basqet/basqet-0.1.4.ebuild26
-rw-r--r--x11-misc/basqet/basqet-0.2.0.ebuild30
-rw-r--r--x11-misc/basqet/files/basqet-0.2.0-desktop.patch14
-rw-r--r--x11-misc/basqet/metadata.xml8
5 files changed, 80 insertions, 0 deletions
diff --git a/x11-misc/basqet/Manifest b/x11-misc/basqet/Manifest
new file mode 100644
index 00000000000..25965642782
--- /dev/null
+++ b/x11-misc/basqet/Manifest
@@ -0,0 +1,2 @@
+DIST basqet_0.1.4-src.tgz 153422 SHA256 ad8187510fcc8c211e049053c0c10eeb4a3719856c17b1ecd8d0501406e4c967
+DIST basqet_0.2.0-src.tgz 471700 SHA256 46a66a61af82b57c5fc6be40565837dab785f1dbb375656cf207ef08eb09f8a2
diff --git a/x11-misc/basqet/basqet-0.1.4.ebuild b/x11-misc/basqet/basqet-0.1.4.ebuild
new file mode 100644
index 00000000000..c541946b9ce
--- /dev/null
+++ b/x11-misc/basqet/basqet-0.1.4.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+inherit eutils qt4-r2
+
+DESCRIPTION="Keep your notes, pictures, ideas, and information in Baskets"
+HOMEPAGE="http://code.google.com/p/basqet/"
+SRC_URI="http://basqet.googlecode.com/files/${PN}_${PV}-src.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-qt/qtgui:4
+ dev-qt/qtxmlpatterns:4"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ qt4-r2_src_prepare
+
+ sed -i 's:PREFIX = /usr/local:PREFIX = /usr:' ${PN}.pro || die
+}
diff --git a/x11-misc/basqet/basqet-0.2.0.ebuild b/x11-misc/basqet/basqet-0.2.0.ebuild
new file mode 100644
index 00000000000..ab66136dba7
--- /dev/null
+++ b/x11-misc/basqet/basqet-0.2.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit qt4-r2
+
+DESCRIPTION="Keep your notes, pictures, ideas, and information in Baskets"
+HOMEPAGE="http://code.google.com/p/basqet/"
+SRC_URI="http://basqet.googlecode.com/files/${PN}_${PV}-src.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-qt/qtcore:4
+ dev-qt/qtgui:4"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/release_${PV}
+
+PATCHES=( "${FILESDIR}/${P}-desktop.patch" )
+
+src_prepare() {
+ qt4-r2_src_prepare
+
+ sed -i 's:PREFIX = /usr/local:PREFIX = /usr:' ${PN}.pro || die
+}
diff --git a/x11-misc/basqet/files/basqet-0.2.0-desktop.patch b/x11-misc/basqet/files/basqet-0.2.0-desktop.patch
new file mode 100644
index 00000000000..161ad1d8fd3
--- /dev/null
+++ b/x11-misc/basqet/files/basqet-0.2.0-desktop.patch
@@ -0,0 +1,14 @@
+--- basqet.desktop
++++ basqet.desktop
+@@ -1,9 +1,9 @@
+ [Desktop Entry]
+-Version=0.2.0
++Version=1.0
+ Terminal=false
+ TryExec=basqet
+ Exec=basqet
+-Icon=basqet.png
++Icon=basqet
+ Type=Application
+ Categories=Office;WordProcessor;
+ StartupNotify=false
diff --git a/x11-misc/basqet/metadata.xml b/x11-misc/basqet/metadata.xml
new file mode 100644
index 00000000000..7aa61dde7f6
--- /dev/null
+++ b/x11-misc/basqet/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>qt</herd>
+ <upstream>
+ <remote-id type="google-code">basqet</remote-id>
+ </upstream>
+</pkgmetadata>