summaryrefslogtreecommitdiff
path: root/x11-misc/bbpager
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/bbpager
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/bbpager')
-rw-r--r--x11-misc/bbpager/Manifest1
-rw-r--r--x11-misc/bbpager/bbpager-0.4.7.ebuild34
-rw-r--r--x11-misc/bbpager/files/bbpager-0.4.7-as-needed.patch92
-rw-r--r--x11-misc/bbpager/files/bbpager-0.4.7-gcc43.patch33
-rw-r--r--x11-misc/bbpager/metadata.xml13
5 files changed, 173 insertions, 0 deletions
diff --git a/x11-misc/bbpager/Manifest b/x11-misc/bbpager/Manifest
new file mode 100644
index 00000000000..6838bd708f1
--- /dev/null
+++ b/x11-misc/bbpager/Manifest
@@ -0,0 +1 @@
+DIST bbpager-0.4.7.tar.gz 170575 SHA256 e7063a8d65c25663f44e2769132053bd3f1b90f0d4b19a8d8aa2e5f028f0679d
diff --git a/x11-misc/bbpager/bbpager-0.4.7.ebuild b/x11-misc/bbpager/bbpager-0.4.7.ebuild
new file mode 100644
index 00000000000..9dcdbd02e60
--- /dev/null
+++ b/x11-misc/bbpager/bbpager-0.4.7.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit base autotools
+
+DESCRIPTION="An understated pager for Blackbox"
+HOMEPAGE="http://bbtools.sourceforge.net/"
+SRC_URI="mirror://sourceforge/bbtools/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="x11-wm/blackbox"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${P}-gcc43.patch"
+ "${FILESDIR}/${P}-as-needed.patch"
+ )
+
+src_unpack() {
+ base_src_unpack
+ cd "${S}"
+ eautoreconf
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS BUGS ChangeLog README TODO
+}
diff --git a/x11-misc/bbpager/files/bbpager-0.4.7-as-needed.patch b/x11-misc/bbpager/files/bbpager-0.4.7-as-needed.patch
new file mode 100644
index 00000000000..47efa7132f9
--- /dev/null
+++ b/x11-misc/bbpager/files/bbpager-0.4.7-as-needed.patch
@@ -0,0 +1,92 @@
+diff -NrU5 bbpager-0.4.7.orig/configure.ac bbpager-0.4.7/configure.ac
+--- bbpager-0.4.7.orig/configure.ac 2008-12-20 22:38:36.000000000 +0100
++++ bbpager-0.4.7/configure.ac 2008-12-20 23:58:12.000000000 +0100
+@@ -37,40 +37,45 @@
+ AC_PROG_INSTALL
+ AC_HEADER_STDC
+ AC_CHECK_HEADERS(ctype.h fcntl.h libgen.h locale.h process.h signal.h stdio.h time.h unistd.h sys/param.h sys/select.h sys/stat.h sys/time.h sys/types.h sys/wait.h)
+ AC_HEADER_TIME
+
++dnl Checks for typedefs, structures, and compiler characteristics.
++AC_C_CONST
++AC_STRUCT_TM
++
++dnl Checks for library functions.
++AC_CHECK_FUNCS(select strstr)
++
+ AC_CHECK_FUNCS(setlocale sigaction strftime)
+
+ AC_PATH_X
+ AC_PATH_XTRA
+
+-CFLAGS="$CFLAGS $X_CFLAGS"
+-CXXFLAGS="$CXXFLAGS $X_CFLAGS"
+-LDFLAGS="$LDFLAGS $X_LIBS $X_PRE_LIBS"
+ dnl Checks for X libraries.
+-AC_CHECK_LIB(X11, XOpenDisplay, LDFLAGS="$LDFLAGS -lX11",
+- AC_MSG_ERROR(XOpenDisplay not found in -lX11))
++AC_CHECK_LIB([X11],
++ [XOpenDisplay],
++ [],
++ [AC_MSG_ERROR(XOpenDisplay not found in -lX11)]
++ )
+
+ dnl Checks for Xextension
+-SHAPE=
+-AC_CHECK_LIB(Xext, XMissingExtension, LIBS="$LIBS -lXext"; SHAPE="-DSHAPE",
+- AC_MSG_ERROR(XMissingExtension not found in -lXext))
+-AC_SUBST(SHAPE)
+-
+-dnl Checks for typedefs, structures, and compiler characteristics.
+-AC_C_CONST
+-AC_HEADER_TIME
+-AC_STRUCT_TM
+-
+-dnl Checks for library functions.
+-AC_CHECK_FUNCS(select strstr)
++PKG_CHECK_MODULES([XEXT], [xext],
++ [
++ AC_CHECK_LIB([Xext],
++ [XMissingExtension],
++ [],
++ [AC_MSG_ERROR(XMissingExtension not found in -lXext)]
++ )
++ ],
++ [AC_MSG_ERROR(xext not found)]
++ )
+
+ dnl pkgconfig checks for blackbox library
+ PKG_CHECK_MODULES(LIBBT, libbt)
+-CXXFLAGS="$CXXFLAGS $LIBBT_CFLAGS"
+-LIBS="$LIBS $LIBBT_LIBS"
++
++LIBS="$LIBS $LIBBT_LIBS $X_LIBS $X_PRE_LIBS $XEXT_LIBS"
+
+ dnl generate the config header
+ AM_CONFIG_HEADER(config.h)
+
+ dnl Print results
+diff -NrU5 bbpager-0.4.7.orig/src/Makefile.am bbpager-0.4.7/src/Makefile.am
+--- bbpager-0.4.7.orig/src/Makefile.am 2008-12-20 22:38:36.000000000 +0100
++++ bbpager-0.4.7/src/Makefile.am 2008-12-20 23:56:15.000000000 +0100
+@@ -1,8 +1,9 @@
+-CPPFLAGS = @CPPFLAGS@ @SHAPE@ \
++AM_CPPFLAGS = $(CPPFLAGS) -DSHAPE \
+ -DBBTOOL_GLOBAL=\"$(datadir)/bbtools/bbpager.rc\" \
+ -DBBTOOL_LOCAL=\"~/.bbtools/bbpager.rc\"
++AM_CXXFLAGS = $(X_CFLAGS) $(XEXT_CFLAGS) $(LIBBT_CFLAGS)
+
+ bin_PROGRAMS = bbpager
+ bbpager_SOURCES = bbpager.cxx bbpager.h \
+ main.cxx main.h \
+ Baseresource.cxx Baseresource.h \
+@@ -10,7 +11,8 @@
+ wminterface.cxx wminterface.h \
+ blackboxstyle.h \
+ pager.cxx pager.h \
+ desktop.cxx desktop.h
+ # pagermenu.cc pagermenu.hh \
+-bbpager_LDADD = @X_LIBS@
++#
++
+
diff --git a/x11-misc/bbpager/files/bbpager-0.4.7-gcc43.patch b/x11-misc/bbpager/files/bbpager-0.4.7-gcc43.patch
new file mode 100644
index 00000000000..bf0c9bedd64
--- /dev/null
+++ b/x11-misc/bbpager/files/bbpager-0.4.7-gcc43.patch
@@ -0,0 +1,33 @@
+diff -urNad bbpager-0.4.7~/src/Baseresource.cxx bbpager-0.4.7/src/Baseresource.cxx
+--- bbpager-0.4.7~/src/Baseresource.cxx 2008-03-28 06:55:16.000000000 -0400
++++ bbpager-0.4.7/src/Baseresource.cxx 2008-04-09 21:58:03.000000000 -0400
+@@ -20,6 +20,7 @@
+ //
+
+ #include <string>
++#include <cstring>
+ #include "Baseresource.h"
+ #include <stdio.h>
+ #include "Menu.hh"
+diff -urNad bbpager-0.4.7~/src/main.cxx bbpager-0.4.7/src/main.cxx
+--- bbpager-0.4.7~/src/main.cxx 2008-03-28 06:55:16.000000000 -0400
++++ bbpager-0.4.7/src/main.cxx 2008-04-09 21:58:03.000000000 -0400
+@@ -25,6 +25,7 @@
+
+ #include <stdio.h>
+ #include <string>
++#include <cstring>
+ #include <iostream>
+
+
+diff -urNad bbpager-0.4.7~/src/resource.cxx bbpager-0.4.7/src/resource.cxx
+--- bbpager-0.4.7~/src/resource.cxx 2007-03-11 17:47:07.000000000 -0400
++++ bbpager-0.4.7/src/resource.cxx 2008-04-09 21:58:39.000000000 -0400
+@@ -19,6 +19,7 @@
+ // (See the included file COPYING / GPL-2.0)
+ //
+
++#include <cstring>
+ #include "resource.h"
+ #include "blackboxstyle.h"
+
diff --git a/x11-misc/bbpager/metadata.xml b/x11-misc/bbpager/metadata.xml
new file mode 100644
index 00000000000..93d6fc922f8
--- /dev/null
+++ b/x11-misc/bbpager/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ An understated pager for Blackbox.
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">bbtools</remote-id>
+ </upstream>
+</pkgmetadata>