summaryrefslogtreecommitdiff
path: root/x11-misc/bbrun
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/bbrun
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/bbrun')
-rw-r--r--x11-misc/bbrun/Manifest1
-rw-r--r--x11-misc/bbrun/bbrun-1.6-r1.ebuild34
-rw-r--r--x11-misc/bbrun/files/bbrun-1.6-makefile.patch29
-rw-r--r--x11-misc/bbrun/files/bbrun-1.6-respectflags.patch26
-rw-r--r--x11-misc/bbrun/metadata.xml5
5 files changed, 95 insertions, 0 deletions
diff --git a/x11-misc/bbrun/Manifest b/x11-misc/bbrun/Manifest
new file mode 100644
index 00000000000..92fe60ea4ec
--- /dev/null
+++ b/x11-misc/bbrun/Manifest
@@ -0,0 +1 @@
+DIST bbrun-1.6.tar.gz 21132 SHA256 d0af57276ec9191a94f8d20a2da69dc1818f410f23478f041334aef2d707559a
diff --git a/x11-misc/bbrun/bbrun-1.6-r1.ebuild b/x11-misc/bbrun/bbrun-1.6-r1.ebuild
new file mode 100644
index 00000000000..b1cfe533972
--- /dev/null
+++ b/x11-misc/bbrun/bbrun-1.6-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="blackbox program execution dialog box"
+HOMEPAGE="http://www.darkops.net/bbrun"
+SRC_URI="http://www.darkops.net/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ x11-libs/libXpm
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-makefile.patch
+}
+
+src_compile() {
+ emake -C ${PN} CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ dobin ${PN}/${PN}
+ dodoc Changelog README
+}
diff --git a/x11-misc/bbrun/files/bbrun-1.6-makefile.patch b/x11-misc/bbrun/files/bbrun-1.6-makefile.patch
new file mode 100644
index 00000000000..cf89b96df6f
--- /dev/null
+++ b/x11-misc/bbrun/files/bbrun-1.6-makefile.patch
@@ -0,0 +1,29 @@
+Respect {C,LD}FLAGS, fix underlinking
+
+http://bugs.gentoo.org/367853
+
+--- bbrun/Makefile
++++ bbrun/Makefile
+@@ -1,7 +1,7 @@
+ CC = gcc
+ LIBDIR = -L/usr/lib -L/usr/X11R6/lib
+-LIBS = -lXpm `pkg-config --libs gtk+-2.0`
+-CFLAGS = `pkg-config --cflags gtk+-2.0`
++LIBS = `pkg-config --libs xext xpm gtk+-2.0`
++DEP_CFLAGS = `pkg-config --cflags xext xpm gtk+-2.0`
+
+ OBJS = bbrun.o \
+ ../wmgeneral/wmgeneral.o \
+@@ -11,10 +11,10 @@
+ all: bbrun
+
+ .c.o:
+- $(CC) -g -c -O2 -Wall $< -o $*.o $(CFLAGS)
++ $(CC) $(CFLAGS) $(DEP_CFLAGS) -c -Wall $< -o $*.o
+
+ bbrun: $(OBJS)
+- $(CC) -Wall -g -o bbrun $^ $(LIBDIR) $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -Wall -o bbrun $^ $(LIBDIR) $(LIBS)
+
+ install:
+ cp bbrun /usr/local/bin/
diff --git a/x11-misc/bbrun/files/bbrun-1.6-respectflags.patch b/x11-misc/bbrun/files/bbrun-1.6-respectflags.patch
new file mode 100644
index 00000000000..d81824b0ed0
--- /dev/null
+++ b/x11-misc/bbrun/files/bbrun-1.6-respectflags.patch
@@ -0,0 +1,26 @@
+Respect {C,LD}FLAGS
+
+--- bbrun/Makefile
++++ bbrun/Makefile
+@@ -1,7 +1,7 @@
+ CC = gcc
+ LIBDIR = -L/usr/lib -L/usr/X11R6/lib
+ LIBS = -lXpm `pkg-config --libs gtk+-2.0`
+-CFLAGS = `pkg-config --cflags gtk+-2.0`
++GTK_CFLAGS = `pkg-config --cflags gtk+-2.0`
+
+ OBJS = bbrun.o \
+ ../wmgeneral/wmgeneral.o \
+@@ -11,10 +11,10 @@
+ all: bbrun
+
+ .c.o:
+- $(CC) -g -c -O2 -Wall $< -o $*.o $(CFLAGS)
++ $(CC) $(CFLAGS) $(GTK_CFLAGS) -c -Wall $< -o $*.o
+
+ bbrun: $(OBJS)
+- $(CC) -Wall -g -o bbrun $^ $(LIBDIR) $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -Wall -o bbrun $^ $(LIBDIR) $(LIBS)
+
+ install:
+ cp bbrun /usr/local/bin/
diff --git a/x11-misc/bbrun/metadata.xml b/x11-misc/bbrun/metadata.xml
new file mode 100644
index 00000000000..4538a68724a
--- /dev/null
+++ b/x11-misc/bbrun/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer><email>maintainer-needed@gentoo.org</email></maintainer>
+</pkgmetadata>