summaryrefslogtreecommitdiff
path: root/x11-misc/bbtime
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/bbtime
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/bbtime')
-rw-r--r--x11-misc/bbtime/Manifest1
-rw-r--r--x11-misc/bbtime/bbtime-0.1.5.ebuild35
-rw-r--r--x11-misc/bbtime/files/bbtime-0.1.5-asneeded.patch39
-rw-r--r--x11-misc/bbtime/metadata.xml11
4 files changed, 86 insertions, 0 deletions
diff --git a/x11-misc/bbtime/Manifest b/x11-misc/bbtime/Manifest
new file mode 100644
index 00000000000..b185758b679
--- /dev/null
+++ b/x11-misc/bbtime/Manifest
@@ -0,0 +1 @@
+DIST bbtime-0.1.5.tar.gz 68842 SHA256 e5ee51b43e5f7014059ae9e66b00a13410a781ecfac84774dcb66d7f3371dd00
diff --git a/x11-misc/bbtime/bbtime-0.1.5.ebuild b/x11-misc/bbtime/bbtime-0.1.5.ebuild
new file mode 100644
index 00000000000..fcf4c9fc08f
--- /dev/null
+++ b/x11-misc/bbtime/bbtime-0.1.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit autotools eutils
+
+DESCRIPTION="blackbox time watcher"
+HOMEPAGE="http://sourceforge.net/projects/bbtools/"
+SRC_URI="mirror://sourceforge/bbtools/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ppc x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="x11-libs/libX11"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-asneeded.patch
+ eautoreconf
+}
+
+src_install () {
+ emake DESTDIR="${D}" install
+ dodoc README AUTHORS BUGS ChangeLog NEWS TODO data/README.bbtime
+
+ rm "${D}"/usr/share/bbtools/README.bbtime || die
+ # since multiple bbtools packages provide this file, install
+ # it in /usr/share/doc/${PF}
+ mv "${D}/usr/share/bbtools/bbtoolsrc.in" \
+ "${D}/usr/share/doc/${PF}/bbtoolsrc.example" || die
+}
diff --git a/x11-misc/bbtime/files/bbtime-0.1.5-asneeded.patch b/x11-misc/bbtime/files/bbtime-0.1.5-asneeded.patch
new file mode 100644
index 00000000000..17788812d8a
--- /dev/null
+++ b/x11-misc/bbtime/files/bbtime-0.1.5-asneeded.patch
@@ -0,0 +1,39 @@
+Fixing build with as-needed
+
+https://bugs.gentoo.org/show_bug.cgi?id=248555
+
+--- configure.in
++++ configure.in
+@@ -47,14 +47,9 @@
+ AC_PATH_X
+ AC_PATH_XTRA
+
+-CFLAGS="$CFLAGS $X_CFLAGS"
+-CXXFLAGS="$CXXFLAGS $X_CFLAGS"
+-LDFLAGS="$LDFLAGS $X_LIBS $X_PRE_LIBS"
+ dnl Checks for X libraries.
+-AC_CHECK_LIB(X11, XOpenDisplay, LDFLAGS="$LDFLAGS -lX11",
+- AC_MSG_ERROR(XOpenDisplay not found in -lX11))
+-
+-LDFLAGS="$LDFLAGS $X_EXTRA_LIBS"
++AC_CHECK_LIB([X11], [XOpenDisplay], ,
++ AC_MSG_ERROR(XOpenDisplay not found in -lX11),)
+
+ dnl Checks for header files.
+ AC_HEADER_STDC
+--- Makefile.am
++++ Makefile.am
+@@ -1,5 +1,4 @@
+-CPPFLAGS = @CPPFLAGS@ \
+- -DDEFAULT_CONF=\"$(datadir)/bbtools/bbtime.conf\" \
++AM_CPPFLAGS = -DDEFAULT_CONF=\"$(datadir)/bbtools/bbtime.conf\" \
+ -DDEFAULT_NOBB=\"$(datadir)/bbtools/bbtime.nobb\"
+
+
+@@ -14,4 +13,5 @@
+ timemenu.cc timemenu.hh \
+ blackboxstyle.hh
+ EXTRA_DIST = BUGS TODO
+-bbtime_LDADD = @X_LIBS@
++bbtime_LDADD = @X_PRE_LIBS@ @X_LIBS@ @X_EXTRA_LIBS@
++bbtime_CFLAGS = @X_PRE_CFLAGS@ @X_CGLAGS@ @X_EXTRA_CFLAGS@
diff --git a/x11-misc/bbtime/metadata.xml b/x11-misc/bbtime/metadata.xml
new file mode 100644
index 00000000000..22b8da1dff6
--- /dev/null
+++ b/x11-misc/bbtime/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription>A time monitor for Blackbox.</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">bbtools</remote-id>
+ </upstream>
+</pkgmetadata>