summaryrefslogtreecommitdiff
path: root/x11-misc/ccsm
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2016-01-28 11:10:03 +0300
committerSergey Popov <pinkbyte@gentoo.org>2016-01-28 11:15:48 +0300
commit0f35eaef18ee050158ef38cc6d8123a500e3191d (patch)
treed7f1b8fe27a533d71a521b9b9597383cabe65f96 /x11-misc/ccsm
parent3f15ba5e4a8f63a9d0dd0b773f4149342befa988 (diff)
downloadgentoo-0f35eaef18ee050158ef38cc6d8123a500e3191d.tar.gz
gentoo-0f35eaef18ee050158ef38cc6d8123a500e3191d.tar.xz
Move x11-apps/ccsm and x11-apps/simple-ccsm to x11-misc/ccsm and
x11-misc/simple-ccsm respectively Gentoo-Bug: 571838 Gentoo-Bug: 571852
Diffstat (limited to 'x11-misc/ccsm')
-rw-r--r--x11-misc/ccsm/Manifest1
-rw-r--r--x11-misc/ccsm/ccsm-0.8.4-r4.ebuild51
-rw-r--r--x11-misc/ccsm/ccsm-0.8.4-r5.ebuild54
-rw-r--r--x11-misc/ccsm/files/ccsm-0.8.4-pygobject-glib-fix.patch16
-rw-r--r--x11-misc/ccsm/metadata.xml9
5 files changed, 131 insertions, 0 deletions
diff --git a/x11-misc/ccsm/Manifest b/x11-misc/ccsm/Manifest
new file mode 100644
index 00000000000..888f47b19e7
--- /dev/null
+++ b/x11-misc/ccsm/Manifest
@@ -0,0 +1 @@
+DIST ccsm-0.8.4.tar.bz2 475864 SHA256 46b9da032cf29e71aec0823799861d926937ad41f4edea3be718ac6a8532c16d SHA512 1991f25ca4f04363006bacd5267cb54c7e24817b263996c7172f58180ca0acf94050220938d4fa87081c93fde23ca0b44a333f9b675950e4c5187903a03692c5 WHIRLPOOL a6730161d07a8c5158700566df31653a7adcf117e791a5b4076b67b68a4ce4c7ff3f88a5710c1fce29d38eccbbade095710f5a73277c54809e5431b3c52c1fe0
diff --git a/x11-misc/ccsm/ccsm-0.8.4-r4.ebuild b/x11-misc/ccsm/ccsm-0.8.4-r4.ebuild
new file mode 100644
index 00000000000..9bc964a048b
--- /dev/null
+++ b/x11-misc/ccsm/ccsm-0.8.4-r4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_IN_SOURCE_BUILD=1
+inherit distutils-r1
+
+DESCRIPTION="Compizconfig Settings Manager"
+HOMEPAGE="http://www.compiz.org/"
+SRC_URI="http://releases.compiz.org/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="
+ >=dev-python/compizconfig-python-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/pygtk-2.12:2[${PYTHON_USEDEP}]
+ gnome-base/librsvg
+"
+
+DOCS=( AUTHORS )
+
+python_prepare_all() {
+ # return error if wrong arguments passed to setup.py
+ sed -i -e 's/raise SystemExit/\0(1)/' setup.py || die 'sed on setup.py failed'
+ # fix desktop file
+ sed -i \
+ -e '/Categories/s/Compiz/X-\0/' \
+ -e '/Encoding/d' \
+ ccsm.desktop.in || die 'sed on ccsm.desktop.in failed'
+
+ # correct gettext behavior
+ if [[ -n "${LINGUAS+x}" ]] ; then
+ for i in $(cd po ; echo *po | sed 's/\.po//g') ; do
+ if ! has ${i} ${LINGUAS} ; then
+ rm po/${i}.po || die
+ fi
+ done
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_configure_all() {
+ #set prefix
+ mydistutilsargs=( build --prefix=/usr )
+}
diff --git a/x11-misc/ccsm/ccsm-0.8.4-r5.ebuild b/x11-misc/ccsm/ccsm-0.8.4-r5.ebuild
new file mode 100644
index 00000000000..dc9ec7f0795
--- /dev/null
+++ b/x11-misc/ccsm/ccsm-0.8.4-r5.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_IN_SOURCE_BUILD=1
+inherit distutils-r1
+
+DESCRIPTION="Compizconfig Settings Manager"
+HOMEPAGE="http://www.compiz.org/"
+SRC_URI="http://releases.compiz.org/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="
+ >=dev-python/compizconfig-python-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/pygtk-2.12:2[${PYTHON_USEDEP}]
+ gnome-base/librsvg
+"
+
+# missing icons and text fix, bug #487106
+PATCHES=( "${FILESDIR}/${P}-pygobject-glib-fix.patch" )
+
+DOCS=( AUTHORS )
+
+python_prepare_all() {
+ # return error if wrong arguments passed to setup.py
+ sed -i -e 's/raise SystemExit/\0(1)/' setup.py || die 'sed on setup.py failed'
+ # fix desktop file
+ sed -i \
+ -e '/Categories/s/Compiz/X-\0/' \
+ -e '/Encoding/d' \
+ ccsm.desktop.in || die 'sed on ccsm.desktop.in failed'
+
+ # correct gettext behavior
+ if [[ -n "${LINGUAS+x}" ]] ; then
+ for i in $(cd po ; echo *po | sed 's/\.po//g') ; do
+ if ! has ${i} ${LINGUAS} ; then
+ rm po/${i}.po || die
+ fi
+ done
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_configure_all() {
+ #set prefix
+ mydistutilsargs=( build --prefix=/usr )
+}
diff --git a/x11-misc/ccsm/files/ccsm-0.8.4-pygobject-glib-fix.patch b/x11-misc/ccsm/files/ccsm-0.8.4-pygobject-glib-fix.patch
new file mode 100644
index 00000000000..9b325af7f34
--- /dev/null
+++ b/x11-misc/ccsm/files/ccsm-0.8.4-pygobject-glib-fix.patch
@@ -0,0 +1,16 @@
+Fix missing icon and text with new PyGObject
+Gentoo bugreport - https://bugs.gentoo.org/show_bug.cgi?id=487106
+Patch by Small_Penguin <dark.shadow AT gmx.at>
+
+diff -Naur ccsm-0.8.4~/ccm/Utils.py ccsm-0.8.4/ccm/Utils.py
+--- ccsm-0.8.4~/ccm/Utils.py 2009-10-14 03:05:30.000000000 +0200
++++ ccsm-0.8.4/ccm/Utils.py 2013-10-05 10:16:10.050030522 +0200
+@@ -184,7 +184,7 @@
+ if has_focus:
+ self.unset_flags (gtk.HAS_FOCUS)
+
+- ret = super (PrettyButton, self).do_expose_event (self, event)
++ ret = gtk.Button.do_expose_event (self, event)
+
+ if has_focus:
+ self.set_flags (gtk.HAS_FOCUS)
diff --git a/x11-misc/ccsm/metadata.xml b/x11-misc/ccsm/metadata.xml
new file mode 100644
index 00000000000..5c8cd1ca91e
--- /dev/null
+++ b/x11-misc/ccsm/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>desktop-effects@gentoo.org</email>
+ <name>Desktop effects</name>
+</maintainer>
+<longdescription lang="en">Compizconfig Settings Manager.</longdescription>
+</pkgmetadata>