summaryrefslogtreecommitdiff
path: root/x11-misc/dclock
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/dclock
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/dclock')
-rw-r--r--x11-misc/dclock/Manifest2
-rw-r--r--x11-misc/dclock/dclock-2.2.2_p4-r1.ebuild71
-rw-r--r--x11-misc/dclock/dclock-2.2.2_p4.ebuild53
-rw-r--r--x11-misc/dclock/files/dclock-2.2.2_p4-include.patch10
-rw-r--r--x11-misc/dclock/metadata.xml5
5 files changed, 141 insertions, 0 deletions
diff --git a/x11-misc/dclock/Manifest b/x11-misc/dclock/Manifest
new file mode 100644
index 00000000000..b32bb93c9c5
--- /dev/null
+++ b/x11-misc/dclock/Manifest
@@ -0,0 +1,2 @@
+DIST dclock_2.2.2-4.debian.tar.gz 6576 SHA256 259aa8e1d9b0b0ca813285c295246921bedb9ff047db01facbf0a49d4f513f34 SHA512 9b1c61c9ad4ac19b9bd128915ccb846b658ecdad8af8cb7197cef49a75f8e6abefd2375b1814364889af3c29b095cdf8dc1cf40b36683842f1d0a272bd9e188f WHIRLPOOL be9cd64af1390a28aacf9cd48ec602fad1fc9fb2b4fc86673060966559b96611b0e03be229a1b0de10769b3bdd747e9d6b06f30e43b5067cbea9faddc8a91ae7
+DIST dclock_2.2.2.orig.tar.gz 63583 SHA256 d14ebc107b4b837ac3ee79ea639c32d7cec658df653687e665979640cd339c3c SHA512 c43ba031fd0d9ba2bc7e8fe9becc73591bfc47cd4ca931df03fa55207cfb148e24e5d702a7de5af8b67e188c561eae2fb7da14162f6a982d0abbb3251c32372c WHIRLPOOL 5f0dc1acd97c22b42aee274d963f6ddc687d648ab43861a8b862567a37adce036e8e662d5b5dc4aac7e26625d4de019fab85d5005c2a89f27580b8ca494277b5
diff --git a/x11-misc/dclock/dclock-2.2.2_p4-r1.ebuild b/x11-misc/dclock/dclock-2.2.2_p4-r1.ebuild
new file mode 100644
index 00000000000..7560bec1bff
--- /dev/null
+++ b/x11-misc/dclock/dclock-2.2.2_p4-r1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="Digital clock for the X window system"
+HOMEPAGE="http://packages.qa.debian.org/d/dclock.html"
+SRC_URI="mirror://debian/pool/main/d/${PN}/${PN}_${PV/_p*/}.orig.tar.gz
+ mirror://debian/pool/main/d/${PN}/${PN}_${PV/_p/-}.debian.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="xft"
+
+RDEPEND="
+ xft? (
+ media-libs/freetype
+ x11-libs/libXft
+ )
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXt
+"
+DEPEND="
+ ${RDEPEND}
+ app-text/rman
+ x11-misc/imake
+ xft? ( virtual/pkgconfig )
+"
+
+S=${WORKDIR}/${P/_p*/}
+
+src_prepare() {
+ EPATCH_FORCE=yes EPATCH_SUFFIX=diff epatch "${WORKDIR}"/debian/patches
+ epatch "${FILESDIR}"/${P}-include.patch
+}
+
+src_configure() {
+ if use xft; then
+ append-cppflags \
+ -DXFT_SUPPORT \
+ $( $(tc-getPKG_CONFIG) --cflags freetype2)
+ else
+ append-cppflags -UXFT_SUPPORT
+ sed -i -e '/EXTRA_LIBRARIES/s|^|#|g' Imakefile || die
+ fi
+
+ xmkmf || die
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ EXTRA_LDOPTIONS="${LDFLAGS}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install{,.man}
+
+ insinto /usr/share/sounds
+ doins sounds/*
+
+ insinto /usr/share/X11/app-defaults
+ newins Dclock.ad DClock
+
+ dodoc README TODO
+}
diff --git a/x11-misc/dclock/dclock-2.2.2_p4.ebuild b/x11-misc/dclock/dclock-2.2.2_p4.ebuild
new file mode 100644
index 00000000000..ae6ac54df88
--- /dev/null
+++ b/x11-misc/dclock/dclock-2.2.2_p4.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Digital clock for the X window system"
+HOMEPAGE="http://packages.qa.debian.org/d/dclock.html"
+SRC_URI="mirror://debian/pool/main/d/${PN}/${PN}_${PV/_p*/}.orig.tar.gz
+ mirror://debian/pool/main/d/${PN}/${PN}_${PV/_p/-}.debian.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXt"
+DEPEND="${RDEPEND}
+ app-text/rman
+ x11-misc/imake"
+
+S=${WORKDIR}/${P/_p*/}
+
+src_prepare() {
+ EPATCH_FORCE=yes EPATCH_SUFFIX=diff epatch "${WORKDIR}"/debian/patches
+ epatch "${FILESDIR}"/${P}-include.patch
+}
+
+src_configure() {
+ xmkmf || die
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ EXTRA_LDOPTIONS="${LDFLAGS}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install{,.man}
+
+ insinto /usr/share/sounds
+ doins sounds/*
+
+ insinto /usr/share/X11/app-defaults
+ newins Dclock.ad DClock
+
+ dodoc README TODO
+}
diff --git a/x11-misc/dclock/files/dclock-2.2.2_p4-include.patch b/x11-misc/dclock/files/dclock-2.2.2_p4-include.patch
new file mode 100644
index 00000000000..2fbdd884faf
--- /dev/null
+++ b/x11-misc/dclock/files/dclock-2.2.2_p4-include.patch
@@ -0,0 +1,10 @@
+--- dclock.c
++++ dclock.c
+@@ -7,6 +7,7 @@
+ * manager: *Dclock.seconds: on
+ */
+ #include <stdio.h>
++#include <stdlib.h> /* exit() */
+ #include <locale.h>
+ #include <X11/Intrinsic.h>
+ #include "Dclock.h"
diff --git a/x11-misc/dclock/metadata.xml b/x11-misc/dclock/metadata.xml
new file mode 100644
index 00000000000..2518313f524
--- /dev/null
+++ b/x11-misc/dclock/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-misc</herd>
+</pkgmetadata>