summaryrefslogtreecommitdiff
path: root/x11-misc/easystroke
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/easystroke
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/easystroke')
-rw-r--r--x11-misc/easystroke/Manifest1
-rw-r--r--x11-misc/easystroke/easystroke-0.6.0-r1.ebuild63
-rw-r--r--x11-misc/easystroke/easystroke-0.6.0.ebuild59
-rw-r--r--x11-misc/easystroke/files/easystroke-0.6.0-buttons-scroll-send.patch43
-rw-r--r--x11-misc/easystroke/files/easystroke-0.6.0-cellrendertextish.patch20
-rw-r--r--x11-misc/easystroke/files/easystroke-0.6.0-desktop.patch11
-rw-r--r--x11-misc/easystroke/files/easystroke-0.6.0-gentoo.patch41
-rw-r--r--x11-misc/easystroke/files/easystroke-0.6.0-reinstate-signal-handlers.patch42
-rw-r--r--x11-misc/easystroke/metadata.xml8
9 files changed, 288 insertions, 0 deletions
diff --git a/x11-misc/easystroke/Manifest b/x11-misc/easystroke/Manifest
new file mode 100644
index 00000000000..122843bfc16
--- /dev/null
+++ b/x11-misc/easystroke/Manifest
@@ -0,0 +1 @@
+DIST easystroke-0.6.0.tar.gz 121358 SHA256 f4c37adbc4dd405a24badb9e6be20d3223b4087ff9caed2c15ff71674051d0fd SHA512 a74cbdfd2b56e6b20d895297e80fb63f3d8ac938235ecf7067f984d087004af22a5ea0116ae20b948e238b02a06b14044a7025d65840f0c8d00542332387c921 WHIRLPOOL d1305449563d599c5159ebddb2fdc6c17f2e79d8a1ea5186cff9f6785545cb2941413fb498347da8801ac665e20f1aa252270bcc88e93d97111ae253924d7b18
diff --git a/x11-misc/easystroke/easystroke-0.6.0-r1.ebuild b/x11-misc/easystroke/easystroke-0.6.0-r1.ebuild
new file mode 100644
index 00000000000..9e2cf6a6316
--- /dev/null
+++ b/x11-misc/easystroke/easystroke-0.6.0-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="a gesture-recognition application for X11"
+HOMEPAGE="http://sourceforge.net/apps/trac/easystroke/"
+SRC_URI="mirror://sourceforge/project/${PN}/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-cpp/gtkmm:3.0
+ dev-libs/boost
+ dev-libs/dbus-glib
+ dev-libs/glib:2
+ x11-base/xorg-server
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libXtst
+"
+DEPEND="
+ ${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-cellrendertextish.patch
+ epatch "${FILESDIR}"/${P}-desktop.patch
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ epatch "${FILESDIR}"/${P}-reinstate-signal-handlers.patch
+ epatch "${FILESDIR}"/${P}-buttons-scroll-send.patch
+
+ tc-export CC CXX PKG_CONFIG
+
+ if ! [[ -z ${LINGUAS} ]]; then
+ strip-linguas -i po/
+
+ local es_lingua lang
+ for es_lingua in $( printf "%s\n" po/*.po ); do
+ lang=${es_lingua/po\/}
+ has ${lang/.po/} ${LINGUAS} || rm ${es_lingua}
+ done
+ fi
+}
+
+src_compile() {
+ emake \
+ AOFLAGS='' \
+ LDFLAGS="${LDFLAGS}" \
+ PREFIX=/usr
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX=/usr install
+}
diff --git a/x11-misc/easystroke/easystroke-0.6.0.ebuild b/x11-misc/easystroke/easystroke-0.6.0.ebuild
new file mode 100644
index 00000000000..73de92fea6f
--- /dev/null
+++ b/x11-misc/easystroke/easystroke-0.6.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="a gesture-recognition application for X11"
+HOMEPAGE="http://sourceforge.net/apps/trac/easystroke/"
+SRC_URI="mirror://sourceforge/project/${PN}/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ dev-cpp/gtkmm:3.0
+ dev-libs/boost
+ dev-libs/dbus-glib
+ dev-libs/glib:2
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libXtst
+"
+DEPEND="
+ ${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-cellrendertextish.patch
+ epatch "${FILESDIR}"/${P}-desktop.patch
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+
+ tc-export CC CXX PKG_CONFIG
+
+ strip-linguas -i po/
+
+ local es_lingua lang
+ for es_lingua in $( printf "%s\n" po/*.po ); do
+ lang=${es_lingua/po\/}
+ has ${lang/.po/} ${LINGUAS} || rm ${es_lingua}
+ done
+}
+
+src_compile() {
+ emake \
+ AOFLAGS='' \
+ LDFLAGS="${LDFLAGS}" \
+ PREFIX=/usr
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX=/usr install
+}
diff --git a/x11-misc/easystroke/files/easystroke-0.6.0-buttons-scroll-send.patch b/x11-misc/easystroke/files/easystroke-0.6.0-buttons-scroll-send.patch
new file mode 100644
index 00000000000..27bfa4cfee6
--- /dev/null
+++ b/x11-misc/easystroke/files/easystroke-0.6.0-buttons-scroll-send.patch
@@ -0,0 +1,43 @@
+From 5388934e722308cd314d65e362ddfaf6e5ab6c94 Mon Sep 17 00:00:00 2001
+From: Thomas Jaeger <ThJaeger@gmail.com>
+Date: Sat, 13 Apr 2013 14:10:35 -0400
+Subject: Make buttons and scroll work properly with 'send'
+
+---
+ handler.cc | 6 ++++--
+ 1 file changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/handler.cc b/handler.cc
+index f47aae3..c1bd279 100644
+--- a/handler.cc
++++ b/handler.cc
+@@ -545,7 +545,7 @@ class AbstractScrollHandler : public Handler {
+
+ protected:
+ AbstractScrollHandler() : last_t(0), offset_x(0.0), offset_y(0.0) {
+- if (!prefs.move_back.get() || xstate->current_dev->absolute)
++ if (!prefs.move_back.get() || (xstate->current_dev && xstate->current_dev->absolute))
+ return;
+ Window dummy1, dummy2;
+ int dummy3, dummy4;
+@@ -563,7 +563,7 @@ protected:
+ }
+ protected:
+ void move_back() {
+- if (!prefs.move_back.get() || xstate->current_dev->absolute)
++ if (!prefs.move_back.get() || (xstate->current_dev && xstate->current_dev->absolute))
+ return;
+ XTestFakeMotionEvent(dpy, DefaultScreen(dpy), orig_x, orig_y, 0);
+ }
+@@ -1115,6 +1115,8 @@ XState::XState() : current_dev(NULL), in_proximity(false), accepted(true) {
+
+ void XState::run_action(RAction act) {
+ RModifiers mods = act->prepare();
++ IF_BUTTON(act, b)
++ return handler->replace_child(new ButtonHandler(mods, b));
+ if (IS_IGNORE(act))
+ return handler->replace_child(new IgnoreHandler(mods));
+ if (IS_SCROLL(act))
+--
+1.8.4
+
diff --git a/x11-misc/easystroke/files/easystroke-0.6.0-cellrendertextish.patch b/x11-misc/easystroke/files/easystroke-0.6.0-cellrendertextish.patch
new file mode 100644
index 00000000000..8664ed736ba
--- /dev/null
+++ b/x11-misc/easystroke/files/easystroke-0.6.0-cellrendertextish.patch
@@ -0,0 +1,20 @@
+--- a/cellrenderertextish.c
++++ b/cellrenderertextish.c
+@@ -599,7 +599,7 @@
+ _g_free0 (self->priv->path);
+ self->priv->path = _tmp3_;
+ g_signal_connect_object ((GtkCellEditable*) self, "editing-done", (GCallback) _cell_editable_accel_on_editing_done_gtk_cell_editable_editing_done, self, 0);
+- _tmp4_ = _ ("Key combination...");
++ _tmp4_ = ("Key combination...");
+ _tmp5_ = (GtkLabel*) gtk_label_new (_tmp4_);
+ g_object_ref_sink (_tmp5_);
+ label = _tmp5_;
+@@ -907,7 +907,7 @@
+ const gchar* _tmp10_;
+ const gchar* _tmp11_ = NULL;
+ _tmp10_ = item;
+- _tmp11_ = _ (_tmp10_);
++ _tmp11_ = (_tmp10_);
+ gtk_combo_box_text_append_text ((GtkComboBoxText*) self, _tmp11_);
+ _g_free0 (item);
+ }
diff --git a/x11-misc/easystroke/files/easystroke-0.6.0-desktop.patch b/x11-misc/easystroke/files/easystroke-0.6.0-desktop.patch
new file mode 100644
index 00000000000..c9a75a2c4b7
--- /dev/null
+++ b/x11-misc/easystroke/files/easystroke-0.6.0-desktop.patch
@@ -0,0 +1,11 @@
+--- a/easystroke.desktop.in
++++ b/easystroke.desktop.in
+@@ -6,7 +6,7 @@
+ Exec=easystroke
+ Icon=easystroke
+ Categories=GTK;Utility;Accessibility;
+-Actions=About;Enable;Disable;Quit
++Actions=About;Enable;Disable;Quit;
+ _Comment=Control your desktop using mouse gestures
+
+ [Desktop Action About]
diff --git a/x11-misc/easystroke/files/easystroke-0.6.0-gentoo.patch b/x11-misc/easystroke/files/easystroke-0.6.0-gentoo.patch
new file mode 100644
index 00000000000..ee95b21486c
--- /dev/null
+++ b/x11-misc/easystroke/files/easystroke-0.6.0-gentoo.patch
@@ -0,0 +1,41 @@
+--- a/Makefile
++++ b/Makefile
+@@ -19,14 +19,14 @@
+ MENUDIR = $(PREFIX)/share/applications
+ LOCALEDIR= $(PREFIX)/share/locale
+ DFLAGS =
+-OFLAGS = -O2
+-AOFLAGS = -O3
++#OFLAGS = -O2
++#AOFLAGS = -O3
+ STROKEFLAGS = -Wall -std=c99 $(DFLAGS)
+-CXXFLAGS = -Wall $(DFLAGS) -DLOCALEDIR=\"$(LOCALEDIR)\" `pkg-config gtkmm-3.0 dbus-glib-1 --cflags`
+-CFLAGS = -Wall $(DFLAGS) -DLOCALEDIR=\"$(LOCALEDIR)\" `pkg-config gtk+-3.0 --cflags` -DGETTEXT_PACKAGE='"easystroke"'
+-LDFLAGS = $(DFLAGS)
++CXXFLAGS += -Wall $(DFLAGS) -DLOCALEDIR=\"$(LOCALEDIR)\" $(shell $(PKG_CONFIG) gtkmm-3.0 dbus-glib-1 --cflags)
++CFLAGS += -Wall $(DFLAGS) -DLOCALEDIR=\"$(LOCALEDIR)\" $(shell $(PKG_CONFIG) gtk+-3.0 --cflags) -DGETTEXT_PACKAGE='"easystroke"'
++#LDFLAGS = $(DFLAGS)
+
+-LIBS = $(DFLAGS) -lboost_serialization -lX11 -lXext -lXi -lXfixes -lXtst `pkg-config gtkmm-3.0 dbus-glib-1 --libs`
++LIBS = $(DFLAGS) -lboost_serialization -lX11 -lXext -lXi -lXfixes -lXtst $(shell $(PKG_CONFIG) gtkmm-3.0 dbus-glib-1 --libs)
+
+ BINARY = easystroke
+ ICON = easystroke.svg
+@@ -60,7 +60,7 @@
+ include $(DEPFILES)
+
+ $(BINARY): $(OFILES)
+- $(CXX) $(LDFLAGS) -o $@ $(OFILES) $(LIBS)
++ $(CXX) $(CFLAGS) $(LDFLAGS) -o $@ $(OFILES) $(LIBS)
+
+ stroke.o: stroke.c
+ $(CC) $(STROKEFLAGS) $(AOFLAGS) -MT $@ -MMD -MP -MF $*.Po -o $@ -c $<
+@@ -119,7 +119,7 @@
+ help2man -N -n "X11 gesture recognition application" ./$(BINARY) > $@
+
+ install: all
+- install -Ds $(BINARY) $(DESTDIR)$(BINDIR)/$(BINARY)
++ install -D $(BINARY) $(DESTDIR)$(BINDIR)/$(BINARY)
+ install -D -m 644 $(ICON) $(DESTDIR)$(ICONDIR)/$(ICON)
+ install -D -m 644 $(MENU) $(DESTDIR)$(MENUDIR)/$(MENU)
+ for f in $(MOFILES); do \
diff --git a/x11-misc/easystroke/files/easystroke-0.6.0-reinstate-signal-handlers.patch b/x11-misc/easystroke/files/easystroke-0.6.0-reinstate-signal-handlers.patch
new file mode 100644
index 00000000000..2e96346459a
--- /dev/null
+++ b/x11-misc/easystroke/files/easystroke-0.6.0-reinstate-signal-handlers.patch
@@ -0,0 +1,42 @@
+From 7bda4bd9c705413598ee9b534884bc7f23704932 Mon Sep 17 00:00:00 2001
+From: Thomas Jaeger <ThJaeger@gmail.com>
+Date: Thu, 20 Jun 2013 01:45:20 -0400
+Subject: Reinstate signal handlers that got lost in the gtk3 transition
+
+Also, fix a segfault when handling SIGINT.
+---
+ main.cc | 11 ++++++++++-
+ 1 file changed, 10 insertions(+), 1 deletion(-)
+
+diff --git a/main.cc b/main.cc
+index 55d0b3c..8cd9c56 100644
+--- a/main.cc
++++ b/main.cc
+@@ -161,7 +161,12 @@ void quit() {
+ xstate->bail_out();
+ dead = true;
+ win->hide();
+- xstate->queue(sigc::ptr_fun(&Gtk::Main::quit));
++ Glib::RefPtr<Gio::Application> app = Gio::Application::get_default();
++ xstate->queue(sigc::mem_fun(*app.operator->(), &Gio::Application::quit));
++}
++
++void sig_int(int) {
++ quit();
+ }
+
+ class App : public Gtk::Application, Base {
+@@ -371,6 +376,10 @@ void App::on_activate() {
+
+ create_config_dir();
+ unsetenv("DESKTOP_AUTOSTART_ID");
++
++ signal(SIGINT, &sig_int);
++ signal(SIGCHLD, SIG_IGN);
++
+ dpy = XOpenDisplay(NULL);
+ if (!dpy) {
+ printf(_("Couldn't open display.\n"));
+--
+1.8.4
+
diff --git a/x11-misc/easystroke/metadata.xml b/x11-misc/easystroke/metadata.xml
new file mode 100644
index 00000000000..2c734e7ab53
--- /dev/null
+++ b/x11-misc/easystroke/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-misc</herd>
+ <upstream>
+ <remote-id type="sourceforge">easystroke</remote-id>
+ </upstream>
+</pkgmetadata>