summaryrefslogtreecommitdiff
path: root/x11-misc/fluxter
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/fluxter
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/fluxter')
-rw-r--r--x11-misc/fluxter/Manifest1
-rw-r--r--x11-misc/fluxter/files/fluxter-0.1.0-asneeded.patch43
-rw-r--r--x11-misc/fluxter/fluxter-0.1.0.ebuild34
-rw-r--r--x11-misc/fluxter/metadata.xml8
4 files changed, 86 insertions, 0 deletions
diff --git a/x11-misc/fluxter/Manifest b/x11-misc/fluxter/Manifest
new file mode 100644
index 00000000000..2f9ebc86c52
--- /dev/null
+++ b/x11-misc/fluxter/Manifest
@@ -0,0 +1 @@
+DIST fluxter-0.1.0.tar.gz 99522 SHA256 e2dc2c18e0a5299feac44facfc4748e92453e916b7b991fe79d00ae9c460e137
diff --git a/x11-misc/fluxter/files/fluxter-0.1.0-asneeded.patch b/x11-misc/fluxter/files/fluxter-0.1.0-asneeded.patch
new file mode 100644
index 00000000000..8b68260741e
--- /dev/null
+++ b/x11-misc/fluxter/files/fluxter-0.1.0-asneeded.patch
@@ -0,0 +1,43 @@
+--- Makefile.am
++++ Makefile.am
+@@ -17,4 +17,4 @@
+ NETInterface.cc NETInterface.hh \
+ blackboxstyle.hh
+ EXTRA_DIST = BUGS TODO
+-fluxter_LDADD = @X_LIBS@
++fluxter_LDADD = @LIBS@
+--- configure.in
++++ configure.in
+@@ -18,14 +18,12 @@
+ [
+ test "$CFLAGS" = "" && CFLAGS="-g -Wall -DDEBUG"
+ test "$CXXFLAGS" = "" && CXXFLAGS="-g -Wall -DDEBUG"
+- test "$LDFLAGS" = "" && LDFLAGS=""
+ ])
+
+ AC_DEFUN(AC_SET_NODEBUG,
+ [
+- test "$CFLAGS" = "" && CFLAGS="-O2 -Wall"
+- test "$CXXFLAGS" = "" && CXXFLAGS="-O2 -Wall"
+- test "$LDFLAGS" = "" && LDFLAGS="-s"
++ test "$CFLAGS" = "" && CFLAGS="-Wall"
++ test "$CXXFLAGS" = "" && CXXFLAGS="-Wall"
+ ])
+
+
+@@ -71,12 +69,12 @@
+
+ CFLAGS="$CFLAGS $X_CFLAGS"
+ CXXFLAGS="$CXXFLAGS $X_CFLAGS"
+-LDFLAGS="$LDFLAGS $X_LIBS $X_PRE_LIBS"
++LIBS="$LIBS $X_LIBS $X_PRE_LIBS"
+ dnl Checks for X libraries.
+-AC_CHECK_LIB(X11, XOpenDisplay, LDFLAGS="$LDFLAGS -lX11",
++AC_CHECK_LIB(X11, XOpenDisplay, LIBS="$LIBS -lX11",
+ AC_MSG_ERROR(XOpenDisplay not found in -lX11))
+
+-LDFLAGS="$LDFLAGS $X_EXTRA_LIBS"
++LIBS="$LIBS $X_EXTRA_LIBS"
+
+ dnl Checks for header files.
+ AC_HEADER_STDC
diff --git a/x11-misc/fluxter/fluxter-0.1.0.ebuild b/x11-misc/fluxter/fluxter-0.1.0.ebuild
new file mode 100644
index 00000000000..821fe277d84
--- /dev/null
+++ b/x11-misc/fluxter/fluxter-0.1.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit autotools eutils
+
+DESCRIPTION="workspace pager dockapp, particularly useful with the Fluxbox window manager"
+HOMEPAGE="http://www.isomedia.com/homes/stevencooper"
+SRC_URI="http://www.isomedia.com/homes/stevencooper/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 hppa ppc x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="x11-libs/libX11
+ x11-libs/libSM
+ x11-libs/libICE"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-asneeded.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --datadir=/usr/share/commonbox
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS BUGS ChangeLog README TODO
+}
diff --git a/x11-misc/fluxter/metadata.xml b/x11-misc/fluxter/metadata.xml
new file mode 100644
index 00000000000..1402a60126f
--- /dev/null
+++ b/x11-misc/fluxter/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>pchrist@gentoo.org</email>
+ <name>Panagiotis Christopoulos</name>
+</maintainer>
+</pkgmetadata>