summaryrefslogtreecommitdiff
path: root/x11-misc/fraqtive
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/fraqtive
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/fraqtive')
-rw-r--r--x11-misc/fraqtive/Manifest2
-rw-r--r--x11-misc/fraqtive/fraqtive-0.4.7.ebuild72
-rw-r--r--x11-misc/fraqtive/fraqtive-0.4.8.ebuild72
-rw-r--r--x11-misc/fraqtive/metadata.xml8
4 files changed, 154 insertions, 0 deletions
diff --git a/x11-misc/fraqtive/Manifest b/x11-misc/fraqtive/Manifest
new file mode 100644
index 00000000000..fd495f688ec
--- /dev/null
+++ b/x11-misc/fraqtive/Manifest
@@ -0,0 +1,2 @@
+DIST fraqtive-0.4.7.tar.bz2 259933 SHA256 f280ada46b1d91859747e7ba6d53aee3ffbb5c3cba803a0b6ffbc155d9e70d72 SHA512 7298be12b67f87f1a0249ea76319360af1477053cb1def67541f362f4e0bd72ee1c13ad1d98cbf4e155f4a1c8509b2553c39e5f4a585b91b53da2b64160d1f0c WHIRLPOOL 251cb00314abb12b053e4b752ba3647305b1609c530ff79d53f711cc4397459d7bdb720ca32f0e6608018c56d059a6a43e9f02b636aab8088f6dc7ed027f9d0b
+DIST fraqtive-0.4.8.tar.bz2 260484 SHA256 dbb21b5e6305cbf02c27aaedb12c5125ac873600bce10d12e88b2305a2083cd7 SHA512 8b4be81dd14fe086dbcffda123395ccb30a197e7762e590bc3ab7dc1d0aafb44dc45e1445e2f83198a0c1f4b9ea0d54a7de1989c3b85c0f2e5f474a67255d942 WHIRLPOOL 29bfc8574d63ac6e77c36531e1dd9aa63810af12e6669f8248c364f6dd42088ac1418cdce6c1b760dc922bbded65b148e0079f8c56df69e27f42b093212ee7c3
diff --git a/x11-misc/fraqtive/fraqtive-0.4.7.ebuild b/x11-misc/fraqtive/fraqtive-0.4.7.ebuild
new file mode 100644
index 00000000000..0fa608e01b2
--- /dev/null
+++ b/x11-misc/fraqtive/fraqtive-0.4.7.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils gnome2-utils qmake-utils toolchain-funcs
+
+DESCRIPTION="an open source, multi-platform generator of the Mandelbrot family fractals"
+HOMEPAGE="http://fraqtive.mimec.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="qt5 cpu_flags_x86_sse2"
+
+RDEPEND="
+ !qt5? (
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qtopengl:4
+ )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtopengl:5
+ )
+ virtual/glu
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_configure() {
+ tc-export PKG_CONFIG
+ sed -i -e "s|-lGLU|$( ${PKG_CONFIG} --libs glu )|g" src/src.pro || die
+ local conf="release"
+
+ if use cpu_flags_x86_sse2; then
+ conf="$conf sse2"
+ else
+ conf="$conf no-sse2"
+ fi
+
+ echo "CONFIG += $conf" > "${S}"/config.pri
+ echo "PREFIX = ${EPREFIX}/usr" >> "${S}"/config.pri
+ # Don't strip wrt #252096
+ echo "QMAKE_STRIP =" >> "${S}"/config.pri
+
+ if use qt5; then
+ eqmake5
+ else
+ eqmake4
+ fi
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/x11-misc/fraqtive/fraqtive-0.4.8.ebuild b/x11-misc/fraqtive/fraqtive-0.4.8.ebuild
new file mode 100644
index 00000000000..0fa608e01b2
--- /dev/null
+++ b/x11-misc/fraqtive/fraqtive-0.4.8.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils gnome2-utils qmake-utils toolchain-funcs
+
+DESCRIPTION="an open source, multi-platform generator of the Mandelbrot family fractals"
+HOMEPAGE="http://fraqtive.mimec.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="qt5 cpu_flags_x86_sse2"
+
+RDEPEND="
+ !qt5? (
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qtopengl:4
+ )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtopengl:5
+ )
+ virtual/glu
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_configure() {
+ tc-export PKG_CONFIG
+ sed -i -e "s|-lGLU|$( ${PKG_CONFIG} --libs glu )|g" src/src.pro || die
+ local conf="release"
+
+ if use cpu_flags_x86_sse2; then
+ conf="$conf sse2"
+ else
+ conf="$conf no-sse2"
+ fi
+
+ echo "CONFIG += $conf" > "${S}"/config.pri
+ echo "PREFIX = ${EPREFIX}/usr" >> "${S}"/config.pri
+ # Don't strip wrt #252096
+ echo "QMAKE_STRIP =" >> "${S}"/config.pri
+
+ if use qt5; then
+ eqmake5
+ else
+ eqmake4
+ fi
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/x11-misc/fraqtive/metadata.xml b/x11-misc/fraqtive/metadata.xml
new file mode 100644
index 00000000000..4e66ecce0fd
--- /dev/null
+++ b/x11-misc/fraqtive/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-misc</herd>
+ <upstream>
+ <remote-id type="sourceforge">fraqtive</remote-id>
+ </upstream>
+</pkgmetadata>