summaryrefslogtreecommitdiff
path: root/x11-misc/idesk-extras
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/idesk-extras
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/idesk-extras')
-rw-r--r--x11-misc/idesk-extras/Manifest1
-rw-r--r--x11-misc/idesk-extras/files/idesk-extras-1.37-stdout.patch112
-rw-r--r--x11-misc/idesk-extras/idesk-extras-1.37-r1.ebuild33
-rw-r--r--x11-misc/idesk-extras/metadata.xml7
4 files changed, 153 insertions, 0 deletions
diff --git a/x11-misc/idesk-extras/Manifest b/x11-misc/idesk-extras/Manifest
new file mode 100644
index 00000000000..85e891506a4
--- /dev/null
+++ b/x11-misc/idesk-extras/Manifest
@@ -0,0 +1 @@
+DIST idesk-extras-1.37.tar.xz 424684 SHA256 8e0bd7011706685810940adabd9f284e33212971a629f81f693322342a958a68 SHA512 a64ced6bd46945949a0bdbcef8a1f142d6fa2f50e4776f5eead9581430d5ef17d41fbd2a05e284f25cc23c2d2b948d02f2d5d0f51217d43958f40949255b6a28 WHIRLPOOL a688a6d923519dc1e48a904327119c9c5d287759c1cd7cca3fe356b2c29127e38d334a0aab87cd84b886c7d3174ff4cf8b7a0335a16c41b7a79648a4631d0acd
diff --git a/x11-misc/idesk-extras/files/idesk-extras-1.37-stdout.patch b/x11-misc/idesk-extras/files/idesk-extras-1.37-stdout.patch
new file mode 100644
index 00000000000..d827184ff9a
--- /dev/null
+++ b/x11-misc/idesk-extras/files/idesk-extras-1.37-stdout.patch
@@ -0,0 +1,112 @@
+From b8e096f75c9a2fb3a5f02146f0e52ccae796aa87 Mon Sep 17 00:00:00 2001
+From: hasufell <hasufell@gentoo.org>
+Date: Sun, 6 Oct 2013 14:39:02 +0200
+Subject: [PATCH] use stdout to avoid broken tmp files
+
+e.g. fontconfig errors will break parsing
+---
+ idesktool | 28 ++++++++++++++--------------
+ 1 file changed, 14 insertions(+), 14 deletions(-)
+
+diff --git a/idesktool b/idesktool
+index 931ad6f..90e5ceb 100755
+--- a/idesktool
++++ b/idesktool
+@@ -88,10 +88,10 @@ end" > ~/.ideskrc
+ newcaption()
+ {
+
+-$DIALOG --wizard --title "idesktool 1.36" \
++$DIALOG --stdout --wizard --title "idesktool 1.36" \
+ --inputbox "Icon Caption:\n
+ (Leave blank for no caption)"\
+- 8 40 "$cap" 2> ~/.idesktop/inputbox.tmp.$$
++ 8 40 "$cap" 1> ~/.idesktop/inputbox.tmp.$$
+ retval=$?
+ case $retval in
+ 0) cap=$(cat ~/.idesktop/inputbox.tmp.$$)
+@@ -132,10 +132,10 @@ modcaption=NoCaption$$
+ fi
+
+
+-$DIALOG --wizard --title "idesktool 1.36" \
++$DIALOG --stdout --wizard --title "idesktool 1.36" \
+ --separate-output --2inputsbox "NOTE: The default right-click command \n
+ runs this configuration tool (recommended)."\
+- 18 40 "Left-Click Command:" "$command" "Right-Click Command:" "idesktool $modcaption.lnk" 2> ~/.idesktop/inputbox.tmp.$$
++ 18 40 "Left-Click Command:" "$command" "Right-Click Command:" "idesktool $modcaption.lnk" 1> ~/.idesktop/inputbox.tmp.$$
+ retval=$?
+
+ case $retval in
+@@ -187,10 +187,10 @@ modifycaption()
+
+ {
+
+-$DIALOG --wizard --title "idesktool 1.36" \
++$DIALOG --stdout --wizard --title "idesktool 1.36" \
+ --inputbox "Icon Caption:\n
+ (Leave blank for no caption)"\
+- 8 40 "$currentcaption" 2> ~/.idesktop/inputbox.tmp.$$
++ 8 40 "$currentcaption" 1> ~/.idesktop/inputbox.tmp.$$
+ retval=$?
+ case $retval in
+ 0) cap=$(cat ~/.idesktop/inputbox.tmp.$$)
+@@ -235,10 +235,10 @@ modcaption=NoCaption$$
+ fi
+
+
+-$DIALOG --wizard --title "idesktool 1.36" \
++$DIALOG --stdout --wizard --title "idesktool 1.36" \
+ --separate-output --2inputsbox "NOTE: The default right-click command \n
+ runs this configuration tool (recommended)."\
+- 18 40 "Left-Click Command:" "$command" "Right-Click Command:" "idesktool $modcaption.lnk" 2> ~/.idesktop/inputbox.tmp.$$
++ 18 40 "Left-Click Command:" "$command" "Right-Click Command:" "idesktool $modcaption.lnk" 1> ~/.idesktop/inputbox.tmp.$$
+ retval=$?
+ case $retval in
+ 1) rm -f ~/.idesktop/inputbox.tmp.$$
+@@ -423,13 +423,13 @@ argyyep()
+
+ firstwindow=argyyep
+
+-$DIALOG --title "idesktool 1.36" \
++$DIALOG --stdout --title "idesktool 1.36" \
+ --radiolist "Desktop Icon Manager" 18 40 0 \
+ "Properties" "View or Edit This Icon" off \
+ "Delete" " Remove This Icon" off \
+ "New" " Add a New Icon" off \
+ "Refresh" " Reload the Desktop" off \
+- "Configure" " Edit iDesk's conf. file" off 2> ~/.idesktop/checklist.tmp.$$
++ "Configure" " Edit iDesk's conf. file" off 1> ~/.idesktop/checklist.tmp.$$
+
+ retval=$?
+
+@@ -469,13 +469,13 @@ argynope()
+
+ firstwindow=argynope
+
+-$DIALOG --title "idesktool 1.36" \
++$DIALOG --stdout --title "idesktool 1.36" \
+ --radiolist "Desktop Icon Manager" 18 40 0 \
+ "Properties" "View or Edit an Icon" off \
+ "Delete" " Remove an Icon" off \
+ "New" " Add a new Icon" off \
+ "Refresh" " Reload the Desktop" off \
+- "Configure" " Edit iDesk's conf. file" off 2> ~/.idesktop/checklist.tmp.$$
++ "Configure" " Edit iDesk's conf. file" off 1> ~/.idesktop/checklist.tmp.$$
+ retval=$?
+
+ case $retval in
+@@ -511,8 +511,8 @@ esac
+ ##########################################################
+ editconfig()
+ {
+-Xdialog --title "iDesk Configuration" --fixed-font "" \
+- --editbox ~/.ideskrc 0 0 2> ~/.idesktop/editbox.txt.$$
++Xdialog --stdout --title "iDesk Configuration" --fixed-font "" \
++ --editbox ~/.ideskrc 0 0 1> ~/.idesktop/editbox.txt.$$
+
+ case $? in
+ 0) cat ~/.idesktop/editbox.txt.$$ > ~/.ideskrc
+--
+1.8.3.2
+
diff --git a/x11-misc/idesk-extras/idesk-extras-1.37-r1.ebuild b/x11-misc/idesk-extras/idesk-extras-1.37-r1.ebuild
new file mode 100644
index 00000000000..c9208922335
--- /dev/null
+++ b/x11-misc/idesk-extras/idesk-extras-1.37-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Graphical configuration for iDesk plus icons"
+HOMEPAGE="http://www.jmurray.id.au/idesk-extras.html" # dead?
+SRC_URI="http://dev.gentoo.org/~hasufell/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="app-shells/bash
+ x11-misc/idesk
+ x11-misc/xdialog"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-stdout.patch
+}
+
+src_install() {
+ dobin idesktool
+ dodoc CHANGES
+ dohtml ${PN}.html
+
+ insinto /usr/share/idesk
+ doins -r icons
+}
diff --git a/x11-misc/idesk-extras/metadata.xml b/x11-misc/idesk-extras/metadata.xml
new file mode 100644
index 00000000000..91f4e72fb54
--- /dev/null
+++ b/x11-misc/idesk-extras/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>