summaryrefslogtreecommitdiff
path: root/x11-misc/netwmpager
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/netwmpager
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/netwmpager')
-rw-r--r--x11-misc/netwmpager/Manifest1
-rw-r--r--x11-misc/netwmpager/files/netwmpager-1.11-desktop-switch.patch10
-rw-r--r--x11-misc/netwmpager/metadata.xml10
-rw-r--r--x11-misc/netwmpager/netwmpager-2.04.ebuild39
4 files changed, 60 insertions, 0 deletions
diff --git a/x11-misc/netwmpager/Manifest b/x11-misc/netwmpager/Manifest
new file mode 100644
index 00000000000..653e3e0eca0
--- /dev/null
+++ b/x11-misc/netwmpager/Manifest
@@ -0,0 +1 @@
+DIST netwmpager-2.04.tar.bz2 175696 SHA256 d1507ad1d79e9d4a8ff00ed9fbb7e909798956d45b562ddfb690ebc0ab8a96f6 SHA512 06e42bdb1cba862faa50716962c7711f04350146c524f7699086335c491c564b4079ebab423932efa5eea757facf5471c60b787dea4c4a73e02574fafab1259e WHIRLPOOL a40ffda11940a1fb814d180a1cb7de8339a4a9ab113c0f9a3196db88909739f4de29c99f4a904c93d80e37503329c6b1e6713d9949a781127ca47cec2a2c7de9
diff --git a/x11-misc/netwmpager/files/netwmpager-1.11-desktop-switch.patch b/x11-misc/netwmpager/files/netwmpager-1.11-desktop-switch.patch
new file mode 100644
index 00000000000..bc4abda5a0e
--- /dev/null
+++ b/x11-misc/netwmpager/files/netwmpager-1.11-desktop-switch.patch
@@ -0,0 +1,10 @@
+--- pager.c 2006-04-15 21:14:55.000000000 +0200
++++ pager.c 2008-04-02 18:10:43.000000000 +0200
+@@ -1137,6 +1137,7 @@
+ if (pager->mouse.window_idx == -1) {
+ x_set_current_desktop(desk);
+ } else if (!pager->mouse.dragging) {
++ x_set_current_desktop(desk);
+ x_set_active_window(pager->windows[pager->mouse.window_idx].window, SOURCE_INDICATION_PAGER);
+ }
+ } else if (button == 2) {
diff --git a/x11-misc/netwmpager/metadata.xml b/x11-misc/netwmpager/metadata.xml
new file mode 100644
index 00000000000..402a82e8c6d
--- /dev/null
+++ b/x11-misc/netwmpager/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">sf-xpaint</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-misc/netwmpager/netwmpager-2.04.ebuild b/x11-misc/netwmpager/netwmpager-2.04.ebuild
new file mode 100644
index 00000000000..7ea67cf0e46
--- /dev/null
+++ b/x11-misc/netwmpager/netwmpager-2.04.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit toolchain-funcs
+
+DESCRIPTION="EWMH (NetWM) compatible pager. Works with Openbox and other EWMH
+compliant window managers."
+HOMEPAGE="http://sourceforge.net/projects/sf-xpaint/files/netwmpager/"
+SRC_URI="mirror://sourceforge/sf-xpaint/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXrender
+ x11-libs/libXft
+ x11-libs/libXdmcp
+ x11-libs/libXau"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ x11-proto/xproto"
+
+src_configure() {
+ # econf doesn't work
+ tc-export CC
+ ./configure --prefix=/usr || die
+
+}
+
+src_install () {
+ default
+
+ dodoc Changelog
+}