summaryrefslogtreecommitdiff
path: root/x11-misc/obmenu-generator
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/obmenu-generator
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/obmenu-generator')
-rw-r--r--x11-misc/obmenu-generator/Manifest1
-rw-r--r--x11-misc/obmenu-generator/metadata.xml13
-rw-r--r--x11-misc/obmenu-generator/obmenu-generator-0.61.ebuild33
3 files changed, 47 insertions, 0 deletions
diff --git a/x11-misc/obmenu-generator/Manifest b/x11-misc/obmenu-generator/Manifest
new file mode 100644
index 00000000000..2b1fb1aa44c
--- /dev/null
+++ b/x11-misc/obmenu-generator/Manifest
@@ -0,0 +1 @@
+DIST obmenu-generator-0.61.tar.gz 19371 SHA256 37a5df166675a71ca8b700709d73b76f38a5e600cb04f8b6e9183fb6bd08cd5f SHA512 0211ca2d84eb78468b4122945efe4ed34fd61822f68a5797c29f9a59d7bd80dc90df6b0602fff3a62476a8e435eb6deb23b0caf9e0e6036d2294228b62b77b9b WHIRLPOOL 7aa48dc3c2ddb5d93c71d37be1870e8565be2cb78ca4af1d3286fc12e533c8de36342a1a8d5ab55a0999dd10b996442617bda114c5dd446cb45b64b37bf17ceb
diff --git a/x11-misc/obmenu-generator/metadata.xml b/x11-misc/obmenu-generator/metadata.xml
new file mode 100644
index 00000000000..f28aa89d791
--- /dev/null
+++ b/x11-misc/obmenu-generator/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <maintainer status="active">
+ <email>trizenx@gmail.com</email>
+ </maintainer>
+ <remote-id type="github">trizen/obmenu-generator</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-misc/obmenu-generator/obmenu-generator-0.61.ebuild b/x11-misc/obmenu-generator/obmenu-generator-0.61.ebuild
new file mode 100644
index 00000000000..f490bc94fce
--- /dev/null
+++ b/x11-misc/obmenu-generator/obmenu-generator-0.61.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="A fast pipe/static menu generator for the Openbox Window Manager"
+HOMEPAGE="http://trizen.go.ro/"
+SRC_URI="https://github.com/trizen/obmenu-generator/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-lang/perl
+ dev-perl/Data-Dump
+ >=dev-perl/Linux-DesktopFiles-0.90.0
+ x11-wm/openbox
+"
+
+src_install() {
+ dobin ${PN}
+ insinto /etc/xdg/obmenu-generator
+ doins schema.pl
+ newdoc README.md README
+}
+
+pkg_postinst() {
+ elog "No docs, run 'obmenu-generator -h' for help."
+ elog "Config file will be created at"
+ elog "~/.config/${PN}/config.pl"
+}