summaryrefslogtreecommitdiff
path: root/x11-misc/openbox-menu/files
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/openbox-menu/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/openbox-menu/files')
-rw-r--r--x11-misc/openbox-menu/files/openbox-menu-0.5.0-build.patch81
1 files changed, 81 insertions, 0 deletions
diff --git a/x11-misc/openbox-menu/files/openbox-menu-0.5.0-build.patch b/x11-misc/openbox-menu/files/openbox-menu-0.5.0-build.patch
new file mode 100644
index 00000000000..5750e982be1
--- /dev/null
+++ b/x11-misc/openbox-menu/files/openbox-menu-0.5.0-build.patch
@@ -0,0 +1,81 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Wed Aug 21 14:26:38 UTC 2013
+Subject: several QA fixes
+
+--- a/Makefile
++++ b/Makefile
+@@ -1,17 +1,27 @@
+-LIBS= `pkg-config --libs glib-2.0 gtk+-2.0 libmenu-cache`
+-CFLAGS+= -g -Wall `pkg-config --cflags glib-2.0 gtk+-2.0 libmenu-cache`
+-CC=gcc
++CC ?= gcc
++PKG_CONFIG ?= pkg-config
++
++CFLAGS ?= -O2 -g
++CFLAGS += -Wall $(shell $(PKG_CONFIG) --cflags glib-2.0 gtk+-2.0 libmenu-cache)
++LIBS += $(shell $(PKG_CONFIG) --libs glib-2.0 gtk+-2.0 libmenu-cache)
+ #-DG_DISABLE_DEPRECATED
+
+-# Comment this line if you don't want icons to appear in menu
+-CFLAGS+=-DWITH_ICONS
+-# Uncomment this line if Openbox can display SVG icons
+-# Check SVG support with '$ ldd /usr/bin/openbox | grep svg', librsvg must appear..
+-# CFLAGS+=-DWITH_SVG
+-
+-prefix= /usr/local
+-DESTDIR ?= $(prefix)
+-BINDIR= ${DESTDIR}/bin
++# set to 0 to turn off icons in menus
++ICONS=1
++
++# set to 0 to turn off svg icons in menus
++SVG_ICONS=1
++
++ifeq ($(SVG_ICONS),1)
++CPPFLAGS += -DWITH_SVG
++endif
++
++ifeq ($(ICONS),1)
++CPPFLAGS += -DWITH_ICONS
++endif
++
++prefix = /usr
++BINDIR = ${prefix}/bin
+
+ SRC= $(shell ls *.c 2> /dev/null)
+ OBJ= $(SRC:.c=.o)
+@@ -19,26 +29,29 @@
+ all: $(OBJ) openbox-menu
+
+ %.o: %.c
+- $(CC) $(CFLAGS) -c $< -o $@
++ $(CC) $(CFLAGS) $(CPPFLAGS) -c $< -o $@
+
+ openbox-menu: $(OBJ)
+- $(CC) $(OBJ) -o openbox-menu $(LDFLAGS) $(LIBS)
++ $(CC) $(CFLAGS) $(OBJ) -o openbox-menu $(LDFLAGS) $(LIBS)
+
+-.PHONY: clean install doc changelog check
++.PHONY: clean install install-strip doc changelog check
+
+ clean:
+ @rm -f *.o openbox-menu
+ @rm -rf doc
+
+ install:
++ @install -Dm 755 openbox-menu "$(DESTDIR)$(BINDIR)/openbox-menu"
++
++install-strip:
+ @strip -s openbox-menu
+- @install -Dm 755 openbox-menu $(BINDIR)/openbox-menu
++ @install -Dm 755 openbox-menu "$(DESTDIR)$(BINDIR)/openbox-menu"
+
+ doc:
+ robodoc --src . --doc doc/ --multidoc --index --html --cmode
+
+ check: openbox-menu
+- ./openbox-menu > test.xml
++ ./openbox-menu > test.xml
+ xmllint test.xml
+ rm test.xml
+