summaryrefslogtreecommitdiff
path: root/x11-misc/ptbatterysystemtray
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/ptbatterysystemtray
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/ptbatterysystemtray')
-rw-r--r--x11-misc/ptbatterysystemtray/Manifest1
-rw-r--r--x11-misc/ptbatterysystemtray/metadata.xml5
-rw-r--r--x11-misc/ptbatterysystemtray/ptbatterysystemtray-1.0.0_rc2.ebuild33
3 files changed, 39 insertions, 0 deletions
diff --git a/x11-misc/ptbatterysystemtray/Manifest b/x11-misc/ptbatterysystemtray/Manifest
new file mode 100644
index 00000000000..29023774ccc
--- /dev/null
+++ b/x11-misc/ptbatterysystemtray/Manifest
@@ -0,0 +1 @@
+DIST ptbatterysystemtray-1.0.0_rc2.tar.gz 234884 SHA256 c28e43e9157df74c7e4599485c24fe8dc79201133c56d7d72f3e4eda5def12f4 SHA512 869eb71032691738277c1ba16b9e8d6e79ab25e8c533c2c12b4a69c6dbfee53d40bb471e4d28ce60b9e3dae19aea166953b5d5641ae0ba873ef55811fdd088e5 WHIRLPOOL 78dd6a7634563abd683ee389ba620fdf6db811df6b0a69773a5d249986ffd381d73f02377a2ae6dd6510e53449c7af4142232a875749a9ea851f391ac9582020
diff --git a/x11-misc/ptbatterysystemtray/metadata.xml b/x11-misc/ptbatterysystemtray/metadata.xml
new file mode 100644
index 00000000000..dc439f7e84f
--- /dev/null
+++ b/x11-misc/ptbatterysystemtray/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>qt</herd>
+</pkgmetadata>
diff --git a/x11-misc/ptbatterysystemtray/ptbatterysystemtray-1.0.0_rc2.ebuild b/x11-misc/ptbatterysystemtray/ptbatterysystemtray-1.0.0_rc2.ebuild
new file mode 100644
index 00000000000..3698bf95acf
--- /dev/null
+++ b/x11-misc/ptbatterysystemtray/ptbatterysystemtray-1.0.0_rc2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit qt4-r2
+
+DESCRIPTION="A simple battery monitor in the system tray"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="
+ dev-qt/qtcore:4
+ dev-qt/qtdbus:4
+ dev-qt/qtgui:4
+"
+RDEPEND="${DEPEND}"
+
+DOCS="AUTHORS ChangeLog README"
+
+src_unpack() {
+ default
+ mv ${PN}-${PN} "${S}" || die
+}
+
+src_configure() {
+ eqmake4 ${PN}.pro INSTALL_PREFIX=/usr
+}